php-db_1.9.2-1_all.deb


Advertisement

Description

php-db - Database Abstraction Layer

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name php-db
Package version 1.9.2
Package release 1
Package architecture all
Package type deb
Installed size 563 B
Download size 69.13 KB
Official Mirror archive.ubuntu.com
DB is a database abstraction layer providing:
* an OO-style query API
* portability features that make programs written for one DBMS work with
other DBMS's
* a DSN (data source name) format for specifying database servers
* prepare/execute (bind) emulation for databases that don't support it
natively
* a result object for each query response
* portable error codes
* sequence emulation
* sequential and non-sequential row fetching as well as bulk fetching
* formats fetched rows as associative arrays, ordered arrays or objects
* row limit support
* transactions support
* table information interface
* DocBook and phpDocumentor API documentation
DB layers itself on top of PHP's existing
database extensions.
Drivers for the following extensions pass
the complete test suite and provide
interchangeability when all of DB's
portability options are enabled:
fbsql, ibase, informix, msql, mssql,
mysql, mysqli, oci8, odbc, pgsql,
sqlite and sybase.
There is also a driver for the dbase
extension, but it can't be used
interchangeably because dbase doesn't
support many standard DBMS features.
DB is compatible with PHP 5 and PHP 7.

Alternatives

Package Version Architecture Repository
php-db_1.9.2-1_all.deb 1.9.2 all Ubuntu Universe
php-db - - -

Requires

Name Value
php-common -
php-pear >= 1.10.0

Download

Type URL
Binary Package php-db_1.9.2-1_all.deb
Source Package php-db

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-db deb package:
    # sudo apt-get install php-db

Files

Path
/usr/share/doc/php-db/changelog.Debian.gz
/usr/share/doc/php-db/copyright
/usr/share/doc/php-db/package.xml.gz
/usr/share/doc/php-db/doc/IDEAS
/usr/share/doc/php-db/doc/MAINTAINERS
/usr/share/doc/php-db/doc/STATUS.gz
/usr/share/doc/php-db/doc/TESTERS.gz
/usr/share/lintian/overrides/php-db
/usr/share/php/DB.php
/usr/share/php/.registry/db.reg
/usr/share/php/DB/common.php
/usr/share/php/DB/dbase.php
/usr/share/php/DB/fbsql.php
/usr/share/php/DB/ibase.php
/usr/share/php/DB/ifx.php
/usr/share/php/DB/msql.php
/usr/share/php/DB/mssql.php
/usr/share/php/DB/mysql.php
/usr/share/php/DB/mysqli.php
/usr/share/php/DB/oci8.php
/usr/share/php/DB/odbc.php
/usr/share/php/DB/pgsql.php
/usr/share/php/DB/sqlite.php
/usr/share/php/DB/storage.php
/usr/share/php/DB/sybase.php

Changelog

2016-03-16 - David Prévot <taffit@debian.org>
php-db (1.9.2-1) unstable; urgency=medium
* Team upload
* New upstream release
* Drop patches
* Simplify get-orig-source target
* Use standard gpg layout
* Use proper team name
* Use proper pkg-php-tools substitutions
* Fix copyright syntax
* Simplify test call
* Provide CI tests
* Update Standards-Version to 3.9.7
* Build with recent pkg-php-tools for the PHP 7.0 transition
2014-08-29 - Thijs Kinkhorst <thijs@debian.org>
php-db (1.7.14-3) unstable; urgency=medium
* Turn off db_error* tests, as they are broken with modern PHP
versions. (Closes: #750287)
* Remove self from uploaders.
* Checked for policy 3.9.5, no changes.
2012-05-22 - Thomas Goirand <zigo@debian.org>
php-db (1.7.14-2) unstable; urgency=low
* Activates build time unit testings.
* Patches unit testings to remove E_STRICT errors.
2012-04-25 - Thomas Goirand <zigo@debian.org>
php-db (1.7.14-1) unstable; urgency=low
* New upstream release 1.7.14
[ Thomas Goirand ]
* Switched the package to Git instead of SVN (changed Vcs fields).
* Replaced debian/svn-deblayout by a debian/gbp.conf.
* Switching to pkg-php-tools (rewrote debian/rules) (Closes: #515327).
* Added myself as uploader.
* Switching to format 3.0 (quilt).
* Increased compat level to 8.
* Removed now useless debian/dirs.
* Removed now useless debian/docs.
* Switched debian/copyright to format 1.0.
* Fixed debian/watch file.
* Adds a patch to declare isError and isManip as static (Closes: #670242).
* Using pkg-php-pear@lists.alioth.debian.org as maintainer (Closes: #656974).
* Removed now obsolete Replaces: php4-pear (<< 4:4.4.0-0) in debian/control.
* Added missing ${misc:Depends} dependency.
* Build-Depends on php-pear (>= 5.4). This probably is too high, but I do
want to express the fact that building in Squeeze wont work without at least
some work (a test showed it wouldn't).
* Bumps Standards-Version to 3.9.3 (no change but the above).
[ Thijs Kinkhorst ]
* Override false-positive spelling-error-in-description Lintian
warning (we mean the PHP module).
2008-01-25 - Thijs Kinkhorst <thijs@debian.org>
php-db (1.7.13-2) unstable; urgency=low
* When using pear during build, we must of course also build-depend
on php-pear (Closes: #462518).
2008-01-20 - Thijs Kinkhorst <thijs@debian.org>
php-db (1.7.13-1) unstable; urgency=low
[ Martin Lohmeier ]
* New upstream release.
+ Fixes parsing of postgresql FETCH (Closes: #357098)
+ Fixes @package_version@ variable (Closes: #384269).
* Updated to PHP License 3.01 as upstream did (Closes: #332608)
* Add debian/watch file.
* Add Vcs-Svn field to debian/control.
* Updated to debhelper 6.
* Updated to standard version 3.7.3.
* Add Homepage to debian/control.
* New build system using PEAR.
[ Thijs Kinkhorst ]
* Even newer upstream release.
* Cleanup packaging.
* Do not install tests, these are not really relevant in the binary
package (Closes: #457437).
* Update package description.
2005-07-29 - Adam Conrad <adconrad@0c3.net>
php-db (1.7.6-2) unstable; urgency=low
* Need to replace php4-pear (<< 4:4.4.0-0), yes the epoch matters.
* Update debian/copyright to make sure the license is correct, the
Debian maintainers are mentioned, the upstream copyright holder
is mentioned and the upstream location is quoted.
* Clean up some lintian warnings about the description and some
scripts that were not made executable.
2005-07-21 - Ondřej Surý <ondrej@sury.org>
php-db (1.7.6-1) unstable; urgency=low
* Initial release.

See Also

Package Description
php-deepcopy_1.6.1-1_all.deb create deep copies (clones) of objects
php-directory-scanner_1.3.2-1_all.deb recursive directory scanner and filter
php-doctrine-annotations_1.2.7-2_all.deb Docblock Annotations Parser - Doctrine component
php-doctrine-bundle_1.7.0-1_all.deb bundle library - Doctrine component
php-doctrine-cache-bundle_1.3.0-4ubuntu1_all.deb cache bundle library - Doctrine component
php-doctrine-cache_1.6.1-1ubuntu1_all.deb cache library - Doctrine component
php-doctrine-collections_1.5.0-1_all.deb Collections Abstraction library - Doctrine component
php-doctrine-common_2.6.1-2_all.deb common extensions for Doctrine
php-doctrine-data-fixtures_1.2.2-1_all.deb Data Fixtures for all Doctrine Object Managers
php-doctrine-dbal_2.5.13-1_all.deb database abstraction layer for Doctrine
php-doctrine-inflector_1.2.0-1_all.deb string manipulations library - Doctrine component
php-doctrine-instantiator_1.0.5-2_all.deb lightweight utility to instantiate objects in PHP
php-doctrine-lexer_1.0.1-4_all.deb base lexer library - Doctrine component
php-doctrine-orm_2.5.4+dfsg-2_all.deb tool for object-relational mapping
php-dompdf_0.6.2+dfsg-3_all.deb HTML to PDF converter
Advertisement
Advertisement