pgcli_1.6.0-1_all.deb


Advertisement

Description

pgcli - CLI for Postgres

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name pgcli
Package version 1.6.0
Package release 1
Package architecture all
Package type deb
Installed size 265 B
Download size 56.54 KB
Official Mirror archive.ubuntu.com
pgcli is a command line interface for PostgreSQL  with
auto-completion and syntax highlighting. The CLI is also capable of pretty
printing tabular data.

Alternatives

Package Version Architecture Repository
pgcli_1.6.0-1_all.deb 1.6.0 all Ubuntu Universe
pgcli - - -

Requires

Name Value
python3-click >= 4.1
python3-configobj >= 5.0.6
python3-humanize >= 0.5.1
python3-pgspecial >= 1.8.0
python3-pkg-resources >= 5.5.1
python3-prompt-toolkit >= 1.0.9
python3-psycopg2 >= 2.6.2
python3-pygments >= 2.0
python3-setproctitle >= 1.1.9
python3-sqlparse >= 0.2.2
python3-wcwidth -
python3:any >= 3.3.2-2~

Download

Type URL
Binary Package pgcli_1.6.0-1_all.deb
Source Package pgcli

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pgcli deb package:
    # sudo apt-get install pgcli

Files

Path
/usr/bin/pgcli
/usr/share/doc/pgcli/changelog.Debian.gz
/usr/share/doc/pgcli/copyright
/usr/share/man/man1/pgcli.1.gz
/usr/share/pgcli/console
/usr/share/pgcli/pgcli/__init__.py
/usr/share/pgcli/pgcli/completion_refresher.py
/usr/share/pgcli/pgcli/config.py
/usr/share/pgcli/pgcli/encodingutils.py
/usr/share/pgcli/pgcli/filters.py
/usr/share/pgcli/pgcli/key_bindings.py
/usr/share/pgcli/pgcli/magic.py
/usr/share/pgcli/pgcli/main.py
/usr/share/pgcli/pgcli/pgbuffer.py
/usr/share/pgcli/pgcli/pgclirc
/usr/share/pgcli/pgcli/pgcompleter.py
/usr/share/pgcli/pgcli/pgexecute.py
/usr/share/pgcli/pgcli/pgstyle.py
/usr/share/pgcli/pgcli/pgtoolbar.py
/usr/share/pgcli/pgcli-1.6.0.egg-info/PKG-INFO
/usr/share/pgcli/pgcli-1.6.0.egg-info/dependency_links.txt
/usr/share/pgcli/pgcli-1.6.0.egg-info/entry_points.txt
/usr/share/pgcli/pgcli-1.6.0.egg-info/pbr.json
/usr/share/pgcli/pgcli-1.6.0.egg-info/requires.txt
/usr/share/pgcli/pgcli-1.6.0.egg-info/top_level.txt
/usr/share/pgcli/pgcli/packages/__init__.py
/usr/share/pgcli/pgcli/packages/expanded.py
/usr/share/pgcli/pgcli/packages/ordereddict.py
/usr/share/pgcli/pgcli/packages/prioritization.py
/usr/share/pgcli/pgcli/packages/sqlcompletion.py
/usr/share/pgcli/pgcli/packages/tabulate.py
/usr/share/pgcli/pgcli/packages/parseutils/__init__.py
/usr/share/pgcli/pgcli/packages/parseutils/ctes.py
/usr/share/pgcli/pgcli/packages/parseutils/meta.py
/usr/share/pgcli/pgcli/packages/parseutils/tables.py
/usr/share/pgcli/pgcli/packages/parseutils/utils.py
/usr/share/pgcli/pgcli/packages/pgliterals/__init__.py
/usr/share/pgcli/pgcli/packages/pgliterals/main.py
/usr/share/pgcli/pgcli/packages/pgliterals/pgliterals.json
/usr/share/python3/runtime.d/pgcli.rtupdate

Changelog

2017-06-30 - Lennart Weller <lhw@ring0.de>
pgcli (1.6.0-1) unstable; urgency=medium
* New upstream release
* Fixes issues with psycopg2 (Closes: #865630)
2017-03-06 - Lennart Weller <lhw@ring0.de>
pgcli (1.4.0-1) unstable; urgency=medium
* New upstream release
2017-01-11 - Lennart Weller <lhw@ring0.de>
pgcli (1.3.1-2) unstable; urgency=medium
* Added pkg-ressources as dependency
2016-11-15 - Lennart Weller <lhw@ring0.de>
pgcli (1.3.1-1) unstable; urgency=medium
* New upstrem release (Closes: #844394)
2016-07-27 - Lennart Weller <lhw@ring0.de>
pgcli (1.1.0-1) unstable; urgency=low
* New upstream release
2016-07-01 - Lennart Weller <lhw@ring0.de>
pgcli (1.0.0-1) unstable; urgency=medium
* Imported new upstream release (Closes: #829021)
* Added python3-humanize dependency
* Updated debian Standards-Version
* Added manpage
* Updated Vcs links
2016-01-19 - Lennart Weller <lhw@ring0.de>
pgcli (0.20.1-3) unstable; urgency=medium
* Merged upstream patch to support prompt_toolkit == 0.57 (Closes: #811478)
* Updated Build-Depends for pgspecial
2015-11-27 - Lennart Weller <lhw@ring0.de>
pgcli (0.20.1-2) unstable; urgency=medium
* Added patch to get pgcli to work with prompt_toolkit >= 0.51
2015-07-31 - Lennart Weller <lhw@ring0.de>
pgcli (0.20.1-1) unstable; urgency=low
* Initial release (Closes: #794250)

See Also

Package Description
pgdbf_0.6.2-1.1_i386.deb converter of XBase / FoxPro tables to PostgreSQL
pglistener_4_all.deb Postgres listener
pgloader_3.4.1+dfsg-1_i386.deb extract, transform and load data into PostgreSQL
pgmodeler-common_0.8.2-1_all.deb pgmodeler's binary independent common files
pgmodeler_0.8.2-1_i386.deb PostgreSQL database modeler GUI interface
pgn-extract_17.21-1_i386.deb Portable Game Notation (PGN) extractor
pgn2web_0.4-1.1build1_i386.deb convert PGN chess game files into webpages
pgpdump_0.31-0.2_i386.deb PGP packet visualizer
pgpgpg_0.13-9.1_i386.deb Wrapper for using GnuPG in programs designed for PGP
pgpool2_3.6.5-1_i386.deb connection pool server and replication proxy for PostgreSQL
pgreplay_1.2.0-2ubuntu1_i386.deb replay PostgreSQL log files
pgtap-doc_0.97.0-2_all.deb Unit testing framework for PostgreSQL - documentation
pgtap_0.97.0-2_all.deb Unit testing framework for PostgreSQL - metapackage
pgtop_3.7.0-2build1_i386.deb PostgreSQL performance monitoring tool akin to top
pgxnclient_1.2.1-3_all.deb command line client for the PostgreSQL Extension Network
Advertisement
Advertisement