pgbouncer_1.7.2-3build1_i386.deb


Advertisement

Description

pgbouncer - lightweight connection pooler for PostgreSQL

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name pgbouncer
Package version 1.7.2
Package release 3build1
Package architecture i386
Package type deb
Installed size 387 B
Download size 162.50 KB
Official Mirror archive.ubuntu.com
PgBouncer is a lightweight connection pooler for PostgreSQL providing the
following features:
* Several levels of brutality when rotating connections: session pooling,
transaction pooling, statement pooling.
* Low memory requirements.
* It is not tied to one backend server, the destination databases
can reside on different hosts.
* Supports online reconfiguration for most of the settings.
* Supports online restart/upgrade.

Alternatives

Package Version Architecture Repository
pgbouncer_1.7.2-3build1_amd64.deb 1.7.2 amd64 Ubuntu Universe
pgbouncer - - -

Requires

Name Value
libc-ares2 >= 1.9.1
libc6 >= 2.8
libevent-2.1-6 >= 2.1.8-stable
libssl1.0.0 >= 1.0.0
lsb-base >= 3.1
postgresql-common >= 26

Download

Type URL
Binary Package pgbouncer_1.7.2-3build1_i386.deb
Source Package pgbouncer

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pgbouncer deb package:
    # sudo apt-get install pgbouncer

Files

Path
/etc/default/pgbouncer
/etc/init.d/pgbouncer
/etc/pgbouncer/pgbouncer.ini
/etc/pgbouncer/userlist.txt
/usr/sbin/pgbouncer
/usr/share/doc/pgbouncer/NEWS.Debian.gz
/usr/share/doc/pgbouncer/NEWS.rst.gz
/usr/share/doc/pgbouncer/README.Debian
/usr/share/doc/pgbouncer/README.rst.gz
/usr/share/doc/pgbouncer/changelog.Debian.gz
/usr/share/doc/pgbouncer/copyright
/usr/share/doc/pgbouncer/examples/pgbouncer.ini.gz
/usr/share/doc/pgbouncer/examples/userlist.txt
/usr/share/man/man1/pgbouncer.1.gz
/usr/share/man/man5/pgbouncer.5.gz
/usr/share/pgbouncer/mkauth.py

Changelog

2017-07-31 - Steve Langasek <steve.langasek@ubuntu.com>
pgbouncer (1.7.2-3build1) artful; urgency=medium
* No-change rebuild against libevent-2.1-6
2017-06-29 - Marco Nenciarini <mnencia@debian.org>
pgbouncer (1.7.2-3) unstable; urgency=medium
[ Christoph Berg ]
* Retire Bernd from Uploaders on his request. Thanks!
[ Marco Nenciarini ]
* Switch DNS backend from evdns2 to c-ares
2016-11-14 - Christoph Berg <christoph.berg@credativ.de>
pgbouncer (1.7.2-2) unstable; urgency=medium
* Build-Depend on libssl1.0-dev. Closes: #828496.
* Build-Depend on ca-certificates to correctly pick up
/etc/ssl/certs/ca-certificates.crt. Closes: #819178.
2016-02-26 - Christoph Berg <christoph.berg@credativ.de>
pgbouncer (1.7.2-1) unstable; urgency=medium
* New upstream version.
+ Fixes online restart. (Though we still don't support it with systemd.)
2016-02-24 - Christoph Berg <christoph.berg@credativ.de>
pgbouncer (1.7.1-2) unstable; urgency=medium
* Set V=1 to get verbose build output.
* Grab patch from libusual upstream to make linking order reproducible.
2016-02-18 - Christoph Berg <myon@debian.org>
pgbouncer (1.7.1-1) unstable; urgency=medium
* New upstream version.
* Disable online restart test, it's broken with systemd (#813487), and
racy otherwise.
2016-01-15 - Christoph Berg <christoph.berg@credativ.de>
pgbouncer (1.7-1) unstable; urgency=medium
* New upstream version with SSL support.  Closes: #810816.
* Start on installation, remove START=0 from /etc/default/pgbouncer.
Closes: #804158.
* Convert d/rules to dh.
2015-09-04 - Christoph Berg <christoph.berg@credativ.de>
pgbouncer (1.6.1-1) unstable; urgency=medium
* Security fix release:
New auth_user functionality introduced in 1.6 allows login as auth_user
when client presents unknown username. It's quite likely auth_user is
superuser. Affects only setups that have enabled auth_user in their
config.
2015-08-26 - Christoph Berg <myon@debian.org>
pgbouncer (1.6-1) unstable; urgency=medium
* New upstream version.
* Support running under different group via RUNASUSER in the init script.
Closes: #768261, thanks to Antti Salmela for the patch.
* Update watch file.
* Note CVE number in last changelog entry.
2015-05-20 - Christoph Berg <myon@debian.org>
pgbouncer (1.5.5-1) unstable; urgency=medium
* New upstream bugfix release.
+ Fix remote crash - invalid packet order causes lookup of NULL pointer.
Not exploitable, just DoS. (CVE-2015-4054)
* Update watch file to point at http://pgbouncer.github.io/downloads/.

See Also

Package Description
pgcli_1.6.0-1_all.deb CLI for Postgres
pgdbf_0.6.2-1.1_i386.deb converter of XBase / FoxPro tables to PostgreSQL
pglistener_4_all.deb Postgres listener
pgloader_3.4.1+dfsg-1_i386.deb extract, transform and load data into PostgreSQL
pgmodeler-common_0.8.2-1_all.deb pgmodeler's binary independent common files
pgmodeler_0.8.2-1_i386.deb PostgreSQL database modeler GUI interface
pgn-extract_17.21-1_i386.deb Portable Game Notation (PGN) extractor
pgn2web_0.4-1.1build1_i386.deb convert PGN chess game files into webpages
pgpdump_0.31-0.2_i386.deb PGP packet visualizer
pgpgpg_0.13-9.1_i386.deb Wrapper for using GnuPG in programs designed for PGP
pgpool2_3.6.5-1_i386.deb connection pool server and replication proxy for PostgreSQL
pgreplay_1.2.0-2ubuntu1_i386.deb replay PostgreSQL log files
pgtap-doc_0.97.0-2_all.deb Unit testing framework for PostgreSQL - documentation
pgtap_0.97.0-2_all.deb Unit testing framework for PostgreSQL - metapackage
pgtop_3.7.0-2build1_i386.deb PostgreSQL performance monitoring tool akin to top
Advertisement
Advertisement