petris_1.0.1-10_i386.deb


Advertisement

Description

petris - Peter's Tetris - a Tetris(TM) clone

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name petris
Package version 1.0.1
Package release 10
Package architecture i386
Package type deb
Installed size 57 B
Download size 17.11 KB
Official Mirror archive.ubuntu.com
Petris supports colours and even features a highscore list.

Alternatives

Package Version Architecture Repository
petris_1.0.1-10_amd64.deb 1.0.1 amd64 Ubuntu Universe
petris - - -

Requires

Name Value
libc6 >= 2.4
libncurses5 >= 6
libtinfo5 >= 6

Download

Type URL
Binary Package petris_1.0.1-10_i386.deb
Source Package petris

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install petris deb package:
    # sudo apt-get install petris

Files

Path
/usr/games/petris
/usr/share/applications/petris.desktop
/usr/share/doc/petris/README.gz
/usr/share/doc/petris/changelog.Debian.gz
/usr/share/doc/petris/copyright
/usr/share/icons/hicolor/128x128/apps/petris-icon.png
/usr/share/man/man6/petris.6.gz
/usr/share/menu/petris
/usr/share/pixmaps/petris-icon.xpm

Changelog

2016-11-14 - Andree Leidenfrost <andree@debian.org>
petris (1.0.1-10) unstable; urgency=low
* Use debian/manpages instead of debian/rules stanza.
* Leave only var/games in debian/dirs - doesn't get created through install.
* Explicitly enabled full hardening in debian/rules to be on the safe side.
* Added XDG desktop support. (Closes: #738002.)
2016-09-08 - Andree Leidenfrost <andree@debian.org>
petris (1.0.1-9) unstable; urgency=low
* Rebuilt package from scratch:
- moved to 3.0 (quilt) format and put changes into separate patches
- simplified rules file
- rewritten postinst & postrm maintainer scripts
- removed spurious files postinst.debhelper & postrm.debhelper'
- added petris.install file
* Increaed standards version to 3.9.8.
* Increased required debhelper version to 9.
* Increased compatibility to 9. (Closes: #817617.)
* Moved ${LIBS} to the end of line for Makefile target 'petris' to fix FTBFS
with 'ld --as-needed'. (Closes: #641575.)
2008-10-03 - Andree Leidenfrost <andree@debian.org>
petris (1.0.1-8) unstable; urgency=low
* Removed hard-coded strip option from install command in rules file. 
(Closes: #437769.)
* Changed menu location to Games/Blocks to be in line with current 
menu policy (version 3.8.0).
* Fixed make clean command in rules file. (Fixes lintian warning.)
* Changed standards version to 3.8.0 with no further changes other 
than the above.
2006-10-03 - Andree Leidenfrost <andree@debian.org>
petris (1.0.1-7) unstable; urgency=low
* Amended copyright file to reflect the fact that there is currently 
no upstream download location.
2006-08-31 - Andree Leidenfrost <andree@debian.org>
petris (1.0.1-6) unstable; urgency=low
* Changed maintainer email address to andree@debian.org.
* Changed standards version from 3.6.2 to 3.7.2 without package
changes. (Fixes lintian warning.)
* Increased package compatibility level to 5 and build-depend on
debhelper >= 5.0 accordingly.
* Removed spurious debian/substvars file. (Fixes lintian warning.)
2006-01-10 - Andree Leidenfrost <aleidenf@bigpond.net.au>
petris (1.0.1-5) unstable; urgency=high
* Integrated fix by Security Team for buffer overflow of environmental
variable when processing highscores. [CVE-2005-3540] (Hence urgency=high.)
* Changed standards version from 3.6.1 to 3.6.2 without package changes.
* Add compat file to avoid warning when building package.
* Install directory under debian is now $package, not tmp - adjust rules
accordingly.
* Initialised 'points.level' in function 'check_lines' (game.c). Avoids
compiler warning.
2004-10-06 - Andree Leidenfrost <aleidenf@bigpond.net.au>
petris (1.0.1-4) unstable; urgency=low
* Fixed compiler warnings.
* Added icon for menu.
* Bumped dephelper version to 4.2.20.
2004-07-06 - Andree Leidenfrost <aleidenf@bigpond.net.au>
petris (1.0.1-3) unstable; urgency=low
* Check outcome of getch() function call to avoid infinite loop in
case hosting terminal dies (Closes: #256265)
2004-06-13 - Andree Leidenfrost <aleidenf@bigpond.net.au>
petris (1.0.1-2) unstable; urgency=low
* Added build dependency for libncurses5-dev (Closes: #253614)
* Changed CFLAGS in rules to turn on debugging symbols using '-g'
* Changed CFLAGS in rules to turn on more extensive warnings using '-W'
* Pass CFLAGS to get make to actually honour the build flags
(thanks Goswin von Brederlow for pointing this out)
* Set architecture to 'any' (fingers crossed)
* Updated standards to 3.6.1 (fixes lintian warning)
* Call petris directly in menu rather than using 'sh -c'
(fixes lintian warning)
* Make sure that /var/games exists by adding it to dirs
2004-04-25 - Andree Leidenfrost <aleidenf@bigpond.net.au>
petris (1.0.1-1) unstable; urgency=low
* Initial Release.

See Also

Package Description
petsc-dev_3.7.6+dfsg1-3build1_all.deb Virtual package depending on latest PETSc development package
petsc3.7.6-doc_3.7.6+dfsg1-3build1_all.deb Documentation and examples for PETSc
pev_0.80-3_i386.deb text-based tool to analyze PE files
pex_1.1.14-2ubuntu2_all.deb library for generating Python executable zip files
pexec_1.0~rc8-3_i386.deb Executing commands in parallel
pfb2t1c2pfb_0.3-11_i386.deb convert pfb into more compressible format and back
pff-tools_20120802-5_i386.deb library to access various ms outlook files formats
pflogsumm_1.1.5-3_all.deb Postfix log entry summarizer
pfm_2.0.8-2_all.deb PostgreSQL graphical client using Tcl/Tk
pforth_21-12_i386.deb portable Forth interpreter
pfqueue_0.5.6-9build1_i386.deb interactive console-based tool to control MTA queues
pfsglview_2.0.6-2_i386.deb command line HDR manipulation programs (OpenGL/GLUT viewer)
pfstmo_2.0.6-2_i386.deb set of tone mapping operators
pfstools_2.0.6-2_i386.deb command line HDR manipulation programs
pfsview_2.0.6-2_i386.deb command line HDR manipulation programs (Qt viewer)
Advertisement
Advertisement