perlqt-dev_4.14.1-0ubuntu9_i386.deb


Advertisement

Description

perlqt-dev - Development files for PerlQt4

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name perlqt-dev
Package version 4.14.1
Package release 0ubuntu9
Package architecture i386
Package type deb
Installed size 391 B
Download size 95.67 KB
Official Mirror archive.ubuntu.com
This package contains the Development files for the Perl Qt Bindings.
This Package is part of the PerlQt module.

Alternatives

Package Version Architecture Repository
perlqt-dev_4.14.1-0ubuntu9_amd64.deb 4.14.1 amd64 Ubuntu Universe
perlqt-dev - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libphonon-perl = 4:4.14.1-0ubuntu9
libqimageblitz-perl = 4:4.14.1-0ubuntu9
libqscintilla-perl = 4:4.14.1-0ubuntu9
libqt3support4-perl = 4:4.14.1-0ubuntu9
libqt4-dbus >= 4:4.5.3
libqt4-xml >= 4:4.5.3
libqtcore4 >= 4:4.8.0
libqtcore4-perl = 4:4.14.1-0ubuntu9
libqtdbus4-perl = 4:4.14.1-0ubuntu9
libqtdeclarative4-perl = 4:4.14.1-0ubuntu9
libqtgui4-perl = 4:4.14.1-0ubuntu9
libqthelp4-perl = 4:4.14.1-0ubuntu9
libqtnetwork4-perl = 4:4.14.1-0ubuntu9
libqtopengl4-perl = 4:4.14.1-0ubuntu9
libqtscript4-perl = 4:4.14.1-0ubuntu9
libqtsql4-perl = 4:4.14.1-0ubuntu9
libqtsvg4-perl = 4:4.14.1-0ubuntu9
libqttest4-perl = 4:4.14.1-0ubuntu9
libqtuitools4-perl = 4:4.14.1-0ubuntu9
libqtxml4-perl = 4:4.14.1-0ubuntu9
libqtxmlpatterns4-perl = 4:4.14.1-0ubuntu9
libstdc++6 >= 5

Download

Type URL
Binary Package perlqt-dev_4.14.1-0ubuntu9_i386.deb
Source Package perlqt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install perlqt-dev deb package:
    # sudo apt-get install perlqt-dev

Files

Path
/usr/bin/prcc4_bin
/usr/bin/qdbusxml2perl
/usr/include/perlqt/QtCore4.h
/usr/include/perlqt/binding.h
/usr/include/perlqt/handlers.h
/usr/include/perlqt/listclass_macros.h
/usr/include/perlqt/marshall.h
/usr/include/perlqt/marshall_basetypes.h
/usr/include/perlqt/marshall_complex.h
/usr/include/perlqt/marshall_macros.h
/usr/include/perlqt/marshall_primitives.h
/usr/include/perlqt/marshall_types.h
/usr/include/perlqt/perlqt.h
/usr/include/perlqt/ppport.h
/usr/include/perlqt/smokehelp.h
/usr/include/perlqt/smokeperl.h
/usr/include/perlqt/util.h
/usr/share/doc/perlqt-dev/README
/usr/share/doc/perlqt-dev/changelog.Debian.gz
/usr/share/doc/perlqt-dev/copyright
/usr/share/perlqt/doxsubpp.pl
/usr/share/perlqt/cmake/FindPerlMore.cmake
/usr/share/perlqt/cmake/PerlQtConfig.cmake
/usr/share/perlqt/cmake/PerlQtExport-debian.cmake
/usr/share/perlqt/cmake/PerlQtExport.cmake

Changelog

2017-07-26 - Matthias Klose <doko@ubuntu.com>
perlqt (4:4.14.1-0ubuntu9) artful; urgency=medium
* No-change rebuild for perl 5.26.0.
2016-10-25 - Iain Lane <iain@orangesquash.org.uk>
perlqt (4:4.14.1-0ubuntu8) zesty; urgency=medium
* debian/patches/0001-Initialize-smokeperl_object-properly.patch:
Cherry-pick from upstream to build with GCC 6.
2015-12-28 - Colin Watson <cjwatson@ubuntu.com>
perlqt (4:4.14.1-0ubuntu7) xenial; urgency=medium
* Remove libqtwebkit4-perl binary package, since WebKit support has been
removed from smokeqt (see https://bugs.debian.org/784528).
2015-12-18 - Colin Watson <cjwatson@ubuntu.com>
perlqt (4:4.14.1-0ubuntu6) xenial; urgency=medium
* Rebuild for Perl 5.22.1.
2015-11-07 - Steve Langasek <steve.langasek@ubuntu.com>
perlqt (4:4.14.1-0ubuntu5) xenial; urgency=medium
* No-change rebuild against libsmokeqttest4-3
2015-08-31 - Matthias Klose <doko@ubuntu.com>
perlqt (4:4.14.1-0ubuntu4) wily; urgency=medium
* No-change rebuild against libsmokeqtcore4-3v5
2015-08-12 - Steve Langasek <steve.langasek@ubuntu.com>
perlqt (4:4.14.1-0ubuntu3) wily; urgency=medium
* No-change rebuild against libsmokeqtcore4-3v5
2014-10-31 - Scott Kitterman <scott@kitterman.com>
perlqt (4:4.14.1-0ubuntu2) vivid; urgency=medium
* Add debian/patches/additionalperl5.20.diff from upstream to complete
Perl 5.20 compatibility fixes
2014-09-22 - Scarlett Clark <sgclark@kubuntu.org>
perlqt (4:4.14.1-0ubuntu1) utopic; urgency=medium
* New upstream release 
* Add back perl5.20.diff patch needed for kdeperl build. 
2014-08-21 - Colin Watson <cjwatson@ubuntu.com>
perlqt (4:4.14.0-0ubuntu3) utopic; urgency=medium
* Adjust *.install to handle vendorarch change in Perl 5.20.  Requires
debhelper 9 for executable configuration files.

See Also

Package Description
perlrdf_0.004-3_all.deb RDF command line utils
perltidy_20140328-2_all.deb Perl script indenter and reformatter
perm_0.4.0-3_i386.deb efficient mapping of short reads with periodic spaced seeds
persistent-cache-cpp-dev_1.0.4+16.10.20160823-0ubuntu3_i386.deb Cache of key-value pairs with persistent storage for C++ 11
persistent-cache-cpp-doc_1.0.4+16.10.20160823-0ubuntu3_all.deb Documentation for persistent-cache-cpp-dev
pescetti_0.5-2_all.deb Bridge Pseudo-duplimate generator
pesign_0.112-4_i386.deb Signing utility for UEFI binaries
petit_1.1.1-1_all.deb log analysis tool for syslog, apache and raw log files
petitboot-twin_13.05.29.14.00-g4dc604b-1ubuntu1_i386.deb Twin GUI version of petitboot, a kexec based bootloader
petitboot_13.05.29.14.00-g4dc604b-1ubuntu1_i386.deb ncurses version of petitboot, a kexec based bootloader
petname_2.7-0ubuntu1_all.deb generate pronouncable, perhaps even memorable, pet names
petri-foo_0.1.87-4_i386.deb MIDI controllable audio sampler - successor of specimen
petris_1.0.1-10_i386.deb Peter's Tetris - a Tetris(TM) clone
petsc-dev_3.7.6+dfsg1-3build1_all.deb Virtual package depending on latest PETSc development package
petsc3.7.6-doc_3.7.6+dfsg1-3build1_all.deb Documentation and examples for PETSc
Advertisement
Advertisement