perlbrew_0.78-1_all.deb


Advertisement

Description

perlbrew - script to manage perl installations in your $HOME

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name perlbrew
Package version 0.78
Package release 1
Package architecture all
Package type deb
Installed size 141 B
Download size 43.69 KB
Official Mirror archive.ubuntu.com
perlbrew is a program to automate the building and installation of perl
in the users HOME. At the moment, it installs everything to ~/perl5/perlbrew,
and requires you to tweak your PATH by including a bashrc/cshrc file it
provides, in your shell configuration file. You then can benefit from not
having to run 'sudo' commands to install cpan modules because those are
installed inside your HOME too. It's a completely separate perl environment.

Alternatives

Package Version Architecture Repository
perlbrew_0.78-1_all.deb 0.78 all Ubuntu Universe
perlbrew - - -

Requires

Name Value
curl -
gcc -
libc-dev -
libc6-dev -
libcapture-tiny-perl >= 0.36
libcpan-perl-releases-perl >= 2.60
libdevel-patchperl-perl >= 1.40
liblocal-lib-perl >= 2.000014
make -
perl >= 5.23.7
wget -

Download

Type URL
Binary Package perlbrew_0.78-1_all.deb
Source Package perlbrew

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install perlbrew deb package:
    # sudo apt-get install perlbrew

Files

Path
/usr/bin/perlbrew
/usr/share/doc/perlbrew/changelog.Debian.gz
/usr/share/doc/perlbrew/copyright
/usr/share/man/man1/perlbrew.1p.gz
/usr/share/man/man3/App::perlbrew.3pm.gz
/usr/share/perl5/App/perlbrew.pm

Changelog

2016-11-21 - gregor herrmann <gregoa@debian.org>
perlbrew (0.78-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.78.
2016-11-19 - gregor herrmann <gregoa@debian.org>
perlbrew (0.77-2) unstable; urgency=medium
* Team upload.
* Add --name parameter to pod2man call in debian/rules in order to make
the build reproducible.
Thanks to Chris Lamb for the bug report and the patch. (Closes: #844992)
2016-11-15 - gregor herrmann <gregoa@debian.org>
perlbrew (0.77-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.77.
Fixes "Unescaped left brace in regex is deprecated"
(Closes: #826500)
* Drop 5.003_07.patch, fixed upstream.
* Update (build) dependencies.
2016-07-30 - gregor herrmann <gregoa@debian.org>
perlbrew (0.76-2) unstable; urgency=medium
* Team upload.
* debian/upstream/metadata: use HTTPS for GitHub URLs.
* Add patch to handle removal of perl 5.003_07 from the CPAN.
(Closes: #832832)
2016-06-27 - Lucas Kanashiro <kanashiro@debian.org>
perlbrew (0.76-1) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
[ Lucas Kanashiro ]
* Import upstream version 0.76
* Remove patch fixing typo in manpage, applied by upstream
* Declare compliance with Debian policy 3.9.8
* debian/control: update build and runtime dependencies
2016-03-21 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
perlbrew (0.75-1) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ Lucas Kanashiro ]
* Import upstream version 0.75
* d/u/metadata: fix email syntax in Contact field
* Update years of upstream copyright
* Update Debian packaging copyright
* Declare compliance with Debian policy 3.9.7
* Create patch to fix spelling error in manpage
2015-11-24 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
perlbrew (0.74-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.74
* Bump debhelper compatibility level to 9
2015-05-10 - gregor herrmann <gregoa@debian.org>
perlbrew (0.73-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.73.
* Drop spelling.patch, merged upstream.
* Update years of upstream copyright.
* Update versioned build and runtime dependencies.
* Mark package as autopkgtest-able.
* Add patch to use installed script in tests for autopktest.
2014-10-01 - gregor herrmann <gregoa@debian.org>
perlbrew (0.71-1) unstable; urgency=medium
[ gregor herrmann ]
* New upstream releases 0.68, 0.69.
* Drop patches, both merged upstream.
* Update years of upstream copyright.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add debian/upstream/metadata
* Imported upstream version 0.71
* Update (build) dependencies.
* Add a patch to fix a spelling mistake.
* Declare compliance with Debian Policy 3.9.6.
2014-04-27 - Alessandro Ghedini <ghedo@debian.org>
perlbrew (0.67-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Imported Upstream version 0.67 (Closes: #746138)
* Update versioned (Build-)Depends(-Indep) for liblocal-lib-perl.
Update the versioned Build-Depends-Indep and Depends on
liblocal-lib-perl to (>= 1.008026).
* Bump Standards-Version to 3.9.5
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Alessandro Ghedini ]
* Add 01_fix-spelling.patch to fix spelling-error-in-manpage
* Add 02_fix-pod.patch to fix manpage-has-errors-from-pod2man

See Also

Package Description
perlconsole_0.4-4_all.deb small program that lets you evaluate Perl code interactively
perlindex_1.606-1_all.deb Perl manual pages index and query application
perlmagick_6.9.7.4+dfsg-16ubuntu2_all.deb Perl interface to ImageMagick -- dummy package
perlpanel_0.9.1+cvs20051225-3_all.deb lean menu and launcher panel written in Perl and Gtk2
perlprimer-doc_1.2.3-1_all.deb Tutorial to perlprimer
perlprimer_1.2.3-1_all.deb Graphical design of primers for PCR
perlqt-dev_4.14.1-0ubuntu9_i386.deb Development files for PerlQt4
perlrdf_0.004-3_all.deb RDF command line utils
perltidy_20140328-2_all.deb Perl script indenter and reformatter
perm_0.4.0-3_i386.deb efficient mapping of short reads with periodic spaced seeds
persistent-cache-cpp-dev_1.0.4+16.10.20160823-0ubuntu3_i386.deb Cache of key-value pairs with persistent storage for C++ 11
persistent-cache-cpp-doc_1.0.4+16.10.20160823-0ubuntu3_all.deb Documentation for persistent-cache-cpp-dev
pescetti_0.5-2_all.deb Bridge Pseudo-duplimate generator
pesign_0.112-4_i386.deb Signing utility for UEFI binaries
petit_1.1.1-1_all.deb log analysis tool for syslog, apache and raw log files
Advertisement
Advertisement