pelican_3.7.1+dfsg-1_all.deb


Advertisement

Description

pelican - blog aware, static website generator

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name pelican
Package version 3.7.1+dfsg
Package release 1
Package architecture all
Package type deb
Installed size 362 B
Download size 77.85 KB
Official Mirror archive.ubuntu.com
Pelican is a static site generator, written in Python.  It allows you
to write your weblog entries directly with your editor of choice in
reStructuredText or Markdown, and generates completely static output
that is easy to host anywhere.  Pelican includes a simple CLI tool to
(re)generate the weblog and it is easy to interface with DVCSes and web
hooks.

Alternatives

Package Version Architecture Repository
pelican_3.7.1+dfsg-1_all.deb 3.7.1+dfsg all Ubuntu Universe
pelican - - -

Requires

Name Value
python >= 2.7
python-argparse -
python-blinker -
python-dateutil -
python-docutils -
python-feedgenerator >= 1.6
python-jinja2 >= 2.7
python-markdown -
python-pkg-resources -
python-pygments -
python-six >= 1.4
python-tz -
python-unidecode -
python:any << 2.8
python:any >= 2.7.5-5~

Replaces

Name Value
python-pelican << 3.6.0-2~

Download

Type URL
Binary Package pelican_3.7.1+dfsg-1_all.deb
Source Package pelican

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pelican deb package:
    # sudo apt-get install pelican

Files

Path
/usr/bin/pelican
/usr/bin/pelican-import
/usr/bin/pelican-quickstart
/usr/bin/pelican-themes
/usr/lib/python2.7/dist-packages/pelican/__init__.py
/usr/lib/python2.7/dist-packages/pelican/cache.py
/usr/lib/python2.7/dist-packages/pelican/contents.py
/usr/lib/python2.7/dist-packages/pelican/generators.py
/usr/lib/python2.7/dist-packages/pelican/log.py
/usr/lib/python2.7/dist-packages/pelican/paginator.py
/usr/lib/python2.7/dist-packages/pelican/readers.py
/usr/lib/python2.7/dist-packages/pelican/rstdirectives.py
/usr/lib/python2.7/dist-packages/pelican/server.py
/usr/lib/python2.7/dist-packages/pelican/settings.py
/usr/lib/python2.7/dist-packages/pelican/signals.py
/usr/lib/python2.7/dist-packages/pelican/urlwrappers.py
/usr/lib/python2.7/dist-packages/pelican/utils.py
/usr/lib/python2.7/dist-packages/pelican/writers.py
/usr/lib/python2.7/dist-packages/pelican-3.7.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/pelican-3.7.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/pelican-3.7.1.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/pelican-3.7.1.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/pelican-3.7.1.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/archives.html
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/article.html
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/author.html
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/authors.html
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/base.html
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/categories.html
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/category.html
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/gosquared.html
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/index.html
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/page.html
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/pagination.html
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/period_archives.html
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/tag.html
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/tags.html
/usr/lib/python2.7/dist-packages/pelican/themes/simple/templates/translations.html
/usr/lib/python2.7/dist-packages/pelican/tools/__init__.py
/usr/lib/python2.7/dist-packages/pelican/tools/pelican_import.py
/usr/lib/python2.7/dist-packages/pelican/tools/pelican_quickstart.py
/usr/lib/python2.7/dist-packages/pelican/tools/pelican_themes.py
/usr/lib/python2.7/dist-packages/pelican/tools/templates/Makefile.in
/usr/lib/python2.7/dist-packages/pelican/tools/templates/develop_server.sh.in
/usr/lib/python2.7/dist-packages/pelican/tools/templates/fabfile.py.in
/usr/lib/python2.7/dist-packages/pelican/tools/templates/pelicanconf.py.in
/usr/lib/python2.7/dist-packages/pelican/tools/templates/publishconf.py.in
/usr/share/doc/pelican/README.Debian
/usr/share/doc/pelican/changelog.Debian.gz
/usr/share/doc/pelican/copyright
/usr/share/man/man1/pelican-import.1.gz
/usr/share/man/man1/pelican-quickstart.1.gz
/usr/share/man/man1/pelican-themes.1.gz
/usr/share/man/man1/pelican.1.gz

Changelog

2017-08-12 - Vincent Cheng <vcheng@debian.org>
pelican (3.7.1+dfsg-1) unstable; urgency=medium
* Remove notmyidea theme to avoid shipping non-free files, repacking tarball.
(Closes: #868047, #868049, #858859)
- Update debian/copyright and debian/lintian-overrides accordingly.
- Add debian/patches/default_theme.patch to change default theme to
"simple".
* Update Standards version to 4.0.1.
- Change python-pelican priority due to "extra" being deprecated.
2017-01-11 - Vincent Cheng <vcheng@debian.org>
pelican (3.7.1-1) unstable; urgency=medium
* New upstream release.
- Drop quickstart_attribute_error.patch; applied upstream.
2017-01-05 - Vincent Cheng <vcheng@debian.org>
pelican (3.7.0-2) unstable; urgency=medium
* Update debian/patches/quickstart_attribute_error.patch with upstream fix.
2017-01-02 - Vincent Cheng <vcheng@debian.org>
pelican (3.7.0-1) unstable; urgency=medium
* New upstream release. (Closes: #849583)
* Add debian/patches/quickstart_attribute_error.patch to fix AttributeError
when invoking pelican-quickstart.
* Update dependency on python-feedgenerator to >= 1.9.
* Update Standards version to 3.9.8, no changes required.
* Update dh compat level to 9.
2015-08-14 - Vincent Cheng <vcheng@debian.org>
pelican (3.6.3-1) unstable; urgency=medium
* New upstream release.
2015-08-03 - Vincent Cheng <vcheng@debian.org>
pelican (3.6.2-1) unstable; urgency=medium
* New upstream release.
* Change Section field in d/control from python to web. (Closes: #791386)
* Add dependency “Suggests: pelican-doc” to pelican. (Closes: #791387)
2015-06-28 - Vincent Cheng <vcheng@debian.org>
pelican (3.6.0-4) unstable; urgency=medium
* Build pelican reproducibly. (Closes: #790309)
2015-06-27 - Vincent Cheng <vcheng@debian.org>
pelican (3.6.0-3) unstable; urgency=medium
* Fix broken package upgrades by declaring Breaks/Replaces on correct
version. (Closes: #790052)
2015-06-16 - Vincent Cheng <vcheng@debian.org>
pelican (3.6.0-2) unstable; urgency=medium
* Rename binary package from python-pelican -> pelican.
* Build documentation and install into new pelican-doc package. Thanks to
Federico Ceratto for the patch! (Closes: #754071)
- Add build-depends on python-sphinx, dh-python, in addition to existing
python module dependencies for sphinx to build docs from source.
2015-06-15 - Vincent Cheng <vcheng@debian.org>
pelican (3.6.0-1) unstable; urgency=medium
* New upstream release.
- Fix a datetime comparison error related to time zones. (Closes: #787591)
* Update debian/watch.

See Also

Package Description
pem_0.7.9-1_all.deb command line personal expense manager
pen_0.34.0-1_i386.deb Load balancer for "simple" tcp based protocols
pencil2d_0.5.4+git20170831.600470f+ds-1_i386.deb Create hand-drawn animation using both bitmap and vector graphics
penguin-command_1.6.11-3_i386.deb missile command clone
pente_2.2.5-7build1_i386.deb five in a row game for X and the console
pentium-builder_0.21_all.deb force pentium optimized compilation
pentobi-kde-thumbnailer_13.1-1_i386.deb clone of the strategy board game Blokus - KDE thumbnailer
pentobi_13.1-1_i386.deb clone of the strategy board game Blokus
peony-common_1.0.4-0ubuntu1_all.deb file manager for the UKUI desktop (common files)
peony_1.0.4-0ubuntu1_i386.deb file manager for the UKUI desktop
pep8_1.7.0-4_all.deb Python PEP 8 code style checker - transitional package
pepper_0.3.3-3_i386.deb Source code repository statistics and report tool
perceptualdiff_1.2-2_i386.deb perceptual image comparison tool
percona-galera-3_3.19-0ubuntu1_i386.deb Galera replication framework for Percona XtraDB Cluster
percona-galera-arbitrator-3_3.19-0ubuntu1_i386.deb Galera arbitrator daemon for Percona XtraDB Cluster
Advertisement
Advertisement