pandoc_1.19.2.1.0-1_i386.deb


Advertisement

Description

pandoc - general markup converter

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name pandoc
Package version 1.19.2.1.0
Package release 1
Package architecture i386
Package type deb
Installed size 39.43 KB
Download size 6.35 MB
Official Mirror archive.ubuntu.com
Pandoc is a Haskell library for converting
from one markup format to another,
and a command-line tool that uses this library.
It can read several dialects of Markdown and (subsets of) HTML,
reStructuredText, LaTeX, DocBook,
MediaWiki markup, TWiki markup, Haddock markup,
OPML, Emacs Org-mode, txt2tags, Word Docx, ODT, and Textile,
and it can write Markdown, reStructuredText, XHTML, HTML 5,
LaTeX (including rendering as plain PDF or beamer slide shows),
ConTeXt, DocBook, OPML, TEI, OpenDocument, ODT, Word docx, RTF,
MediaWiki, DokuWiki, ZimWiki, Textile, groff man pages, GNU Texinfo,
plain text, Emacs Org-Mode, AsciiDoc, Haddock markup,
EPUB (v2 and v3), FictionBook2, InDesign ICML,
and several kinds of HTML/javascript slide shows
(S5, Slidy, Slideous, DZSlides, reveal.js).
In contrast to most existing tools for converting Markdown to HTML,
pandoc has a modular design:
it consists of a set of readers, which parse text in a given format
and produce a native representation of the document,
and a set of writers,
which convert this native representation into a target format.
Thus,
adding an input or output format requires only adding a reader or writer.
This package contains the pandoc tool.
PDF output via PDFLaTeX requires the package texlive-latex-recommended.
* XeLaTeX additionally requires texlive-xetex
* LuaTeX additionally requires texlive-luatex
* content with YAML metadata additionally requires
texlive-latex-extra.
PDF output via wkhtmltopdf requires the package wkhtmltopdf.

Alternatives

Package Version Architecture Repository
pandoc_1.19.2.1.0-1_amd64.deb 1.19.2.1.0 amd64 Ubuntu Universe
pandoc - - -

Requires

Name Value
libc6 >= 2.15
libffi6 >= 3.0.4
libgmp10 -
liblua5.1-0 -
libluajit-5.1-2 -
libpcre3 -
libyaml-0-2 -
pandoc-data << 1.19.2.1.0-1.~
pandoc-data >= 1.19.2.1.0-1
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package pandoc_1.19.2.1.0-1_i386.deb
Source Package pandoc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pandoc deb package:
    # sudo apt-get install pandoc

Files

Path
/usr/bin/pandoc
/usr/share/doc/pandoc/BUGS
/usr/share/doc/pandoc/NEWS.Debian.gz
/usr/share/doc/pandoc/README.Debian
/usr/share/doc/pandoc/README.md.gz
/usr/share/doc/pandoc/TODO.Debian
/usr/share/doc/pandoc/changelog.Debian.gz
/usr/share/doc/pandoc/copyright
/usr/share/lintian/overrides/pandoc
/usr/share/man/man1/pandoc.1.gz

Changelog

2017-08-01 - Jonas Smedegaard <dr@jones.dk>
pandoc (1.19.2.1.0-1) unstable; urgency=medium
[ upstream ]
* New release(s).
+ Fixes lang-Variable collision between pandoc-citeproc and Babel.
Closes: Bug#870248. Thanks to Claus-Michael.
[ Jonas Smedegaard ]
* Update package relations:
+ Add GHC for skylighting (replacing highlighting-kate).
+ Relax GHC upper bounds for aeson blaze-html blaze-markup vector.
* Update copyright info: Extend coverage for main authors.
* Drop patch 2003 (relax GHC upper bounds for directory): Relaxed
upstream now.
* Unfuzz patches.
* Add patches cherry-picked upstream to use newer skylighting and
mention skylighting (not highlighting-kate) in manpage.
2017-07-26 - Jonas Smedegaard <dr@jones.dk>
pandoc (1.19.2.1~dfsg+really1.19.1-1) unstable; urgency=medium
* Revert to upstream release 1.19.1: Avoid broken skylighting.
2017-07-25 - Jonas Smedegaard <dr@jones.dk>
pandoc (1.19.2.1~dfsg-1) unstable; urgency=medium
[ upstream ]
* New release(s).
[ Jonas Smedegaard ]
* Update package relations:
+ Add GHC for skylighting (replacing highlighting-kate).
+ Relax GHC upper bounds for aeson blaze-html blaze-markup vector.
* Update copyright info:
+ Extend coverage for main authors.
* Drop patch 2003: Upstream now relax GHC upper bounds for directory.
* Unfuzz patches, and advertise DEP3 format.
2017-07-21 - Jonas Smedegaard <dr@jones.dk>
pandoc (1.19.1~dfsg-1) unstable; urgency=medium
[ upstream ]
* New release.
[ Jonas Smedegaard ]
* Update package relations:
+ Add GHC for doctemplates.
+ Tighten GHC lower bounds for mtl.
+ Shift GHC bounds for texmath pandoc-types.
+ Drop GHC lower bounds for network-uri zip-archive tagsoup
blaze-html yaml vector sha cmark http-types.
+ Drop GHC lower bounds for diff (but unused as testsuite skipped).
+ Relax to build-depend unversioned on haskell-devscripts.
+ Relax to suggest unversioned texlive-latex-extra: Needed versions
satisfied even in oldsable.
+ Relax GHC upper bounds for aeson.
+ Relax GHC upper bounds for hunit (but unused as testsuite is
skipped).
* Stop override lintian for
package-needs-versioned-debhelper-build-depends: Fixed in lintian.
* Update copyright info: Add and tidy some copyright holders.
* Modernize cdbs:
+ Check copyright in maintainer script (not during build).
+ Stop build-Depend on licensecheck libregexp-assemble-perl
libimage-exiftool-perl libfont-ttf-perl.
+ Relax to build-depend unversioned on cdbs.
+ Update patches:
+ Drop patch 2002: Upstream relaxed GHC lower bounds for http-client
http-client-tls.
+ Unfuzz patches.
* Install README.md.
* Modernize Vcs-Browser field: Use git (not cgit) in path.
* Declare compliance with Debian Policy 4.0.0.
2017-06-21 - Gianfranco Costamagna <locutusofborg@debian.org>
pandoc (1.17.2~dfsg-4) unstable; urgency=medium
* Team upload.
* Bump directory bounds on buildds.
2016-11-11 - Clint Adams <clint@debian.org>
pandoc (1.17.2~dfsg-3) unstable; urgency=medium
* Reduce compile-time memory utilization on mips and mipsel.
2016-10-27 - Clint Adams <clint@debian.org>
pandoc (1.17.2~dfsg-2) unstable; urgency=medium
* Temporarily build-depend on ghc 8 and haskell-devscripts 0.13.

See Also

Package Description
pandora-build_0.171.1-0ubuntu2_all.deb autotools made better, faster stronger
pandora_0.7.1-0ubuntu3_i386.deb GIMP Plugin For Creating Panoramas
pandorafms-agent_4.1-1_all.deb Pandora FMS - The Flexible Monitoring System (agent)
pango1.0-tests_1.40.12-1_i386.deb Layout and rendering of internationalized text - installed tests
pangzero_1.4.1+git20121103-3_all.deb action game that involves popping balloons with a harpoon
panko-api_3.0.0-0ubuntu2_all.deb Event storage dispatcher for Ceilometer (Python 2)
panko-common_3.0.0-0ubuntu2_all.deb panko common files
panoramisk_1.0-1_all.deb asyncio based library to play with asterisk (Python 3 binary)
paperkey_1.3-2_i386.deb extract just the secret information out of OpenPGP secret keys
papi-examples_5.5.1-2_all.deb PAPI example files and test programs
papi-tools_5.5.1-2_i386.deb PAPI utilities
paprass_2.06-2_all.deb Manager of electronic documents
paprefs_0.9.10-2_i386.deb PulseAudio Preferences
paps_0.6.8-7.1_i386.deb UTF-8 to PostScript converter using Pango
par2_0.7.2-1_i386.deb PAR 2.0 compatible file verification and repair tool
Advertisement
Advertisement