abyss_2.0.2-3_i386.deb


Advertisement

Description

abyss - de novo, parallel, sequence assembler for short reads

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Multiverse i386
Package name abyss
Package version 2.0.2
Package release 3
Package architecture i386
Package type deb
Installed size 8.31 KB
Download size 2.71 MB
Official Mirror archive.ubuntu.com
ABySS is a de novo, parallel, sequence assembler that is designed for
short reads. It may be used to assemble genome or transcriptome
sequence data. Parallelization is achieved using MPI, OpenMP and
pthread.

Alternatives

Package Version Architecture Repository
abyss_2.0.2-3_amd64.deb 2.0.2 amd64 Ubuntu Multiverse
abyss - - -

Requires

Name Value
bsdmainutils -
libc6 >= 2.7
libgcc1 >= 1:4.2
libgomp1 >= 4.9
libsqlite3-0 >= 3.5.9
libstdc++6 >= 5.2
make -
perl:any -

Download

Type URL
Binary Package abyss_2.0.2-3_i386.deb
Source Package abyss

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install abyss deb package:
    # sudo apt-get install abyss

Files

Path
/usr/bin/DistanceEst
/usr/bin/abyss-fixmate
/usr/bin/abyss-pe
/usr/lib/abyss/ABYSS
/usr/lib/abyss/AdjList
/usr/lib/abyss/Consensus
/usr/lib/abyss/DAssembler
/usr/lib/abyss/DistanceEst
/usr/lib/abyss/DistanceEst-ssq
/usr/lib/abyss/KAligner
/usr/lib/abyss/MergeContigs
/usr/lib/abyss/MergePaths
/usr/lib/abyss/Overlap
/usr/lib/abyss/ParseAligns
/usr/lib/abyss/PathConsensus
/usr/lib/abyss/PathOverlap
/usr/lib/abyss/PopBubbles
/usr/lib/abyss/SimpleGraph
/usr/lib/abyss/abyss-align
/usr/lib/abyss/abyss-bloom
/usr/lib/abyss/abyss-bloom-dbg
/usr/lib/abyss/abyss-bloom-dist.mk
/usr/lib/abyss/abyss-bowtie
/usr/lib/abyss/abyss-bowtie2
/usr/lib/abyss/abyss-bwa
/usr/lib/abyss/abyss-bwamem
/usr/lib/abyss/abyss-bwasw
/usr/lib/abyss/abyss-db-csv
/usr/lib/abyss/abyss-db-txt
/usr/lib/abyss/abyss-dida
/usr/lib/abyss/abyss-fac
/usr/lib/abyss/abyss-fatoagp
/usr/lib/abyss/abyss-filtergraph
/usr/lib/abyss/abyss-fixmate
/usr/lib/abyss/abyss-fixmate-ssq
/usr/lib/abyss/abyss-gapfill
/usr/lib/abyss/abyss-gc
/usr/lib/abyss/abyss-index
/usr/lib/abyss/abyss-junction
/usr/lib/abyss/abyss-kaligner
/usr/lib/abyss/abyss-layout
/usr/lib/abyss/abyss-longseqdist
/usr/lib/abyss/abyss-map
/usr/lib/abyss/abyss-map-ssq
/usr/lib/abyss/abyss-mergepairs
/usr/lib/abyss/abyss-overlap
/usr/lib/abyss/abyss-paired-dbg
/usr/lib/abyss/abyss-pe
/usr/lib/abyss/abyss-samtoafg
/usr/lib/abyss/abyss-scaffold
/usr/lib/abyss/abyss-sealer
/usr/lib/abyss/abyss-tabtomd
/usr/lib/abyss/abyss-todot
/usr/lib/abyss/abyss-tofastq
/usr/lib/abyss/konnector
/usr/lib/abyss/logcounter
/usr/share/doc/abyss/README.html
/usr/share/doc/abyss/README.md.gz
/usr/share/doc/abyss/README.test
/usr/share/doc/abyss/changelog.Debian.gz
/usr/share/doc/abyss/copyright
/usr/share/doc/abyss/flowchart.pdf.gz
/usr/share/doc/abyss/run-unit-test
/usr/share/doc/abyss/test-data/reads1.fastq.gz
/usr/share/doc/abyss/test-data/reads2.fastq.gz
/usr/share/man/man1/ABYSS.1.gz
/usr/share/man/man1/abyss-pe.1.gz
/usr/share/man/man1/abyss-tofastq.1.gz

Changelog

2017-06-30 - Nadiya Sitdykova  <rovenskasa@gmail.com>
abyss (2.0.2-3) unstable; urgency=medium
* Team upload.
[ Nadiya Sitdykova ]
* Add simple autopkgtest test-suite.
[ Steffen Moeller ]
* [debian/upstream/metadata] Added references to bio.tools, OMICtools
and RRID
[ Sascha Steinbiss ]
* Add missing dependency on bsdmainutils.
* Use HTTPS URL for Format entry in d/copyright.
* Bump Standards-Version.
2016-12-11 - Andreas Tille <tille@debian.org>
abyss (2.0.2-2) unstable; urgency=medium
* FTBFS on mips and other big-endian architectures (Thanks for the patch
to Daniel Knezevic <Daniel.Knezevic@imgtec.com>)
Closes: #847574
* debhelper 10
* d/watch: version=4
2016-11-01 - Andreas Tille <tille@debian.org>
abyss (2.0.2-1) unstable; urgency=medium
* New upstream version
2016-10-10 - Andreas Tille <tille@debian.org>
abyss (2.0.1-1) unstable; urgency=medium
[ Andreas Tille ]
* New upstream version now licensed under GPL-3
* Moved package to main
* cme fix dpkg-control
* use markdown to create doc
* hardening=+all
[ Gert Wollny ]
* Force gtest to use c++11 based std::tuple
2015-07-16 - Andreas Tille <tille@debian.org>
abyss (1.9.0-1) unstable; urgency=medium
* New upstream version
Adapted patches
* Took over COPYRIGHT from upstream as debian/copyright
* Dropped Shaun Jackman from Uploaders since he confirmed that he will not
be able to maintain the package
* Build-Depends: libsqlite3-dev
* Script uses bash syntax so request bash interpreter
2015-05-18 - Andreas Tille <tille@debian.org>
abyss (1.5.2-2) unstable; urgency=medium
* abyss-fixmate and DistanceEst are expected to be in /usr/bin by sga
* configure was missing ghc -> mention this fact in README.source for
further inspection
* Fix FTBFS on 32-bit architectures (thanks for the patch to Graham
Inggs <graham@nerve.org.za>)
Closes: #780409
* cme fix dpkg-control
2014-09-15 - Andreas Tille <tille@debian.org>
abyss (1.5.2-1) unstable; urgency=medium
* New upstream version (remove applied patches)
* d/watch: Moved to github
* d/control+d/rules: use dh-autoreconf
* d/control: Build-Depends: libtext-multimarkdown-perl
* cme fix dpkg-control
* d/control: Build-Depends: libgtest-dev to enable unit tests at build time
* d/control: drop copy of citation info from long description
* patch to make gtest work (thanks to Anthony Raymond <traymond@bcgsc.ca>)
* Drop privacy breach in doc
2013-09-08 - Charles Plessy <plessy@debian.org>
abyss (1.3.6-1) unstable; urgency=low
* Team upload (Closes: #722072).
e05ee57 Imported Upstream version 1.3.5
b391f1f Imported Upstream version 1.3.6 (Closes: #702440)
7edc28b Signal the use of git-buildpackage with this configuration file.
a3beaac Normalised source package control file with config-model-edit.
dd86394 Conforms with Policy version 3.9.4.
71d42ad Normalised VCS URLs.
2013-07-01 - Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>
abyss (1.3.4-4) unstable; urgency=low
* Team upload.
* Fix FTBFS with gcc-4.8, -Werror=unused-local-typedefs.
* Enable parallel build.
2013-01-04 - Andreas Tille <tille@debian.org>
abyss (1.3.4-3) unstable; urgency=low
* Disable POPCNT
Closes: #697344
* Add debian/README.debian to inform users about this change asking
for some comparison of the speed to consider other means for better
performance

See Also

Package Description
acccheck_0.2.1-3_all.deb Password dictionary attack tool for SMB
afio_2.5.1.20160103+gitc8e4317-1_i386.deb archive file manipulation program
agrep_4.17-9_i386.deb text search tool with support for approximate patterns
album-data_4.05-7_all.deb themes, plugins and translations for album
album_4.15-1_all.deb HTML photo album generator with theme support
alien-arena-data_7.66-2_all.deb Game data files for Alien Arena
alien-arena-server_7.66+dfsg-4_i386.deb Dedicated server for Alien Arena
alien-arena_7.66+dfsg-4_i386.deb Standalone 3D first person online deathmatch shooter
alsa-firmware-loaders_1.1.3-1_i386.deb ALSA software loaders for specific hardware
amd64-microcode_3.20160316.3_i386.deb Processor microcode firmware for AMD CPUs
amiwm_0.20.48-8_i386.deb The Amiga look alike window manager
amoeba-data_1.1-6_all.deb Fast-paced, polished OpenGL demonstration by Excess (data)
amoeba_1.1-29.1ubuntu1_i386.deb fast-paced, polished OpenGL demonstration by Excess
android-src-vendor_7-0ubuntu1_all.deb Vendor files to build Android Open Source Project
angband-audio_3.1.0-1_all.deb Sound files for the roguelike game angband
Advertisement
Advertisement