python3-requests_2.18.1-1_all.deb


Advertisement

Description

python3-requests - elegant and simple HTTP library for Python3, built for human beings

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Main amd64
Package name python3-requests
Package version 2.18.1
Package release 1
Package architecture all
Package type deb
Installed size 271 B
Download size 56.28 KB
Official Mirror archive.ubuntu.com
Requests allow you to send HTTP/1.1 requests. You can add headers, form data,
multipart files, and parameters with simple Python dictionaries, and access
the response data in the same way. It's powered by httplib and urllib3, but
it does all the hard work and crazy hacks for you.
Features
- International Domains and URLs
- Keep-Alive & Connection Pooling
- Sessions with Cookie Persistence
- Browser-style SSL Verification
- Basic/Digest Authentication
- Elegant Key/Value Cookies
- Automatic Decompression
- Unicode Response Bodies
- Multipart File Uploads
- Connection Timeouts
This package contains the Python 3 version of the library.

Alternatives

Package Version Architecture Repository
python3-requests_2.18.1-1_all.deb 2.18.1 all Ubuntu Main
python3-requests_2.8.1-1~bpo8+1~nd90+1+nd17.04+1+nd17.10+1_all.deb 2.8.1 all NeuroDebian Main
python3-requests_2.8.1-1~bpo8+1~nd90+1+nd17.04+1+nd17.10+1_all.deb 2.8.1 all NeuroDebian Main
python3-requests - - -

Requires

Name Value
ca-certificates -
python3-certifi -
python3-chardet >= 3.0.2
python3-idna -
python3-urllib3 << 1.22
python3-urllib3 >= 1.21.1
python3:any >= 3.3.2-2~

Download

Type URL
Binary Package python3-requests_2.18.1-1_all.deb
Source Package requests

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-requests deb package:
    # sudo apt-get install python3-requests

Files

Path
/usr/lib/python3/dist-packages/requests/__init__.py
/usr/lib/python3/dist-packages/requests/__version__.py
/usr/lib/python3/dist-packages/requests/_internal_utils.py
/usr/lib/python3/dist-packages/requests/adapters.py
/usr/lib/python3/dist-packages/requests/api.py
/usr/lib/python3/dist-packages/requests/auth.py
/usr/lib/python3/dist-packages/requests/certs.py
/usr/lib/python3/dist-packages/requests/compat.py
/usr/lib/python3/dist-packages/requests/cookies.py
/usr/lib/python3/dist-packages/requests/exceptions.py
/usr/lib/python3/dist-packages/requests/help.py
/usr/lib/python3/dist-packages/requests/hooks.py
/usr/lib/python3/dist-packages/requests/models.py
/usr/lib/python3/dist-packages/requests/packages.py
/usr/lib/python3/dist-packages/requests/sessions.py
/usr/lib/python3/dist-packages/requests/status_codes.py
/usr/lib/python3/dist-packages/requests/structures.py
/usr/lib/python3/dist-packages/requests/utils.py
/usr/lib/python3/dist-packages/requests-2.18.1.egg-info/PKG-INFO
/usr/lib/python3/dist-packages/requests-2.18.1.egg-info/dependency_links.txt
/usr/lib/python3/dist-packages/requests-2.18.1.egg-info/not-zip-safe
/usr/lib/python3/dist-packages/requests-2.18.1.egg-info/requires.txt
/usr/lib/python3/dist-packages/requests-2.18.1.egg-info/top_level.txt
/usr/share/doc/python3-requests/changelog.Debian.gz
/usr/share/doc/python3-requests/copyright

Changelog

2017-08-04 - Daniele Tricoli <eriol@mornie.org>
requests (2.18.1-1) unstable; urgency=medium
* New upstream release. (Closes: #856619)
- No more bundling of dependencies. (Closes: #859504)
* Drop all patches.
* Add autodep8 tests.
* debian/control
- Bump python{,3}-urllib3 dependencies to (>= 1.21.1) (<< 1.22).
- Bump Standards-Version to 4.0.0 (no changes needed).
- Add version constraint for chardet and idna.
- Add python{,3}-certifi to Build-Depends and Depends.
* debian/copyright
- Remove stanzas of no more bundled dependencies.
- Update copyright years.
2016-12-19 - Daniele Tricoli <eriol@mornie.org>
requests (2.12.4-1) unstable; urgency=medium
* New upstream release.
2016-12-13 - Daniele Tricoli <eriol@mornie.org>
requests (2.12.3-1) unstable; urgency=medium
* New upstream release.
* debian/control
- Bump python{,3}-urllib3 dependencies to (>= 1.19.1) (<< 1.19.2).
- Remove python{,3}-ndg-httpsclient and python{,3}-pyasn1.
- Add python{,3}-cryptography and python{,3}-idna.
* debian/copyright
- Add stanza for idna.
* debian/patches/02_populate-install_requires.patch
- Refresh.
* debian/patches/use-pip-unbundling.patch
- Refresh.
2016-09-09 - Daniele Tricoli <eriol@mornie.org>
requests (2.11.1-1) unstable; urgency=medium
* New upstream release.
* debian/control
- Bump python{,3}-urllib3 dependencies to (>= 1.16) (<< 1.16.1).
* debian/patches/02_populate-install_requires.patch
- Refresh.
2016-06-18 - Daniele Tricoli <eriol@mornie.org>
requests (2.10.0-2) unstable; urgency=medium
* debian/patches/use-pip-unbundling.patch
- Use the same unbundling strategy implemented by pip.
2016-05-20 - Daniele Tricoli <eriol@mornie.org>
requests (2.10.0-1) unstable; urgency=medium
* New upstream release.
* debian/control
- Bump Standards-Version to 3.9.8 (no changes needed).
- Add python{,3}-socks to Suggests.
- Bump python{,3}-urllib3 dependencies to (>= 1.15.1) (<< 1.15.2).
* debian/copyright
- Update copyright years.
* debian/patches/02_populate-install_requires.patch
- Refresh.
2016-02-12 - Daniele Tricoli <eriol@mornie.org>
requests (2.9.1-3) unstable; urgency=medium
* debian/control
- Remove python-requests-whl as it's no longer necessary.
- Remove python3-wheel from Build-Depends.
- Fix Vcs-Git URI.
- Bump Standards-Version to 3.9.7 (no changes needed).
- Bump X-Python3-Version to >= 3.3.
* debian/copyright
- Updated copyright years.
* debian/python-requests-whl.install
- Remove.
* debian/rules
- Remove override_dh_auto_install since we no longer need to
build the wheel package.
2016-01-24 - Daniele Tricoli <eriol@mornie.org>
requests (2.9.1-2) unstable; urgency=medium
* debian/control
- Tweak fixed dependency on urllib3 1.13.1 to accommodate
packaging changes, as the version requirement is upstream version
only. Thanks James Page for report and patch. (Closes: #809485)
- Use HTTPS scheme for Vcs-Git.
2015-12-27 - Daniele Tricoli <eriol@mornie.org>
requests (2.9.1-1) unstable; urgency=medium
* New upstream release.
* debian/control
- Bump python{,3}-urllib3 to = 1.13.1-1 both in Build-Depends and Depends.
Tighten urllib3 dependency is needed because, otherwise, any programs
depending to requests through pkgresources will fail. Thanks to Vincent
Bernat for the report.
* debian/patches/02_populate-install_requires.patch
- Refresh. (Closes: #809031)

See Also

Package Description
python3-roman_2.0.0-2_all.deb module for generating/analyzing Roman numerals for Python 3
python3-scripttest_1.3-2_all.deb Helper to test command-line scripts - python 3.x
python3-seamicroclient_0.4.0-1ubuntu1_all.deb Client library for Seamicro chassis API - Python 3.x
python3-secretstorage_2.3.1-2_all.deb Python module for storing secrets - Python 3.x version
python3-serial_3.4-1_all.deb pyserial - module encapsulating access for the serial port
python3-service-identity_16.0.0-2_all.deb Service identity verification for pyOpenSSL (Python 3 module)
python3-setproctitle_1.1.10-1build2_amd64.deb Setproctitle implementation for Python 3
python3-setuptools_36.2.7-2_all.deb Python3 Distutils Enhancements
python3-simplejson_3.11.1-1build1_amd64.deb simple, fast, extensible JSON encoder/decoder for Python 3.x
python3-simplestreams_0.1.0~bzr450-0ubuntu1_all.deb Library and tools for using Simple Streams data
python3-six_1.10.0-4_all.deb Python 2 and 3 compatibility library (Python 3 interface)
python3-software-properties_0.96.24.17_all.deb manage the repositories that you install software from
python3-speechd_0.8.7-1_all.deb Python interface to Speech Dispatcher
python3-sphinx_1.5.6-2_all.deb documentation generator for Python projects (implemented in Python 3)
python3-sqlalchemy-ext_1.1.9+ds1-0ubuntu3_amd64.deb SQL toolkit and Object Relational Mapper for Python3 - C extension
Advertisement
Advertisement