libpsl-dev_0.18.0-2_amd64.deb


Advertisement

Description

libpsl-dev - Library for Public Suffix List (development headers)

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Main amd64
Package name libpsl-dev
Package version 0.18.0
Package release 2
Package architecture amd64
Package type deb
Installed size 131 B
Download size 21.39 KB
Official Mirror archive.ubuntu.com
Libpsl allows checking domains against the Public Suffix List.
It can be used to avoid privacy-leaking 'super-cookies',
'super domain' certificates, for domain highlighting purposes
sorting domain lists by site and more.
Please see https://publicsuffix.org for more detailed information.
This package contains development header files and documentation for
developers.

Alternatives

Package Version Architecture Repository
libpsl-dev_0.18.0-2_i386.deb 0.18.0 i386 Ubuntu Main
libpsl-dev - - -

Requires

Name Value
libpsl5 = 0.18.0-2

Download

Type URL
Binary Package libpsl-dev_0.18.0-2_amd64.deb
Source Package libpsl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpsl-dev deb package:
    # sudo apt-get install libpsl-dev

Files

Path
/usr/include/libpsl.h
/usr/lib/x86_64-linux-gnu/libpsl.so
/usr/lib/x86_64-linux-gnu/pkgconfig/libpsl.pc
/usr/share/doc/libpsl-dev/AUTHORS
/usr/share/doc/libpsl-dev/README.md.gz
/usr/share/doc/libpsl-dev/changelog.Debian.gz
/usr/share/doc/libpsl-dev/copyright
/usr/share/doc/libpsl-dev/html
/usr/share/gtk-doc/html/libpsl/api-index-full.html
/usr/share/gtk-doc/html/libpsl/deprecated-api-index.html
/usr/share/gtk-doc/html/libpsl/home.png
/usr/share/gtk-doc/html/libpsl/index.html
/usr/share/gtk-doc/html/libpsl/left-insensitive.png
/usr/share/gtk-doc/html/libpsl/left.png
/usr/share/gtk-doc/html/libpsl/libpsl-Public-Suffix-List-functions.html
/usr/share/gtk-doc/html/libpsl/libpsl.devhelp2
/usr/share/gtk-doc/html/libpsl/libpsl.html
/usr/share/gtk-doc/html/libpsl/object-tree.html
/usr/share/gtk-doc/html/libpsl/right-insensitive.png
/usr/share/gtk-doc/html/libpsl/right.png
/usr/share/gtk-doc/html/libpsl/style.css
/usr/share/gtk-doc/html/libpsl/up-insensitive.png
/usr/share/gtk-doc/html/libpsl/up.png
/usr/share/man/man3/libpsl.3.gz

Changelog

2017-08-11 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libpsl (0.18.0-2) unstable; urgency=medium
* build-depend on python:any to ease cross-building.  Thanks, Helmut
Grohne.  (Closes: #856477)
2017-08-10 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libpsl (0.18.0-1) unstable; urgency=medium
* New upstream release
* debhelper 10 does autoreconf automatically, drop unnecessary
build-depends
2017-07-14 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libpsl (0.17.0-5) unstable; urgency=medium
* fix bugs found upstream by fuzzing.
2017-02-21 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libpsl (0.17.0-4) unstable; urgency=medium
* prefer dafsa to plain-text (Closes: #855711)
2017-01-24 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libpsl (0.17.0-3) unstable; urgency=medium
* runtime dependency on libidn2-dev should have been on libidn2-0
(Closes: #852418)
2017-01-24 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libpsl (0.17.0-2) unstable; urgency=medium
* Force a higher runtime dependency on libidn2
2017-01-24 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libpsl (0.17.0-1) unstable; urgency=medium
[ Tim Rühsen ]
* new upstream release
[ Daniel Kahn Gillmor ]
* Use alioth for debian packaging
* Move from libicu to libidn2
2016-12-15 - Tim Rühsen <tim.ruehsen@gmx.de>
libpsl (0.16.1-1) unstable; urgency=medium
* new upstream release
2016-11-15 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libpsl (0.15.0-1) unstable; urgency=medium
* new upstream release
2016-07-05 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libpsl (0.14.0-1) unstable; urgency=medium
* New uptream version; moved from libpsl0 to libpsl5 because of removal
of psl_builtin_compile_time()
* new psl-make-dafsa package
* use upstreamed manpages instead

See Also

Package Description
libpsl5_0.18.0-2_amd64.deb Library for Public Suffix List (shared libraries)
libpspell-dev_0.60.7~20110707-4_amd64.deb Development files for applications with pspell support
libptexenc-dev_2017.20170613.44572-5build1_amd64.deb TeX Live: ptex encoding library (development part)
libptexenc1_2017.20170613.44572-5build1_amd64.deb TeX Live: pTeX encoding library
libpthread-stubs0-dev_0.3-4_amd64.deb pthread stubs not provided by native libc, development files
libpulse-dev_10.0-2ubuntu3_amd64.deb PulseAudio client development headers and libraries
libpulse-mainloop-glib0_10.0-2ubuntu3_amd64.deb PulseAudio client libraries (glib support)
libpulse0_10.0-2ubuntu3_amd64.deb PulseAudio client libraries
libpulsedsp_10.0-2ubuntu3_amd64.deb PulseAudio OSS pre-load library
libpwquality-common_1.4.0-1_all.deb library for password quality checking and generation (data files)
libpwquality-dev_1.4.0-1_amd64.deb Password quality checking and generation (development files)
libpwquality1_1.4.0-1_amd64.deb library for password quality checking and generation
libpython-all-dev_2.7.14-2ubuntu1_amd64.deb package depending on all supported Python development packages
libpython-dev_2.7.14-2ubuntu1_amd64.deb header files and a static library for Python (default)
libpython-stdlib_2.7.14-2ubuntu1_amd64.deb interactive high-level object-oriented language (default python version)
Advertisement
Advertisement