gir1.2-gdkpixbuf-2.0_2.36.5-3ubuntu0.2_amd64.deb


Advertisement

Description

gir1.2-gdkpixbuf-2.0 - GDK Pixbuf library - GObject-Introspection

Distribution: Ubuntu 17.04 (Zesty Zapus)
Repository: Ubuntu Updates Main amd64
Package name: gir1.2-gdkpixbuf-2.0
Package version: 2.36.5
Package release: 3ubuntu0.2
Package architecture: amd64
Package type: deb
Installed size: 44 B
Download size: 8.01 KB
Official Mirror: archive.ubuntu.com
The GDK Pixbuf library provides: - Image loading and saving facilities. - Fast scaling and compositing of pixbufs. - Simple animation loading (ie. animated GIFs) It can be used by packages using the GIRepository format to generate dynamic bindings.

    Download

    Source package: gdk-pixbuf

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install gir1.2-gdkpixbuf-2.0 deb package:
      # sudo apt-get install gir1.2-gdkpixbuf-2.0

    Changelog

    2017-09-13 - Leonidas S. Barbosa <leo.barbosa@canonical.com> gdk-pixbuf (2.36.5-3ubuntu0.2) zesty-security; urgency=medium * SECURITY UPDATE: Integer overflow checks not enough - debian/patches/CVE-2017-2870.patch: checks for integer overflow in multiplication in gdk-pixbuf/io-tiff.c. - CVE-2017-2870 * SECURITY UPDATE: exploitable heap overflow - debian/patches/CVE-2017-2862-part1.patch: Throw error when number of colour components is unsupported in gdk-pixbuf/io-jpeg.c. - debian/patches/CVE-2017-2862-part2.patch: restore grayscale support in gdk-pixbuf/io-jpeg.c - debian/patches/CVE-2017-2862-part3.patch: add test in tests/pixbuf-fail.c. - CVE-2017-2862 * SECURITY UPDATE: context-dependent to cause DoS - debian/patches/CVE-2017-6311-part1.patch: update skeleton to fix a possible crash in thumbnailer/gnome-thumbnailer-skeleton.c. - debian/patches/CVE-2017-6311-part2.patch: return an error if the ICO didn't load in gdk-pixbuf/io-ico.c. - CVE-2017-6311

    2017-03-14 - Jeremy Bicha <jbicha@ubuntu.com> gdk-pixbuf (2.36.5-3) experimental; urgency=medium [ Jeremy Bicha ] * Add new libgdk-pixbuf2.0-bin package to install thumbnailer binary and metadata needed by gnome-desktop 3.23 (LP: #1665602) * Have libgdk-pibxuf2.0-0 recommend libgdk-pixbuf2.0-bin * debian/rules: Change dh_install's --list-missing to --fail-missing to catch this issue sooner next time [ Iain Lane ] * debian/rules: Don't use -X.la - it's error prone as it does substring matching instead of globbing. Instead use `find ... -delete' to remove *.la files explicitly. * debian/control.*: Update Vcs-* for branch.

    2017-02-16 - Iain Lane <laney@debian.org> gdk-pixbuf (2.36.5-2) unstable; urgency=medium * Unbranch - that was short lived. Upload the stable release to unstable.

    2017-02-14 - Iain Lane <laney@debian.org> gdk-pixbuf (2.36.5-1) experimental; urgency=medium * Branch to experimental - update Vcs-* * New upstream release 2.36.5 + Fix mimetypes for thumbnailer + Handle fseek failure + Fix signed/unsigned handling + Fix an overflow check + Handle extreme scaling better * Bump libglib2.0 BD to 2.48.0, per configure.ac * Try replacing d/p/01-disable-oom-test.patch with d/p/0001-skip-perturb-for-cve-2015-4491-original-test.patch: This should ideally allow the test to be run without OOMing, which is better than not running it at all. (The proper fix is still to be investigated.)

    2017-01-17 - Emilio Pozuelo Monfort <pochu@debian.org> gdk-pixbuf (2.36.4-1) unstable; urgency=medium * New upstream release.

    2017-01-09 - Iain Lane <laney@debian.org> gdk-pixbuf (2.36.3-1) unstable; urgency=medium [ Emilio Pozuelo Monfort ] * New upstream release.

    2016-12-22 - Michael Biebl <biebl@debian.org> gdk-pixbuf (2.36.2-1) unstable; urgency=medium * New upstream release.

    2016-12-17 - Michael Biebl <biebl@debian.org> gdk-pixbuf (2.36.1-1) unstable; urgency=medium * New upstream release.

    2016-09-19 - Michael Biebl <biebl@debian.org> gdk-pixbuf (2.36.0-1) unstable; urgency=medium * New upstream release.

    2016-09-13 - Michael Biebl <biebl@debian.org> gdk-pixbuf (2.35.5-1) unstable; urgency=medium * New upstream development release. * Drop 02-tests-Make-sure-to-NULL-terminate-the-arguments-pass.patch, merged upstream. * Bump debhelper compat level to 10. * Use dh_install --list-missing to show uninstalled files and exclude libtool .la files.

    Advertisement
    Advertisement