libqt5gui5_5.7.1+dfsg-2ubuntu4~1_amd64.deb


Advertisement

Description

libqt5gui5 - Qt 5 GUI module

Distribution: Ubuntu 17.04 (Zesty Zapus)
Repository: Ubuntu Main amd64
Package name: libqt5gui5
Package version: 5.7.1+dfsg
Package release: 2ubuntu4~1
Package architecture: amd64
Package type: deb
Installed size: 9.17 KB
Download size: 2.31 MB
Official Mirror: archive.ubuntu.com
Qt is a cross-platform C++ application framework. Qt's primary feature is its rich set of widgets that provide standard GUI functionality. The QtGui module extends QtCore with GUI functionality.

Replaces

  • libqt5egldeviceintegration5 << 5.6.0~beta+dfsg-5~
  • libqt5xcbqpa5 << 5.6.0~beta+dfsg-5~

    Download

    Source package: qtbase-opensource-src

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libqt5gui5 deb package:
      # sudo apt-get install libqt5gui5

    Changelog

    2017-02-09 - Timo Jyrinki <timo-jyrinki@ubuntu.com> qtbase-opensource-src (5.7.1+dfsg-2ubuntu4~1) zesty; urgency=medium [ Marco Trevisan (Treviño) ] * debian/patch/qdbus-tray-icon-use-runtimedir.patch: - QDBusTrayIcon: try use runtime or cache for icons (LP: #1600136) * debian/patch/qdbus-tray-icon-always-save-icon-in-unity.patch: - QDBusTrayIcon: always save the temp icon in Unity (LP: #1600136)

    2017-01-30 - Timo Jyrinki <timo-jyrinki@ubuntu.com> qtbase-opensource-src (5.7.1+dfsg-2ubuntu3~2) zesty; urgency=medium [ Dmitry Shachnev ] * Backport upstream change to make shortcuts working with global menu on Unity (global_menu_shortcuts.diff, LP: #1380702). [ Timo Jyrinki ] * debian/patches/Add-support-for-selecting-the-printer-plugin-via-the.patch: - Backport from Qt 5.9.

    2017-01-16 - Timo Jyrinki <timo-jyrinki@ubuntu.com> qtbase-opensource-src (5.7.1+dfsg-2ubuntu2~1) zesty; urgency=medium * Disable gold linker also on arm64 and ppc64el (LP: #1656431)

    2016-08-25 - Timo Jyrinki <timo-jyrinki@ubuntu.com> qtbase-opensource-src (5.7.1+dfsg-2ubuntu1~8) zesty; urgency=medium * New upstream release. * Drop patches included in upstream release: - color-fonts.patch - dbusmenu_exclusive_groups.diff - dbusmenu_global_menu.diff - dbustray_use_separate_connections.diff - qplatformmenubar_createmenu.diff - fix-scalable-bitmap-factor-caching.patch - Make-sure-connection-is-not-null-before-using-it.patch - xcb-Send-also-text-plain-when-a-text-uri-list-is-dro.patch * Update symbols and mark private ones. * Adjust tests enablement patch for Qt 5.7 and 5.7.1. * Drop also net-bearer-nm-disconnect-ap-signals7.patch that was upstreamed. * Ubuntu doesn't have package named libssl1.0-dev yet. * debian/patches/QSettings-Avoid-unneeded-sync-on-destruction.patch: - Backport from 5.8 (LP: #1642605) * Disable gold linker also on armhf (LP: #1653529) * Disable gold linker also on amd64 (LP: #1654820) - Now disabled on i386, powerpc, armhf, amd64

    2016-12-25 - Dmitry Shachnev <mitya57@debian.org> qtbase-opensource-src (5.7.1+dfsg-2) unstable; urgency=medium * Backport upstream patch to fix build with gcc 6.3 and newer versions (gcc_6.3.diff; closes: #846996). * Update symbols files from buildds’ logs.

    2016-12-14 - Dmitry Shachnev <mitya57@debian.org> qtbase-opensource-src (5.7.1+dfsg-1) unstable; urgency=medium [ Dmitry Shachnev ] * New upstream final release. * Refresh qsettings_XDG_CONFIG_DIRS.diff and qsettings_simplify_logic.diff. * Build with system libdouble-conversion library (closes: #845372). * Convert to automatic dbgsym packages. * Bump documentation build-dependencies to 5.7.1. * Replace 5.7.1~20161021 with 5.7.1 in the symbols files. * Drop one optional symbol from debian/libqt5network5.symbols. * Make qtbase5-dev suggest default-libmysqlclient-dev. [ Lisandro Damián Nicanor Pérez Meyer ] * Remove a bogus double hostdatadir entry while configuring Qt. Thanks Nick Shaforostoff for the bug! (Closes: 847769).

    2016-11-20 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org> qtbase-opensource-src (5.7.1~20161021+dfsg-6) unstable; urgency=medium [ Dmitry Shachnev ] * Make libqt5network5 depend on libssl1.0.2. It will crash when only newer libssl versions are installed. * Backport upstream patch to fix build on x32 (fix_build_on_x32.diff). * Merge some more entries in the update-copyright script. [ Lisandro Damián Nicanor Pérez Meyer ] * Update symbols files with buildds' logs.

    2016-11-02 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org> qtbase-opensource-src (5.7.1~20161021+dfsg-5) unstable; urgency=medium * Switch libssl-dev to libssl1.0-dev. We can't yet use libssl 1.1.

    2016-11-01 - Dmitry Shachnev <mitya57@debian.org> qtbase-opensource-src (5.7.1~20161021+dfsg-4) unstable; urgency=medium * Drop Build-Conflicts: libmariadbclient-dev, should be no longer needed.

    Advertisement
    Advertisement