libsox-fmt-base_14.4.1-5+deb8u4ubuntu0.1_i386.deb


Advertisement

Description

libsox-fmt-base - Minimal set of SoX format libraries

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Universe i386
Package filename libsox-fmt-base_14.4.1-5+deb8u4ubuntu0.1_i386.deb
Package name libsox-fmt-base
Package version 14.4.1
Package release 5+deb8u4ubuntu0.1
Package architecture i386
Package type deb
Category universe/sound
Homepage http://sox.sourceforge.net
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 29.30 KB
Installed size 274.00 KB
SoX is the swiss army knife of sound processing.
This package contains most audio formats libraries supported by SoX.
Among them: Ogg Vorbis, WAV, AIFF, VOC, SND, AU, GSM, WavPack, LPC10, FLAC,
MATLAB/GNU Octave, Portable Voice Format, AMR and Sound Forge Audio Format.

Alternatives

Package Version Architecture Repository
libsox-fmt-base_14.4.1-5+deb8u4ubuntu0.1_amd64.deb 14.4.1 amd64 Ubuntu Updates Universe
libsox-fmt-base_14.4.1-5_i386.deb 14.4.1 i386 Ubuntu Universe
libsox-fmt-base_14.4.1-5_amd64.deb 14.4.1 amd64 Ubuntu Universe
libsox-fmt-base - - -

Requires

Name Value
libc6 >= 2.4
libflac8 >= 1.3.0
libgsm1 >= 1.0.13
libogg0 >= 1.0rc3
libopencore-amrnb0 -
libopencore-amrwb0 -
libsndfile1 >= 1.0.20
libsox2 >= 14.4.0
libvorbis0a >= 1.1.2
libvorbisenc2 >= 1.1.2
libvorbisfile3 >= 1.1.2
libwavpack1 >= 4.40.0

Replaces

Name Value
libsox-fmt-flac -
libsox-fmt-gsm -
libsox-fmt-libsndfile -
libsox-fmt-ogg -
libsox-fmt-sndfile -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libsox-fmt-base_14.4.1-5+deb8u4ubuntu0.1_i386.deb
Source Package sox

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsox-fmt-base deb package:
    # sudo apt-get install libsox-fmt-base

Files

Path
/usr/lib/i386-linux-gnu/sox/libsox_fmt_amr_nb.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_amr_wb.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_caf.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_fap.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_flac.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_gsm.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_lpc10.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_mat4.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_mat5.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_paf.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_pvf.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_sd2.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_sndfile.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_vorbis.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_w64.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_wavpack.so
/usr/lib/i386-linux-gnu/sox/libsox_fmt_xi.so
/usr/share/doc/libsox-fmt-base/changelog.Debian.gz
/usr/share/doc/libsox-fmt-base/copyright

Changelog

2019-07-29 - Eduardo Barretto <eduardo.barretto@canonical.com>
sox (14.4.1-5+deb8u4ubuntu0.1) xenial-security; urgency=medium
* SECURITY UPDATE: Merge from Debian
- Fixes:
- CVE-2019-8354
- CVE-2019-8356
- CVE-2019-8357
- Fixes overwritten by Debian:
- CVE-2017-11332
- CVE-2017-11358
- CVE-2017-11359
- CVE-2017-15370
- CVE-2017-15371
- CVE-2017-15372
- CVE-2017-15642
- CVE-2017-18189
- Ignored Debian's "override_dh_strip" in debian/rules as this change was
made by mistake
2019-05-10 - Emilio Pozuelo Monfort <pochu@debian.org>
sox (14.4.1-5+deb8u4) jessie-security; urgency=medium
* Non-maintainer upload by the LTS Team.
* CVE-2019-8354, CVE-2019-8355: buffer overflow in valloc functions.
* CVE-2019-8356: stack-based buffer overflow in bitrv2().
* CVE-2019-8357: NULL pointer dereference in lsx_make_lpf().
2019-03-05 - Hugo Lefeuvre <hle@debian.org>
sox (14.4.1-5+deb8u3) jessie-security; urgency=high
* Non-maintainer upload by the LTS Team.
* CVE-2017-15371: reachable assertion in sox_append_comment() (formats.c)
(Closes: #878809).
* CVE-2017-11359: divide-by-zero error wavwritehdr function (wav.c)
(Closes: #870328).
* CVE-2017-11332: divide-by-zero error in startread function (wav.c).
* CVE-2017-11358: invalid memory read in read_samples function (hcom.c).
2019-02-28 - Hugo Lefeuvre <hle@debian.org>
sox (14.4.1-5+deb8u2) jessie-security; urgency=high
* Non-maintainer upload by the LTS Team.
* CVE-2017-15370: heap-based buffer overflow in the ImaExpandS function
of ima_rw.c (Closes: #878810).
* CVE-2017-15372: stack-based buffer overflow in the
lsx_ms_adpcm_block_expand_i function of adpcm.c (Closes: #878808).
* CVE-2017-18189: null pointer dereference caused by corrupt header
specifying zero channels, sending read_channels() into an infinite loop
(Closes: #881121).
* CVE-2017-15642: use-after-free in output_message, triggered by crafted
aiff file (Closes: #882144).
2019-02-24 - Adrian Bunk <bunk@debian.org>
sox (14.4.1-5+deb8u1) jessie-security; urgency=medium
* Non-maintainer upload.
* Add patches for CVE-2014-8145 to series file and really apply fixes.
Thanks to Mike Salvatore for spotting the issue. (Closes: #773720)

See Also

Package Description
libsox-fmt-mp3_14.4.1-5+deb8u4ubuntu0.1_i386.deb SoX MP2 and MP3 format library
libsox-fmt-oss_14.4.1-5+deb8u4ubuntu0.1_i386.deb SoX OSS format I/O library
libsox-fmt-pulse_14.4.1-5+deb8u4ubuntu0.1_i386.deb SoX PulseAudio format I/O library
libsox2_14.4.1-5+deb8u4ubuntu0.1_i386.deb SoX library of audio effects and processing
libsqlite3-tcl_3.11.0-1ubuntu1.3_i386.deb SQLite 3 Tcl bindings
libssh2-1-dev_1.5.0-2ubuntu0.1_i386.deb SSH2 client-side library (development headers)
libssh2-1_1.5.0-2ubuntu0.1_i386.deb SSH2 client-side library
libstd-rust-1.15_1.15.1+dfsg0-1~exp1ubuntu2~16.04.3_i386.deb Rust standard libraries
libstd-rust-1.17_1.17.0+dfsg2-8~ubuntu0.16.04.2_i386.deb Rust standard libraries
libstd-rust-1.21_1.21.0+dfsg1+llvm-0ubuntu3~16.04.1_i386.deb Rust standard libraries
libstd-rust-1.22_1.22.1+dfsg1+llvm-0ubuntu2~16.04.2_i386.deb Rust standard libraries
libstd-rust-1.24_1.24.1+dfsg1+llvm-0ubuntu1~16.04.1_i386.deb Rust standard libraries
libstd-rust-1.25_1.25.0+dfsg1+llvm-0ubuntu1~16.04.1_i386.deb Rust standard libraries
libstd-rust-1.28_1.28.0+dfsg1+llvm-0ubuntu1~16.04.1_i386.deb Rust standard libraries
libstd-rust-1.30_1.30.0+dfsg1+llvm-2ubuntu1~16.04.1_i386.deb Rust standard libraries
Advertisement
Advertisement