libplexus-archiver-java_2.2-1+deb9u1build0.16.04.1_all.deb


Advertisement

Description

libplexus-archiver-java - Archiver plugin for the Plexus compiler system

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Universe i386
Package name libplexus-archiver-java
Package version 2.2
Package release 1+deb9u1build0.16.04.1
Package architecture all
Package type deb
Installed size 209 B
Download size 167.35 KB
Official Mirror archive.ubuntu.com
The Plexus project provides a full software stack for creating and
executing software projects. Based on the Plexus container, the applications
can utilise component-oriented programming to build modular, reusable
components that can easily be assembled and reused.
This package provides the Archiver plugin for Plexus, used to create
JARs and other archives.

Alternatives

Package Version Architecture Repository
libplexus-archiver-java_2.2-1+deb9u1build0.16.04.1_all.deb 2.2 all Ubuntu Updates Universe
libplexus-archiver-java_2.2-1_all.deb 2.2 all Ubuntu Universe
libplexus-archiver-java_2.2-1_all.deb 2.2 all Ubuntu Universe
libplexus-archiver-java - - -

Requires

Name Value
libplexus-containers java
libplexus-io java
libplexus-utils java

Download

Type URL
Binary Package libplexus-archiver-java_2.2-1+deb9u1build0.16.04.1_all.deb
Source Package plexus-archiver

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libplexus-archiver-java deb package:
    # sudo apt-get install libplexus-archiver-java

Files

Path
/usr/share/doc/libplexus-archiver-java/changelog.Debian.gz
/usr/share/doc/libplexus-archiver-java/copyright
/usr/share/java/plexus-archiver-2.2.jar
/usr/share/java/plexus-archiver.jar
/usr/share/maven-repo/org/codehaus/plexus/plexus-archiver/2.2/plexus-archiver-2.2.jar
/usr/share/maven-repo/org/codehaus/plexus/plexus-archiver/2.2/plexus-archiver-2.2.pom
/usr/share/maven-repo/org/codehaus/plexus/plexus-archiver/debian/plexus-archiver-debian.jar
/usr/share/maven-repo/org/codehaus/plexus/plexus-archiver/debian/plexus-archiver-debian.pom

Changelog

2018-11-09 - Mike Salvatore <mike.salvatore@canonical.com>
plexus-archiver (2.2-1+deb9u1build0.16.04.1) xenial-security; urgency=medium
* fake sync from Debian
2018-06-10 - Salvatore Bonaccorso <carnil@debian.org>
plexus-archiver (2.2-1+deb9u1) stretch-security; urgency=high
* Non-maintainer upload by the Security Team.
* Fail when trying to extract outside of dest dir (CVE-2018-1002200)
Fixes arbitrary file write vulnerability using a specially crafted zip
file. (Closes: #900953)
2015-05-05 - Emmanuel Bourg <ebourg@apache.org>
plexus-archiver (2.2-1) unstable; urgency=medium
* Team upload.
* New upstream release
- Added a patch ensuring the compatibility with plexus-io 1.x
* debian/control:
- Mark the version 1.2 as breaking libmaven-assembly-plugin (<= 2.2~beta5-2)
- Updated Standards-Version to 3.9.6 (no changes)
* Moved the package to Git
2013-10-22 - Emmanuel Bourg <ebourg@apache.org>
plexus-archiver (1.2-1) unstable; urgency=low
* Team upload.
* New upstream release
* debian/control:
- Use canonical URLs for the Vcs-* fields
- Updated Standards-Version to 3.9.4 (no changes)
* Bump to debhelper 9 compat level
* debian/rules: Improved the clean target
* debian/watch: Updated to watch the new release tags on Github
* Removed debian/orig-tar.sh and use the tarball from Github directly
2011-05-29 - Damien Raude-Morvan <drazzib@debian.org>
plexus-archiver (1.0~alpha12-3) unstable; urgency=low
* Add myself to Uploaders.
* Bump Standards-Version to 3.9.2: no changes needed.
* Fix FTBFS: remove version param (deprecated in debian-ant-helper)
and use POM version (Closes: #628337).
* Use mh_clean in clean rule.
* Bump to debhelper 7 compat level.
* Switch to source format 3.0 (quilt).
2009-07-09 - Ludovic Claude <ludovic.claude@laposte.net>
plexus-archiver (1.0~alpha12-2) unstable; urgency=low
* Fix versions in the POM
2009-03-19 - Ludovic Claude <ludovic.claude@laposte.net>
plexus-archiver (1.0~alpha12-1) experimental; urgency=low
* New upstream release, add myself to Uploaders
* Change section to java
* Add the Maven POM to the package,
* Add a Build-Depends-Indep dependency on maven-repo-helper
* Use mh_installpom and mh_installjar to install the POM and the jar to the
Maven repository
* Remove the patch for the POM as it's no longer needed
* Remove the dependency on java2-runtime and default-java as this is a library
* Remove the Build dependency on quilt as it's no longer needed
2008-12-26 - Torsten Werner <twerner@debian.org>
plexus-archiver (1.0~alpha10-2) unstable; urgency=low
* Change Depends: default-java to default-jre.
2008-12-09 - Torsten Werner <twerner@debian.org>
plexus-archiver (1.0~alpha10-1) unstable; urgency=low
* Initial release. (Closes: #475780)

See Also

Package Description
libplexus-utils-java-doc_1.5.15-4+deb8u1build0.16.04.1_all.deb API Documentation for plexus-utils
libplexus-utils-java_1.5.15-4+deb8u1build0.16.04.1_all.deb utilities for the Plexus framework
libplist-utils_1.12-3.1ubuntu0.16.04.1_i386.deb Apple property list converter
libpng3_1.2.54-1ubuntu1.1_i386.deb PNG library - runtime
libpoco-dev_1.3.6p1-5.1ubuntu0.1_i386.deb C++ Portable Components (POCO) Development files
libpococrypto9v5_1.3.6p1-5.1ubuntu0.1_i386.deb C++ Portable Components (POCO) Crypto library
libpocodata9v5_1.3.6p1-5.1ubuntu0.1_i386.deb C++ Portable Components (POCO) Data library
libpocofoundation9v5_1.3.6p1-5.1ubuntu0.1_i386.deb C++ Portable Components (POCO) Foundation library
libpocomysql9v5_1.3.6p1-5.1ubuntu0.1_i386.deb C++ Portable Components (POCO) MySQL library
libpoconet9v5_1.3.6p1-5.1ubuntu0.1_i386.deb C++ Portable Components (POCO) Network library
libpoconetssl9v5_1.3.6p1-5.1ubuntu0.1_i386.deb C++ Portable Components (POCO) Network library with SSL
libpocoodbc9v5_1.3.6p1-5.1ubuntu0.1_i386.deb C++ Portable Components (POCO) ODBC library
libpocosqlite9v5_1.3.6p1-5.1ubuntu0.1_i386.deb C++ Portable Components (POCO) SQLite library
libpocoutil9v5_1.3.6p1-5.1ubuntu0.1_i386.deb C++ Portable Components (POCO) Util library
libpocoxml9v5_1.3.6p1-5.1ubuntu0.1_i386.deb C++ Portable Components (POCO) XML library
Advertisement
Advertisement