libkf5config-bin_5.18.0-0ubuntu1.1_i386.deb


Advertisement

Description

libkf5config-bin - configuration settings framework for Qt

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Universe i386
Package filename libkf5config-bin_5.18.0-0ubuntu1.1_i386.deb
Package name libkf5config-bin
Package version 5.18.0
Package release 0ubuntu1.1
Package architecture i386
Package type deb
Category universe/libs
Homepage https://projects.kde.org/projects/frameworks/kconfig
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 34.46 KB
Installed size 128.00 KB
KConfig provides an advanced configuration system. It is made of two
parts: KConfigCore and KConfigGui.
KConfigCore provides access to the configuration files themselves. It
features:
- centralized definition: define your configuration in an XML file
and use `kconfig_compiler` to generate classes to read and write
configuration entries.
- lock-down (kiosk) support.
KConfigGui provides a way to hook widgets to the configuration so
that they are automatically initialized from the configuration and
automatically propagate their changes to their respective
configuration files.
This package is part of KDE Frameworks 5.
This package contains runtime files for KConfig.

Alternatives

Package Version Architecture Repository
libkf5config-bin_5.36.0-0ubuntu2~ubuntu16.04~ppa1_i386.deb 5.36.0 i386 Kubuntu Backports
libkf5config-bin_5.36.0-0ubuntu2~ubuntu16.04~ppa1_amd64.deb 5.36.0 amd64 Kubuntu Backports
libkf5config-bin_5.18.0-0ubuntu1.1_amd64.deb 5.18.0 amd64 Ubuntu Updates Universe
libkf5config-bin_5.18.0-0ubuntu1_i386.deb 5.18.0 i386 Ubuntu Universe
libkf5config-bin_5.18.0-0ubuntu1_amd64.deb 5.18.0 amd64 Ubuntu Universe
libkf5config-bin - - -

Requires

Name Value
libc6 >= 2.4
libkf5configcore5 >= 4.97.0
libqt5core5a >= 5.5.0
libstdc++6 >= 4.1.1

Replaces

Name Value
libkf5configcore5 <= 4.100.0-0ubuntu1~ubuntu14.10~ppa1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libkf5config-bin_5.18.0-0ubuntu1.1_i386.deb
Source Package kconfig

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libkf5config-bin deb package:
    # sudo apt-get install libkf5config-bin

Changelog

2019-08-09 - Rik Mills <rikmills@kubuntu.org>
kconfig (5.18.0-0ubuntu1.1) xenial-security; urgency=medium
* SECURITY UPDATE: malicious .desktop files (and others) would execute
code (LP: #1839432).
- debian/patches/CVE-2019-14744.diff: removes the affected feature as
currently 'unused'.
- CVE-2019-14744
2016-03-07 - Philip Muškovac <yofel@kubuntu.org>
kconfig (5.18.0-0ubuntu1) xenial; urgency=medium
[ Scarlett Clark ]
* New upstream release Xenial
[ Philip Muškovac ]
* New upstream release
2015-11-30 - Maximiliano Curia <maxy@debian.org>
kconfig (5.16.0-1) unstable; urgency=medium
* Move ConfigCompiler cmake files to the -bin-dev package.
* New upstream release (5.16.0).
2015-11-11 - Scarlett Clark <sgclark@kubuntu.org>
kconfig (5.15.0-0ubuntu3) UNRELEASED; urgency=medium
* Fix merge madness.
2015-10-27 - Maximiliano Curia <maxy@debian.org>
kconfig (5.15.0-2~) UNRELEASED; urgency=medium
[ Maximiliano Curia ]
* Move ConfigCompiler cmake files to the -bin-dev package.
[ Scarlett Clark ]
* Everything is failing due to a lack of kconf_update binary
needed at buildtime. Adding libkf5config-bin as a depend
to libkf5config-dev ranther than updating every package 
with the build dependency. 
2015-10-09 - Maximiliano Curia <maxy@debian.org>
kconfig (5.15.0-1) unstable; urgency=medium
* New upstream release (5.15.0).
* Update symbols files from buildds logs (5.14.0-1).
* Update symbols files.
2015-11-03 - Philip Muškovac <yofel@kubuntu.org>
kconfig (5.15.0-0ubuntu2) xenial; urgency=medium
* Fix autopackagetests by adding allow-stderr to the requirements.
2015-10-07 - Jonathan Riddell <jriddell@ubuntu.com>
kconfig (5.15.0-0ubuntu1) wily; urgency=medium
[ Scarlett Clark ]
* Vivid backport
[ Jonathan Riddell ]
* new upstream release
2015-09-15 - Maximiliano Curia <maxy@debian.org>
kconfig (5.14.0-1) unstable; urgency=medium
* New upstream release (5.14.0).
2015-09-17 - Clive Johnston <clivejo@aol.com>
kconfig (5.14.0-0ubuntu1) wily; urgency=medium
* new upstream release
* Removing missing symbols after automatic update

See Also

Package Description
libkf5config-data_5.18.0-0ubuntu1.1_all.deb configuration settings framework for Qt
libkf5config-dev_5.18.0-0ubuntu1.1_i386.deb configuration settings framework for Qt
libkf5configcore5_5.18.0-0ubuntu1.1_i386.deb configuration settings framework for Qt
libkf5configgui5_5.18.0-0ubuntu1.1_i386.deb configuration settings framework for Qt
libkf5coreaddons-bin-dev_5.18.0-0ubuntu1.1_i386.deb KDE Frameworks 5 addons to QtCore - development files
libkf5coreaddons-data_5.18.0-0ubuntu1.1_all.deb KDE Frameworks 5 addons to QtCore - data files
libkf5coreaddons-dev_5.18.0-0ubuntu1.1_i386.deb KDE Frameworks 5 addons to QtCore - development files
libkf5coreaddons5_5.18.0-0ubuntu1.1_i386.deb KDE Frameworks 5 addons to QtCore
libkf5eventviews5_15.12.3-0ubuntu1.1_i386.deb event viewing library
libkf5followupreminder5_15.12.3-0ubuntu1.1_i386.deb follow up reminder library
libkf5gravatar5_15.12.3-0ubuntu1.1_i386.deb gravatar library
libkf5incidenceeditorsng5_15.12.3-0ubuntu1.1_i386.deb incidence editors library
libkf5kdepimdbusinterfaces5_15.12.3-0ubuntu1.1_i386.deb KDE PIM D-Bus interfaces library
libkf5kdgantt2-5_15.12.3-0ubuntu1.1_i386.deb Gantt chart library
libkf5kiocore5_5.18.0-0ubuntu1.1_i386.deb Resource and network access abstraction
Advertisement
Advertisement