python3-nltk_3.1-1ubuntu0.1_all.deb


Advertisement

Description

python3-nltk - Python3 libraries for natural language processing

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Universe amd64
Package filename python3-nltk_3.1-1ubuntu0.1_all.deb
Package name python3-nltk
Package version 3.1
Package release 1ubuntu0.1
Package architecture all
Package type deb
Category universe/python
Homepage http://www.nltk.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 831.88 KB
Installed size 4.75 MB
The Natural Language Toolkit (NLTK) is a leading platform for building
Python programs to work with human language data. It provides easy-to-use
interfaces to over 50 corpora and lexical resources such as WordNet,
along with a suite of text processing libraries for classification,
tokenization, stemming, tagging, parsing, and semantic reasoning.
This package contains the modules for Python3.

Alternatives

Package Version Architecture Repository
python3-nltk_3.1-1ubuntu0.1_all.deb 3.1 all Ubuntu Updates Universe
python3-nltk_3.1-1_all.deb 3.1 all Ubuntu Universe
python3-nltk_3.1-1_all.deb 3.1 all Ubuntu Universe
python3-nltk - - -

Requires

Name Value
python3-six >= 1.9.0
python3:any >= 3.3.2-2~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python3-nltk_3.1-1ubuntu0.1_all.deb
Source Package nltk

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-nltk deb package:
    # sudo apt-get install python3-nltk

Changelog

2019-08-08 - Mike Salvatore <mike.salvatore@canonical.com>
nltk (3.1-1ubuntu0.1) xenial-security; urgency=medium
* SECURITY UPDATE: Zip Slip directory traversal via a malicious NLTK package
download
- debian/patches/CVE-2019-14751.patch: use built-in implementation of unzip
- CVE-2019-14751
2015-10-24 - Daniel Stender <debian@danielstender.com>
nltk (3.1-1) unstable; urgency=medium
* New upstream release.
* Don't use nltk/six.py but python-six:
+ added use-six-package.diff.
+ stripe out nltk/six.py via Files-Excluded in deb/copyright.
* deb/control: bumped X-Python-Version to 2.7.
* Added deb/README.Debian with info where to find a list of changes
(use override for dh_installdocs in deb/rules to contribute it
into both binaries).
2015-09-10 - Daniel Stender <debian@danielstender.com>
nltk (3.0.5-1) unstable; urgency=medium
* New upstream release.
* deb/control: added six to Depends.
* deb/rules: removed override for dh_installdocs (README.txt dropped).
* added deb/source/options.
2015-07-15 - Daniel Stender <debian@danielstender.com>
nltk (3.0.4-1) unstable; urgency=medium
* New upstream release.
2015-06-15 - Daniel Stender <debian@danielstender.com>
nltk (3.0.3-1) unstable; urgency=medium
* New upstream release.
2015-04-27 - Daniel Stender <debian@danielstender.com>
nltk (3.0.2-1) unstable; urgency=medium
* New upstream release.
* deb/control: added Tkinter to Recommends.
* deb/copyright: expanded copyright spans.
* deb/rules: added override for auto_install with fix of incorrect
permission in nltk/test/.
* deb/watch: watch pypi.debian.net.
* Added deb/source/local-options.
2014-10-11 - Daniel Stender <debian@danielstender.com>
nltk (3.0.0-1) unstable; urgency=medium
* Initial release (Closes: #279422, LP: #1155282).

See Also

Package Description
python3-novaagent_2.1.18-0ubuntu1~16.04.0_all.deb Python 3 module for Rackspace Public Cloud Guest Agent
python3-novaclient_3.3.1-2ubuntu1_all.deb client library for OpenStack Compute API - 3.x
python3-openstackclient_2.3.1-0ubuntu1_all.deb OpenStack Command-line Client - Python 3.x
python3-os-brick_1.2.0-2ubuntu0.3_all.deb Library for managing local volume attaches - Python 3.x
python3-oslo-concurrency_3.7.1-0ubuntu1.1_all.deb transitional dummy package for python3-oslo-concurrency
python3-oslo-context_2.2.0-2ubuntu1_all.deb transitional dummy package for python3-oslo-context
python3-oslo-middleware_3.8.0-2ubuntu1_all.deb transitional dummy package for python3-oslo-middleware
python3-oslo.concurrency_3.7.1-0ubuntu1.1_all.deb oslo.concurrency library - Python 3.x
python3-oslo.context_2.2.0-2ubuntu1_all.deb WSGI context helpers for OpenStack - Python 3.x
python3-oslo.messaging_4.6.1-2ubuntu2_all.deb oslo messaging library - Python 3.x
python3-oslo.middleware_3.8.0-2ubuntu1_all.deb various WSGI middleware components for OpenStack - Python 3.x
python3-oslo.versionedobjects_1.8.0-1ubuntu1_all.deb deals with DB schema versions and code expectations - Python 3.x
python3-photutils_0.2.1-5ubuntu1~16.04_amd64.deb Astropy affiliated package for image photometry (Python 3)
python3-pip_8.1.1-2ubuntu0.4_all.deb alternative Python package installer - Python 3 version of the package
python3-powerline_2.3-1ubuntu0_all.deb powerline python3 library
Advertisement
Advertisement