python-web2py_2.12.3-1ubuntu0.1_all.deb


Advertisement

Description

python-web2py - High-level Python web development framework

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Universe amd64
Package filename python-web2py_2.12.3-1ubuntu0.1_all.deb
Package name python-web2py
Package version 2.12.3
Package release 1ubuntu0.1
Package architecture all
Package type deb
Category universe/python
Homepage http://www.web2py.com
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 4.19 MB
Installed size 8.63 MB
web2py is a free, open-source web framework for agile development of
secure database-driven web applications; it is written in Python and
programmable in Python. Web2py is a full-stack framework, meaning that
it contains all the components you need to build fully functional web
applications. Web2py was inspired by Ruby on Rails and Django, and
follows a Model View Controller design.
This package includes an example site, an internal web server and the
administration tools to develop web sites with web2py.

Alternatives

Package Version Architecture Repository
python-web2py_2.12.3-1ubuntu0.1_all.deb 2.12.3 all Ubuntu Updates Universe
python-web2py_2.12.3-1_all.deb 2.12.3 all Ubuntu Universe
python-web2py_2.12.3-1_all.deb 2.12.3 all Ubuntu Universe
python-web2py - - -

Requires

Name Value
python-gluon -
python:any -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-web2py_2.12.3-1ubuntu0.1_all.deb
Source Package web2py

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-web2py deb package:
    # sudo apt-get install python-web2py

Changelog

2019-06-18 - Emilia Torino <emilia.torino@canonical.com>
web2py (2.12.3-1ubuntu0.1) xenial-security; urgency=medium
* SECURITY UPDATE: remote code execution
- debian/patches/CVE-2016-3957-1.patch: more secure sessions in
cookies using json
- debian/patches/CVE-2016-3957-2.patch: restored pickles in sessions
- debian/patches/CVE-2016-3957-3.patch: fixed sessions for long keys
- CVE-2016-3957
- CVE-2016-3954
- CVE-2016-3953
* SECURITY UPDATE: brute force password attack
- debian/patches/CVE-2016-10321.patch: check if host is denied before
verifying passwords
- CVE-2016-10321
* SECURITY UPDATE: information disclosure
- debian/patches/CVE-2016-3952-1.patch: do not leak global settings into
request object
- debian/patches/CVE-2016-3952-2.patch: adding back cmd_options
- debian/patches/CVE-2016-3952-3.patch: simplified beautify example
- debian/patches/CVE-2016-3952-4.patch: fixing error due to removing 
global settings from request
- debian/patches/CVE-2016-3952-5.patch: fixing typo on previous patch
- CVE-2016-3952 
2015-09-26 - José L. Redrejo Rodríguez <jredrejo@debian.org>
web2py (2.12.3-1) unstable; urgency=medium
[ José L. Redrejo Rodríguez]
* Removed gtk patch, no needed now as tk looks good on Gnome  
* Added extras directory to the instalation
* Added apache configuration file to examples (Closes: #777696)
* Removed python-support references (Closes: #798479)
* Bump Standards-Version to 3.9.6 (no changes needed)
[ Raphael Lechner ]
* New upstream release (Closes: #689658, #772360)
* Refreshed patches
* Add version patch
* Add fix_websocket_messaging patch
2015-09-07 - Piotr Ożarowski <piotr@debian.org>
web2py (1.99.7-2) unstable; urgency=low
* Team upload.
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
* Use empty lines to separate paragraphs in debian/control.
[ Ana Rodríguez López ]
* Replace python-support with dh-python (Closes: #786088)
2012-03-12 - José L. Redrejo Rodríguez <jredrejo@debian.org>
web2py (1.99.7-1) unstable; urgency=low
* New upstream release
* Refreshed gtk_gui and fix_interpreters patches
2011-12-14 - José L. Redrejo Rodríguez <jredrejo@debian.org>
web2py (1.99.4-1) unstable; urgency=low
* New upstream release
* Refreshed gtk_gui and avoid_upgrading patches
* Fixed bug in debian/patches/launcher (Closes: #650721)
2011-11-04 - José L. Redrejo Rodríguez <jredrejo@debian.org>
web2py (1.99.2.1-1) unstable; urgency=low
* Updated upstream sources with real 1.99.2 version
* Ensure python-gtk2 is not needed to run web2py, fixing 
debian/patches/gtk_gui (Closes: #646931)
* Refreshed debian/patches/avoid_updating patch
2011-10-01 - José L. Redrejo Rodríguez <jredrejo@debian.org>
web2py (1.99.2-2) unstable; urgency=low
* Fixed paths in Vcs* fields (Closes: #643924) 
2011-09-26 - José L. Redrejo Rodríguez <jredrejo@debian.org>
web2py (1.99.2-1) unstable; urgency=low
* New upstream version
* Reverted transition to dh_python2 because of bad placement of
files causing importing problems (Closes: #637971)
2011-08-08 - José L. Redrejo Rodríguez <jredrejo@debian.org>
web2py (1.98.2-1) unstable; urgency=low
* New upstream version
* Transition to dh_python2:
- Removed python-support from build dependencies in debian/control
- Bumped python version dependencies to 2.6.6-3 in debian/control
2011-06-27 - José L. Redrejo Rodríguez <jredrejo@debian.org>
web2py (1.97.1-1) unstable; urgency=low
* New upstream version
* Refreshed debian/patches/launcher to fix bug when used for first time
* Moved most examples from python-web2py to python-gluon package

See Also

Package Description
python-wokkel_0.7.1-1ubuntu0.16.04.1_all.deb collection of enhancements for Twisted
python3-acme_0.31.0-2~ubuntu16.04.1_all.deb ACME protocol library for Python 3
python3-aplpy_1.0-4~16.04_all.deb Astronomical Plotting Library in Python 3
python3-aptdaemon.test_1.1.1+bzr982-0ubuntu14.2_all.deb Test environment for aptdaemon clients
python3-astroquery_0.2.4+dfsg-1ubuntu2_all.deb Python online astronomical database querying (Python 3)
python3-astroscrappy_1.0.3-7~16.04_amd64.deb Optimized Cosmic Ray Annihilation in Python 3
python3-audit_2.4.5-1ubuntu2.1_amd64.deb Python3 bindings for security auditing
python3-botocore_1.4.70-1~16.04.0_all.deb Low-level, data-driven core of boto 3 (Python 3)
python3-bottle_0.12.7-1+deb8u1build0.16.04.1_all.deb fast and simple WSGI-framework for Python3
python3-brotli_1.0.3-1ubuntu1~16.04.1_amd64.deb lossless compression algorithm and format (Python 3 version)
python3-cassandra_2.5.1-1ubuntu0.1_all.deb Python driver for Apache Cassandra (Python 3)
python3-ccdproc_0.3.3-3~16.04_all.deb Basic data reductions of astronomy CCD images (Python 3)
python3-cinderclient_1.6.0-2ubuntu1_all.deb Python bindings to the OpenStack Volume API - Python 3.x
python3-cracklib_2.9.2-1ubuntu1_amd64.deb Python3 bindings for password checker library cracklib2
python3-defusedxml_0.4.1-2ubuntu0.16.04.1_all.deb XML bomb protection for Python stdlib modules (for Python 3)
Advertisement
Advertisement