oxideqt-codecs-extra_1.21.5-0ubuntu0.16.04.1_amd64.deb


Advertisement

Description

oxideqt-codecs-extra - Web browser engine for Qt (codecs)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Universe amd64
Package filename oxideqt-codecs-extra_1.21.5-0ubuntu0.16.04.1_amd64.deb
Package name oxideqt-codecs-extra
Package version 1.21.5
Package release 0ubuntu0.16.04.1
Package architecture amd64
Package type deb
Category universe/libs
Homepage https://launchpad.net/oxide
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 987.96 KB
Installed size 3.61 MB
Oxide is a web browser engine library based on Chromium that makes it easy to
embed web content in your Qt application
This package provides some media codecs needed for the HTML5 <audio> and
<video> tags. Included are the Theora, Vorbis, Opus, VP8, VP9, MP3, AAC
and H.264 codecs

Alternatives

Package Version Architecture Repository
oxideqt-codecs-extra_1.21.5-0ubuntu0.16.04.1_i386.deb 1.21.5 i386 Ubuntu Updates Universe
oxideqt-codecs-extra_1.13.6-0ubuntu1_i386.deb 1.13.6 i386 Ubuntu Universe
oxideqt-codecs-extra_1.13.6-0ubuntu1_amd64.deb 1.13.6 amd64 Ubuntu Universe
oxideqt-codecs-extra - - -

Requires

Name Value
libc6 >= 2.14

Conflicts

Name Value
oxideqt-codecs -

Replaces

Name Value
liboxideqtcore0 << 1.0.0~bzr488
oxideqt-codecs -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package oxideqt-codecs-extra_1.21.5-0ubuntu0.16.04.1_amd64.deb
Source Package oxide-qt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install oxideqt-codecs-extra deb package:
    # sudo apt-get install oxideqt-codecs-extra

Files

Path
/usr/lib/x86_64-linux-gnu/oxide-qt/libffmpeg.so
/usr/share/doc/oxideqt-codecs-extra/changelog.Debian.gz
/usr/share/doc/oxideqt-codecs-extra/copyright

Changelog

2017-03-17 - Chris Coulson <chris.coulson@canonical.com>
oxide-qt (1.21.5-0ubuntu0.16.04.1) xenial-security; urgency=medium
* Update to v1.21.5 (see USN-3236-1)
- Bump Chromium rev to 57.0.2987.110
- Build everything with the correct symbol visibility (-fvisibility=hidden)
- Revert "Decide focus state of webview based on activeFocusItem check of
window", as it caused a regression in popup menu handling (LP: #1649577)
- Unbreak build for older CMake versions
- Unbreak ENABLE_PLUGINS=0 build
- Fix LP: #1654363 - Fails to build with vivid gcc
- Fix LP: #1654512 - Unbreak component build
- Fix LP: #1649577 - Decide the webview focus state from ItemChanged event
not the focusIn/Out events
- Fix LP: #1637194 - Add <select> popup menu implementation to UbuntuWebView
- Fix LP: #1656303 - Test hang at the start of tst_focus.qml
- Fix LP: #1649861 - Session save/restore across oxide versions
- Test that we don't leak context menus or popup menus when a webview
closes
- tst_WebViewPopupMenu.qml should verify that the menu is visible
- Fix CMake error on cross-compilation after installing qtsystems5-dev
- Make WebContextMenu and WebPopupMenu ownership more obvious
- Fix LP: #1647799 - Don't run ubuntu-api and ubuntu-ui test sequences
when built without ENABLE_UITK_WEBVIEW
- Fix LP: #1568296, LP: #1656905 - Change the behaviour of JS dialogs.
+ Alert dialogs requested from background webviews are no longer
displayed immediately, but are delayed until the webview is brought to
the foreground. In this case, window.alert() returns and script
execution continues immediately.
+ Confirm and prompt dialogs from background webviews are suppressed.
+ Dialogs are automatically dismissed if another webview is brought to
the foreground.
+ Before Unload dialogs will only be displayed if they are associated
with a navigation that is application initiated or triggered from a
user gesture. Otherwise, the navigation will proceed without a prompt.
- Remove the openerName parameter from WebContextMenuDesktop.qml
- Fix a case where the JavaScriptDialog implementation could leak
- Fix LP: #1637195 - Add JS dialog implementation to UbuntuWebView
- Emit warnings when trying to provide dialog components with UbuntuWebView
- Use AuxiliaryUIFactory for legacy UI components, and add a "Legacy"
prefix to those classes
- Rename qt::Web{Context,Popup}MenuImpl to qt::Web{Context,Popup}MenuHost
for consistency with JavaScriptDialogHost
- Fix LP: #1665978 - Sync ParamTraits for content::WebPreferences to make
double-tap-to-zoom work again
- Fix LP: #1668614 - Fix build failure with GCC 4.8 due to lack of
stdatomic.h
* Refresh gross-hack-for-dual-ffmpeg-build.patch
* Drop debian/patches/lp1642317.patch - fixed upstream

See Also

Package Description
p7zip-full_9.20.1~dfsg.1-4.2ubuntu0.1_amd64.deb 7z and 7za file archivers with high compression ratio
p7zip_9.20.1~dfsg.1-4.2ubuntu0.1_amd64.deb 7z file archiver with high compression ratio
pacemaker-remote_1.1.14-2ubuntu1.6_amd64.deb cluster resource manager proxy daemon for remote nodes
packagekit-backend-smart_0.8.17-4ubuntu6~gcc5.4ubuntu1.4_amd64.deb Smart backend for PackageKit
packagekit-gtk3-module_0.8.17-4ubuntu6~gcc5.4ubuntu1.4_amd64.deb Install fonts automatically using PackageKit
packagekit-plugin-click_0.4.43+16.04.20170613-0ubuntu1_amd64.deb Click packages (PackageKit plugin)
parallel_20161222-1~ubuntu0.16.04.1_all.deb build and execute command lines from standard input in parallel
parsec47-data_0.2.dfsg1-8~16.04_all.deb retromodern hispeed shmup - game data
parsec47_0.2.dfsg1-8~16.04_amd64.deb retromodern hispeed shmup
partitionmanager_1.2.1-0ubuntu1.1_amd64.deb file, disk and partion management for KDE
patchelf_0.9-1~ubuntu16.04.1_amd64.deb modify properties of ELF executables
pcmanfm_1.2.4-1ubuntu0.1_amd64.deb extremely fast and lightweight file manager
pcs_0.9.149-1ubuntu1.1_amd64.deb Pacemaker Configuration System
pcscd_1.8.14-1ubuntu1.16.04.1_amd64.deb Middleware to access a smart card using PC/SC (daemon side)
pdns-recursor_4.0.0~alpha2-2ubuntu0.1_amd64.deb PowerDNS recursor
Advertisement
Advertisement