nasm_2.11.08-1ubuntu0.1_amd64.deb


Advertisement

Description

nasm - General-purpose x86 assembler

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Universe amd64
Package name nasm
Package version 2.11.08
Package release 1ubuntu0.1
Package architecture amd64
Package type deb
Installed size 4.04 KB
Download size 1.48 MB
Official Mirror archive.ubuntu.com
Netwide Assembler.  NASM will currently output flat-form binary files,
a.out, COFF and ELF Unix object files, and Microsoft 16-bit DOS and
Win32 object files.
Also included is NDISASM, a prototype x86 binary-file disassembler
which uses the same instruction table as NASM.
NASM is released under the GNU Lesser General Public License (LGPL).

Alternatives

Package Version Architecture Repository
nasm_2.11.08-1ubuntu0.1_i386.deb 2.11.08 i386 Ubuntu Updates Universe
nasm_2.11.08-1_i386.deb 2.11.08 i386 Ubuntu Universe
nasm_2.11.08-1_amd64.deb 2.11.08 amd64 Ubuntu Universe
nasm - - -

Requires

Name Value
dpkg >= 1.15.4
install-info -
libc6 >= 2.14

Download

Type URL
Binary Package nasm_2.11.08-1ubuntu0.1_amd64.deb
Source Package nasm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install nasm deb package:
    # sudo apt-get install nasm

Changelog

2018-06-28 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
nasm (2.11.08-1ubuntu0.1) xenial-security; urgency=medium
* SECURITY UPDATE: code execution via heap use-after-free
- debian/patches/CVE-2017-10686-1.patch: don't call free_mmacro in
preproc.c.
- debian/patches/CVE-2017-10686-2.patch: free token's text if only it
has been modified in preproc.c.
- CVE-2017-10686
* SECURITY UPDATE: heap buffer overflow
- debian/patches/CVE-2017-11111.patch: only concat tok->text if we
accounted for its size in preproc.c.
- CVE-2017-11111
* SECURITY UPDATE: NULL pointer dereference in paste_tokens
- debian/patches/CVE-2017-14228.patch: check length in preproc.c.
- CVE-2017-14228
* SECURITY UPDATE: DoS via macro calls with wrong number of arguments
- debian/patches/CVE-2017-17810.patch: check arguments in preproc.c.
- CVE-2017-17810
* SECURITY UPDATE: DoS via heap over-read
- debian/patches/CVE-2017-17812.patch: check for data to process in
preproc.c.
- CVE-2017-17812
* SECURITY UPDATE: DoS via missing check
- debian/patches/CVE-2017-17815.patch: don't leave nparam_max less than
nparam_min in preproc.c.
- CVE-2017-17815
* SECURITY UPDATE: DoS via incorrect validation
- debian/patches/CVE-2017-17819.patch: check for NULL pointer in
preproc.c.
- CVE-2017-17819
* SECURITY UPDATE: heap-based overread
- debian/patches/CVE-2018-8881.patch: handle unterminated strings in
preproc.c.
- CVE-2018-8881
* The above patches also fix the following CVEs:
- CVE-2017-17811
- CVE-2017-17813
- CVE-2017-17814
- CVE-2017-17816
- CVE-2017-17817
- CVE-2017-17818
- CVE-2017-17820
2016-01-11 - Anibal Monsalve Salazar <anibal@debian.org>
nasm (2.11.08-1) unstable; urgency=medium
* New upstream version 2.11.08
* Update debian/copyright
* Update homepage in debian/control
* Make the build reproducible (timestamps)
Add 04-reproducible-build.patch
Patch by Valentin Lorentz
Closes: #796335
2014-11-12 - Anibal Monsalve Salazar <anibal@debian.org>
nasm (2.11.06-1really2.11.05-1) unstable; urgency=low
* Upload 2.11.05-1 to unstable.
2.11.06-1 in unstable makes syslinux FTBFS.
Closes: #769160.
2014-11-05 - Anibal Monsalve Salazar <anibal@debian.org>
nasm (2.11.06-1) unstable; urgency=medium
* Debian policy version is 3.9.6.
* New upstream version 2.11.06.
* Refresh patches.
2014-09-09 - Anibal Monsalve Salazar <anibal@debian.org>
nasm (2.11.05-1) unstable; urgency=medium
* New upstream version 2.11.05.
* Use default compression for binary packages.
* Refresh patches.
2014-02-16 - Anibal Monsalve Salazar <anibal@debian.org>
nasm (2.11-1) unstable; urgency=medium
* New upstream version 2.11 
2013-12-29 - Anibal Monsalve Salazar <anibal@debian.org>
nasm (2.10.09-1) unstable; urgency=low
* New upstream version 2.10.09
* Debian policy version is 3.9.5
* Update debian/watch
2013-05-25 - Anibal Monsalve Salazar <anibal@debian.org>
nasm (2.10.07-1) unstable; urgency=low
* New upstream version 2.10.07
* Debian policy version is 3.9.4
* debian/rules: pass CPPFLAGS through CFLAGS
Patch by Simon Ruderich
Closes: #681490
2012-06-14 - Anibal Monsalve Salazar <anibal@debian.org>
nasm (2.10.01-1) unstable; urgency=low
* New upstream version 2.10.01
* Enable hardened build flags
* DH compatibility level is 9
2012-04-12 - Anibal Monsalve Salazar <anibal@debian.org>
nasm (2.10-1) unstable; urgency=low
* New upstream version 2.10
* Ship nasmdoc.pdf
Closes: 439434
* Fix out-of-date-standards-version
* Fix spelling-error-in-doc-base-abstract-field

See Also

Package Description
nautilus-image-converter_0.3.1~git20110416-1ubuntu1.16.04.1_amd64.deb nautilus extension to mass resize or rotate images
nautilus-owncloud_2.1.1+dfsg-1ubuntu1.1_all.deb ownCloud integration for Nautilus
ndiswrapper-dkms_1.60-3~ubuntu16.04.3_all.deb Source for the ndiswrapper Linux kernel module (DKMS)
ndiswrapper-source_1.60-3~ubuntu16.04.3_all.deb Source for the ndiswrapper Linux kernel module
ndiswrapper-utils-1.9_1.60-3~ubuntu16.04.3_all.deb Transitional dummy package upgrading to ndiswrapper
ndiswrapper_1.60-3~ubuntu16.04.3_amd64.deb Userspace utilities for the ndiswrapper Linux kernel module
nettle-bin_3.2-1ubuntu0.16.04.1_amd64.deb low level cryptographic library (binary tools)
network-manager-openconnect-gnome_1.2.0-0ubuntu0.16.04.1_amd64.deb network management framework (OpenConnect plugin GNOME GUI)
network-manager-openconnect_1.2.0-0ubuntu0.16.04.1_amd64.deb network management framework (OpenConnect plugin)
network-manager-openvpn-gnome_1.1.93-1ubuntu1.1_amd64.deb network management framework (OpenVPN plugin GNOME GUI)
network-manager-openvpn_1.1.93-1ubuntu1.1_amd64.deb network management framework (OpenVPN plugin core)
network-manager-ssh-gnome_1.2.0-0ubuntu0.16.04.1_amd64.deb network management framework (SSH plugin GNOME GUI)
network-manager-ssh_1.2.0-0ubuntu0.16.04.1_amd64.deb network management framework (SSH plugin core)
network-manager-vpnc-gnome_1.1.93-1ubuntu0.1_amd64.deb network management framework (VPNC plugin GNOME GUI)
network-manager-vpnc_1.1.93-1ubuntu0.1_amd64.deb network management framework (VPNC plugin core)
Advertisement
Advertisement