linux-headers-4.15.0-1045-aws_4.15.0-1045.47~16.04.1_amd64.deb


Advertisement

Description

linux-headers-4.15.0-1045-aws - Linux kernel headers for version 4.15.0 on 64 bit x86 SMP

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Universe amd64
Package filename linux-headers-4.15.0-1045-aws_4.15.0-1045.47~16.04.1_amd64.deb
Package name linux-headers-4.15.0-1045-aws
Package version 4.15.0
Package release 1045.47~16.04.1
Package architecture amd64
Package type deb
Category universe/devel
Homepage -
License -
Maintainer Ubuntu Kernel Team <kernel-team@lists.ubuntu.com>
Download size 944.30 KB
Installed size 10.56 MB
This package provides kernel header files for version 4.15.0 on
64 bit x86 SMP.
This is for sites that want the latest kernel headers.  Please read
/usr/share/doc/linux-headers-4.15.0-1045/debian.README.gz for details.

Alternatives

Package Version Architecture Repository
linux-headers-4.15.0-1045-aws - - -

Requires

Name Value
libc6 >= 2.14
libelf1 >= 0.142
libssl1.0.0 >= 1.0.0
linux-aws-headers-4.15.0-1045 -

Provides

Name Value
linux-headers -
linux-headers-3.0 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package linux-headers-4.15.0-1045-aws_4.15.0-1045.47~16.04.1_amd64.deb
Source Package linux-aws-hwe

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install linux-headers-4.15.0-1045-aws deb package:
    # sudo apt-get install linux-headers-4.15.0-1045-aws

Changelog

2019-08-02 - Kleber Sacilotto de Souza <kleber.souza@canonical.com>
linux-aws-hwe (4.15.0-1045.47~16.04.1) xenial; urgency=medium
* Packaging resync (LP: #1786013)
- [Packaging] resync git-ubuntu-log
- [Packaging] update helper scripts
[ Ubuntu: 4.15.0-1045.47 ]
* CVE-2019-1125
- x86/cpufeatures: Carve out CQM features retrieval
- x86/cpufeatures: Combine word 11 and 12 into a new scattered features word
- x86/speculation: Prepare entry code for Spectre v1 swapgs mitigations
- x86/speculation: Enable Spectre v1 swapgs mitigations
- x86/entry/64: Use JMP instead of JMPQ
- x86/speculation/swapgs: Exclude ATOMs from speculation through SWAPGS
* CVE-2018-12126 // CVE-2018-12127 // CVE-2018-12130 // CVE-2019-11091
- SAUCE: Synchronize MDS mitigations with upstream
* add support for Amazon Graviton PCIe controller (LP: #1834962)
- PCI: al: Add Amazon Annapurna Labs PCIe host controller driver
- SAUCE: [aws] irqchip/gic-v2m: invoke from gic-v3 initialization and add acpi
quirk flow
- SAUCE: [aws] arm64: acpi/pci: invoke _DSM whether to preserve firmware PCI
setup
* linux-aws builds modules which are not shipped (LP: #1836706)
- [Packaging] Start shipping modules-extra
2019-07-04 - Kleber Sacilotto de Souza <kleber.souza@canonical.com>
linux-aws-hwe (4.15.0-1044.46~16.04.1) xenial; urgency=medium
* linux-aws-hwe: 4.15.0-1044.46~16.04.1 -proposed tracker (LP: #1834929)
[ Ubuntu: 4.15.0-1044.46 ]
* linux-aws: 4.15.0-1044.46 -proposed tracker (LP: #1834930)
* hibernation support for linux-aws (LP: #1831940)
- UBUNTU SAUCE [aws]: block: xen-blkfront: consider new dom0 features on
restore
- UBUNTU SAUCE [aws]: ACPICA: Enable sleep button on ACPI legacy wake
- UBUNTU SAUCE [aws]: xen: restore pirqs on resume from hibernation.
- UBUNTU SAUCE [aws]: xen: Only restore the ACPI SCI interrupt in
xen_restore_pirqs.
- mm: rid swapoff of quadratic complexity
- sched/wait: Introduce wait_var_event()
- mm: swapoff: shmem_unuse() stop eviction without igrab()
- UBUNTU SAUCE [aws]: mm: aggressive swapoff
- netlink: Don't shift on 64 for ngroups
2019-06-26 - Stefan Bader <stefan.bader@canonical.com>
linux-aws-hwe (4.15.0-1043.45~16.04.1) xenial; urgency=medium
* linux-aws-hwe: 4.15.0-1043.45~16.04.1 -proposed tracker (LP: #1833965)
[ Ubuntu: 4.15.0-1043.45 ]
* linux-aws: 4.15.0-1043.45 -proposed tracker (LP: #1833967)
* linux: 4.15.0-54.58 -proposed tracker (LP: #1833987)
* Remote denial of service (resource exhaustion) caused by TCP SACK scoreboard
manipulation (LP: #1831638) // CVE-2019-11478
- tcp: refine memory limit test in tcp_fragment()
* CVE-2019-11479
- SAUCE: tcp: add tcp_min_snd_mss sysctl
- SAUCE: tcp: enforce tcp_min_snd_mss in tcp_mtu_probing()
2019-06-06 - Stefan Bader <stefan.bader@canonical.com>
linux-aws-hwe (4.15.0-1041.43~16.04.1) xenial; urgency=medium
[ Ubuntu: 4.15.0-1041.43 ]
* Remote denial of service (resource exhaustion) caused by TCP SACK scoreboard
manipulation (LP: #1831638)
- SAUCE: tcp: tcp_fragment() should apply sane memory limits
* Remote denial of service (system crash) caused by integer overflow in TCP
SACK handling (LP: #1831637)
- SAUCE: tcp: limit payload size of sacked skbs

See Also

Package Description
linux-headers-4.15.0-1047-aws_4.15.0-1047.49~16.04.1_amd64.deb Linux kernel headers for version 4.15.0 on 64 bit x86 SMP
linux-headers-4.15.0-1048-aws_4.15.0-1048.50~16.04.1_amd64.deb Linux kernel headers for version 4.15.0 on 64 bit x86 SMP
linux-headers-4.15.0-1050-aws_4.15.0-1050.52~16.04.1_amd64.deb Linux kernel headers for version 4.15.0 on 64 bit x86 SMP
linux-headers-4.15.0-1051-aws_4.15.0-1051.53~16.04.1_amd64.deb Linux kernel headers for version 4.15.0 on 64 bit x86 SMP
linux-headers-4.4.0-1001-aws_4.4.0-1001.10_amd64.deb Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
linux-headers-4.4.0-1003-aws_4.4.0-1003.12_amd64.deb Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
linux-headers-4.4.0-1003-gke_4.4.0-1003.3_amd64.deb Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
linux-headers-4.4.0-1004-aws_4.4.0-1004.13_amd64.deb Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
linux-headers-4.4.0-1004-kvm_4.4.0-1004.9_amd64.deb Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
linux-headers-4.4.0-1005-gke_4.4.0-1005.6_amd64.deb Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
linux-headers-4.4.0-1006-gke_4.4.0-1006.6_amd64.deb Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
linux-headers-4.4.0-1007-aws_4.4.0-1007.16_amd64.deb Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
linux-headers-4.4.0-1008-gke_4.4.0-1008.8_amd64.deb Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
linux-headers-4.4.0-1009-aws_4.4.0-1009.18_amd64.deb Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
linux-headers-4.4.0-1009-gke_4.4.0-1009.9_amd64.deb Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
Advertisement
Advertisement