libebml-dev_1.3.3-1ubuntu0.1_amd64.deb


Advertisement

Description

libebml-dev - access library for the EBML format (development files)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Universe amd64
Package filename libebml-dev_1.3.3-1ubuntu0.1_amd64.deb
Package name libebml-dev
Package version 1.3.3
Package release 1ubuntu0.1
Package architecture amd64
Package type deb
Category universe/libdevel
Homepage http://dl.matroska.org/downloads/libebml/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 67.25 KB
Installed size 518.00 KB
The libebml library allows one to read and write files using EBML (the
Extensible Binary Meta Language), a binary pendant to XML. Using libebml
makes it easier to extend a file format without breaking support in
older parsers.
This package contains the header files and static libraries needed to
compile applications that use libebml.

Alternatives

Package Version Architecture Repository
libebml-dev_1.3.3-1ubuntu0.1_i386.deb 1.3.3 i386 Ubuntu Updates Universe
libebml-dev_1.3.3-1_i386.deb 1.3.3 i386 Ubuntu Universe
libebml-dev_1.3.3-1_amd64.deb 1.3.3 amd64 Ubuntu Universe
libebml-dev - - -

Requires

Name Value
libebml4v5 = 1.3.3-1ubuntu0.1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libebml-dev_1.3.3-1ubuntu0.1_amd64.deb
Source Package libebml

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libebml-dev deb package:
    # sudo apt-get install libebml-dev

Changelog

2019-07-24 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
libebml (1.3.3-1ubuntu0.1) xenial-security; urgency=medium
* SECURITY UPDATE: heap-based out of bounds read
- debian/patches/CVE-2019-13615-1.patch: check the max size to read
before actually reading in src/EbmlElement.cpp.
- debian/patches/CVE-2019-13615-2.patch: do not output an element with
size Unknown if it's not allowed in src/EbmlElement.cpp.
- debian/patches/CVE-2019-13615-3.patch: exit the max size loop when
there's nothing left possible to find in src/EbmlElement.cpp.
- debian/patches/CVE-2019-13615-4.patch: rework the way we look at the
end boundary when looking an element in a parent in
src/EbmlElement.cpp.
- CVE-2019-13615
2015-10-21 - Matteo F. Vescovi <mfv@debian.org>
libebml (1.3.3-1) unstable; urgency=medium
* New upstream release
2015-10-20 - Matteo F. Vescovi <mfv@debian.org>
libebml (1.3.2-1) unstable; urgency=medium
* New upstream release
2015-08-04 - Sebastian Ramacher <sramacher@debian.org>
libebml (1.3.1-5) unstable; urgency=medium
* Team upload.
* Upload to unstable.
2015-08-03 - Sebastian Ramacher <sramacher@debian.org>
libebml (1.3.1-4) experimental; urgency=medium
* Team upload.
* Rename libebml4 for GCC 5 transition.
2015-04-27 - Matteo F. Vescovi <mfv@debian.org>
libebml (1.3.1-3) unstable; urgency=medium
* Upload to unstable
2015-01-07 - Matteo F. Vescovi <mfv@debian.org>
libebml (1.3.1-2) experimental; urgency=medium
* debian/: pkg-config dependency added
2015-01-07 - Matteo F. Vescovi <mfv@debian.org>
libebml (1.3.1-1) experimental; urgency=medium
* New upstream release
* debian/copyright: DEP-5 compliance added
* debian/rules: source directory parameter dropped
* debian/rules: dh_auto_install stanza dropped
* debian/control: Uploader e-mail address updated
* debian/control: S-V bump 3.9.4 => 3.9.6 (no changes needed)
2013-08-19 - Matteo F. Vescovi <mfv.debian@gmail.com>
libebml (1.3.0-2) unstable; urgency=low
* Upload to unstable (Closes: #720182)
2013-06-29 - Matteo F. Vescovi <mfv.debian@gmail.com>
libebml (1.3.0-1) experimental; urgency=low
* New upstream release
- debian/: SONAME bump libebml3 => libebml4
* debian/control: Standards-Version bumped to 3.9.4
* debian/control: Vcs-* URLs updated

See Also

Package Description
libebml4v5_1.3.3-1ubuntu0.1_amd64.deb access library for the EBML format (shared library)
libegl1-mesa-drivers-lts-utopic_13_amd64.deb Transitional package for libegl1-mesa-drivers-lts-utopic
libegl1-mesa-drivers_12.0.6-0ubuntu0.16.04.1_amd64.deb transitional dummy package
libevolution_3.18.5.2-0ubuntu3.2_amd64.deb evolution libraries
libfaad-dev_2.8.0~cvs20150510-1ubuntu0.1_amd64.deb freeware Advanced Audio Decoder - development files
libfaad2_2.8.0~cvs20150510-1ubuntu0.1_amd64.deb freeware Advanced Audio Decoder - runtime files
libflightcrew-dev_0.7.2+dfsg-6ubuntu0.1_all.deb C++ library development filesfor epub validation
libflightcrew0v5_0.7.2+dfsg-6ubuntu0.1_amd64.deb C++ library for epub validation
libfm-data_1.2.4-1ubuntu1.1_all.deb file management support (common data)
libfm-dev_1.2.4-1ubuntu1.1_amd64.deb file management support (core development files)
libfm-doc_1.2.4-1ubuntu1.1_all.deb file management support (development documentation)
libfm-extra4_1.2.4-1ubuntu1.1_amd64.deb file management support (extra library)
libfm-gtk-data_1.2.4-1ubuntu1.1_all.deb file management support (GTK+ library common data)
libfm-gtk-dev_1.2.4-1ubuntu1.1_amd64.deb file management support (GTK+ GUI development files)
libfm-gtk4_1.2.4-1ubuntu1.1_amd64.deb file management support (GTK+ 2.0 GUI library)
Advertisement
Advertisement