gunicorn_19.4.5-1ubuntu1.1_all.deb


Advertisement

Description

gunicorn - Event-based HTTP/WSGI server

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Universe amd64
Package filename gunicorn_19.4.5-1ubuntu1.1_all.deb
Package name gunicorn
Package version 19.4.5
Package release 1ubuntu1.1
Package architecture all
Package type deb
Category universe/python
Homepage http://gunicorn.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 17.49 KB
Installed size 50.00 KB
Green Unicorn (gunicorn) is an HTTP/WSGI server designed to serve fast clients
or sleepy applications. That is to say; behind a buffering front-end server
such as nginx or lighttpd.
* Optional support for Eventlet, Tornado and Gevent to provide asynchronous
long-polling ("Comet") connections.
* Process management: Gunicorn reaps and restarts workers that die.
* Easy integration with Django and Paster compatible applications (Pylons,
TurboGears 2, etc.
* Load balancing via pre-fork and a shared socket
* Graceful worker process restarts
* Upgrading without losing connections
* Decode chunked transfers on-the-fly, allowing upload progress notifications
or stream-based protocols over HTTP
This is the Python 2 version.

Alternatives

Package Version Architecture Repository
gunicorn_19.4.5-1ubuntu1.1_all.deb 19.4.5 all Ubuntu Updates Universe
gunicorn_19.4.5-1ubuntu1_all.deb 19.4.5 all Ubuntu Universe
gunicorn_19.4.5-1ubuntu1_all.deb 19.4.5 all Ubuntu Universe
gunicorn - - -

Requires

Name Value
python-gunicorn = 19.4.5-1ubuntu1.1
python-pkg-resources -
python-setuptools -
python:any >= 2.6~

Provides

Name Value
httpd-wsgi -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gunicorn_19.4.5-1ubuntu1.1_all.deb
Source Package gunicorn

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gunicorn deb package:
    # sudo apt-get install gunicorn

Changelog

2019-06-14 - Mark Morlino <mark.morlino@canonical.com>
gunicorn (19.4.5-1ubuntu1.1) xenial-security; urgency=medium
* SECURITY UPDATE: Fix HTTP header splitting vulnerability
- debian/patches/CVE-2018-1000164.patch: adds header checking and error handling
- CVE-2018-1000164 
2016-02-17 - Matthias Klose <doko@ubuntu.com>
gunicorn (19.4.5-1ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- Suggest libjs-jquery-flot instead of recommending it, package in universe
2016-01-11 - Chris Lamb <lamby@debian.org>
gunicorn (19.4.5-1) unstable; urgency=medium
* New upstream release.
2016-01-07 - Matthias Klose <doko@ubuntu.com>
gunicorn (19.4.1-1ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- Suggest libjs-jquery-flot instead of recommending it, package in universe
2015-12-10 - Chris Lamb <lamby@debian.org>
gunicorn (19.4.1-1) unstable; urgency=medium
* New upstream release.
2015-11-24 - Chris Lamb <lamby@debian.org>
gunicorn (19.3-3) unstable; urgency=medium
* Correct Python interpreter path references in gunicorn3-debian. Thanks to
Olivier AUDRY <olivier@minas.fr> for the report and patch, although note I
applied it slightly differently keeping the "python" argument consistent
(Closes: #805973)
* Rebase patches with gbp-pq.
2015-10-28 - Chris Lamb <lamby@debian.org>
gunicorn (19.3-2) unstable; urgency=medium
* Correct path in `rm` call to _gaiohttp.py (Closes: #803170)
* wrap-and-sort -sa
* Tidy debian/rules
2015-10-26 - Chris Lamb <lamby@debian.org>
gunicorn (19.3-1) unstable; urgency=medium
* New upstream release (Closes: #803086)
* Update debian/watch to not use deprecated githubredir.
* Refresh 0001-drop-supplemental-groups.patch.
* Refresh 0002-use-system-js-libs.patch.
2015-09-15 - Matthias Klose <doko@ubuntu.com>
gunicorn (19.0-8ubuntu1) wily; urgency=medium
* Merge with Debian; no remaining changes.
* Suggest libjs-jquery-flot instead of recommending it, package in universe.
2015-09-12 - Chris Lamb <lamby@debian.org>
gunicorn (19.0-8) unstable; urgency=medium
* Drop dependency on python-tox now that tests are disabled.
(Closes: #798798)

See Also

Package Description
gvncviewer_0.5.3-1.3ubuntu2.1_amd64.deb VNC viewer using gtk-vnc
gwakeonlan_0.5.1-1.1ubuntu0.1_all.deb wakes up your machines using Wake on LAN
haproxy-doc_1.6.3-1ubuntu0.3_all.deb fast and reliable load balancing reverse proxy (HTML documentation)
havp_0.92a-4ubuntu0.16.04.1_amd64.deb HTTP Anti Virus Proxy
hdf5-helpers_1.8.16+docs-4ubuntu1.1_amd64.deb Hierarchical Data Format 5 (HDF5) - Helper tools
hdf5-tools_1.8.16+docs-4ubuntu1.1_amd64.deb Hierarchical Data Format 5 (HDF5) - Runtime tools
hdhomerun-config-gui_20150826-0ubuntu1.16.04.0_amd64.deb GUI Configuration utility for Silicon Dust HD HomeRun
heimdal-clients_1.7~git20150920+dfsg-4ubuntu1.16.04.1_amd64.deb Heimdal Kerberos - clients
heimdal-kcm_1.7~git20150920+dfsg-4ubuntu1.16.04.1_amd64.deb Heimdal Kerberos - KCM daemon
heimdal-kdc_1.7~git20150920+dfsg-4ubuntu1.16.04.1_amd64.deb Heimdal Kerberos - key distribution center (KDC)
heimdal-servers_1.7~git20150920+dfsg-4ubuntu1.16.04.1_amd64.deb Heimdal Kerberos - server programs
hesiod_3.2.1-3.1~build0.16.04.1_amd64.deb Project Athena's DNS-based directory service - utilities
hollywood_1.8-0ubuntu1~16.04_all.deb fill your console with Hollywood melodrama technobabble
host_9.10.3.dfsg.P4-8ubuntu1.15_all.deb Transitional package
hostapd_2.4-0ubuntu6.6_amd64.deb IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP Authenticator
Advertisement
Advertisement