python-ceph_10.2.11-0ubuntu0.16.04.2_all.deb


Advertisement

Description

python-ceph - Meta-package for python libraries for the Ceph libraries

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main i386
Package filename python-ceph_10.2.11-0ubuntu0.16.04.2_all.deb
Package name python-ceph
Package version 10.2.11
Package release 0ubuntu0.16.04.2
Package architecture all
Package type deb
Category python
Homepage http://ceph.com/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 12.35 KB
Installed size 58.00 KB
Ceph is a massively scalable, open-source, distributed
storage system that runs on commodity hardware and delivers object,
block and file system storage.
This package is a metapackage for all python bindings.

Alternatives

Package Version Architecture Repository
python-ceph_10.2.11-0ubuntu0.16.04.2_all.deb 10.2.11 all Ubuntu Updates Main
python-ceph_10.1.2-0ubuntu1_all.deb 10.1.2 all Ubuntu Main
python-ceph_10.1.2-0ubuntu1_all.deb 10.1.2 all Ubuntu Main
python-ceph - - -

Requires

Name Value
python-cephfs >= 10.2.11-0ubuntu0.16.04.2
python-rados >= 10.2.11-0ubuntu0.16.04.2
python-rbd >= 10.2.11-0ubuntu0.16.04.2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package python-ceph_10.2.11-0ubuntu0.16.04.2_all.deb
Source Package ceph

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-ceph deb package:
    # sudo apt-get install python-ceph

Files

Path
/usr/share/doc/python-ceph/changelog.Debian.gz
/usr/share/doc/python-ceph/copyright

Changelog

2019-05-29 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
ceph (10.2.11-0ubuntu0.16.04.2) xenial-security; urgency=medium
* SECURITY UPDATE: incorrect permissions on dm-crypt keys
- debian/patches/CVE-2018-14662.patch: limit caps allowed to access the
store in qa/suites/rados/singleton/all/mon-config-key-caps.yaml,
qa/workunits/mon/test_config_key_caps.sh, src/mon/MonCap.cc.
- CVE-2018-14662
* SECURITY UPDATE: DoS against OMAPs holding bucket indices
- debian/patches/CVE-2018-16846-pre1.patch: enforce bounds on
max-keys/max-uploads/max-parts in src/rgw/rgw_op.cc,
src/rgw/rgw_op.h, src/rgw/rgw_rest.cc, src/rgw/rgw_rest_swift.cc,
src/common/config_opts.h.
- debian/patches/CVE-2018-16846.patch: fix issues with 'enforce bounds'
patch in src/rgw/rgw_op.cc, src/rgw/rgw_op.h, src/rgw/rgw_rest.cc.
- CVE-2018-16846
2018-10-09 - James Page <james.page@ubuntu.com>
ceph (10.2.11-0ubuntu0.16.04.1) xenial; urgency=medium
* New upstream point release (LP: #1784401).
- d/p/*: Refresh.
* Resolve build hang with RocksDB under i386:
- d/p/0001-CoreLocalArray-class.patch
d/p/0002-core-local-array-type-conversions.patch
d/p/0003-Core-local-statistics.patch: Selected cherry picks
from later Ceph releases with same issue.
2018-07-11 - James Page <james.page@ubuntu.com>
ceph (10.2.10-0ubuntu0.16.04.1) xenial; urgency=medium
* d/watch: Scope to 10.2.x series, use tarball download site.
* New upstream point release (LP: #1780930).
2017-09-26 - James Page <james.page@ubuntu.com>
ceph (10.2.9-0ubuntu0.16.04.1) xenial; urgency=medium
* New upstream point release (LP: #1706566):
- d/p/sleep-recover.patch: Drop, superceeded by upstream fix.
2017-04-21 - James Page <james.page@ubuntu.com>
ceph (10.2.7-0ubuntu0.16.04.1) xenial; urgency=medium
[ Billy Olsen ]
* Start ceph-all after static-network-up (LP: #1636322):
- d/p/start-ceph-all-after-network.patch: add dependency on
the static-network-up event before starting ceph-all.
[ James Page ]
* New upstream point release (LP: #1684527):
- d/p/disable-openssl-linking.patch: Dropped, no longer required.
- d/control: Add BD on libssl-dev to support optional runtime
loading of openssl in the radosgw.
2017-03-09 - James Page <james.page@ubuntu.com>
ceph (10.2.6-0ubuntu0.16.04.1) xenial; urgency=medium
* New upstream stable point release (LP: #1671117):
- d/p/osd-limit-omap-data-in-push-op.patch,rgw_rados-creation_time.patch:
Dropped, included upstream.
- d/p/*: Refresh.
2016-12-14 - James Page <james.page@ubuntu.com>
ceph (10.2.5-0ubuntu0.16.04.1) xenial; urgency=medium
* New upstream stable release (LP: #1649856):
- d/p/32bit-ftbfs.patch: Drop, no longer required.
- d/p/*: Refresh.
- d/ceph-common.install: Switch to RSA keys for drop.ceph.com.
* d/rules: Install upstream provided systemd targets and ensure they
are enabled and started on install to ensure that integrations aligned
to upstream packaging work with Ubuntu packages (LP: #1646583).
* d/ceph.*,d/*.logrotate: Install logrotate configuration
in ceph-common, ensuring that all daemons get log rotation on
log files, deal with removal of logrotate configuration in
ceph for upgrades (LP: #1609866).
2016-10-28 - Frode Nordahl <frode.nordahl@canonical.com>
ceph (10.2.3-0ubuntu0.16.04.2) xenial; urgency=medium
* rgw: Fixes for creation times for buckets (LP: #1587261):
- d/p/rgw_rados-creation_time.patch: Backport fix from upstream master.
Fix logic error that leads to creation time being 0 instead of current
time when creating buckets.

See Also

Package Description
python-cephfs_10.2.11-0ubuntu0.16.04.2_i386.deb Python libraries for the Ceph libcephfs library
python-cinder_8.1.1-0ubuntu3_all.deb Cinder Python libraries
python-cinderclient_1.6.0-2ubuntu1_all.deb Python bindings to the OpenStack Volume API - Python 2.x
python-crypto-doc_2.6.1-6ubuntu0.16.04.3_all.deb cryptographic algorithms and protocols for Python (documentation)
python-crypto_2.6.1-6ubuntu0.16.04.3_i386.deb cryptographic algorithms and protocols for Python
python-cryptography-doc_1.2.3-1ubuntu0.2_all.deb Python library exposing cryptographic recipes and primitives (documentation)
python-cryptography_1.2.3-1ubuntu0.2_i386.deb Python library exposing cryptographic recipes and primitives (Python 2)
python-defusedxml_0.4.1-2ubuntu0.16.04.1_all.deb XML bomb protection for Python stdlib modules (for Python 2)
python-dev_2.7.12-1~16.04_i386.deb header files and a static library for Python (default)
python-django-common_1.8.7-1ubuntu5.11_all.deb High-level Python web development framework (common)
python-django-doc_1.8.7-1ubuntu5.11_all.deb High-level Python web development framework (documentation)
python-django-horizon_9.1.2-0ubuntu5_all.deb Django module providing web based interaction with OpenStack
python-django_1.8.7-1ubuntu5.11_all.deb High-level Python web development framework (Python 2 version)
python-doc_2.7.12-1~16.04_all.deb documentation for the high-level object-oriented language Python
python-ecdsa_0.13-2ubuntu0.16.04.1_all.deb ECDSA cryptographic signature library (Python 2)
Advertisement
Advertisement