libndp-dev_1.4-2ubuntu0.16.04.1_i386.deb


Advertisement

Description

libndp-dev - Library for Neighbor Discovery Protocol (development files)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main i386
Package filename libndp-dev_1.4-2ubuntu0.16.04.1_i386.deb
Package name libndp-dev
Package version 1.4
Package release 2ubuntu0.16.04.1
Package architecture i386
Package type deb
Category libdevel
Homepage http://libndp.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 10.40 KB
Installed size 56.00 KB
libndp is a library for the IPv6 Neighbor Discovery Protocol (NDP).  It
contains functions for building and parsing NDP messages, and provides
a high-level interface for sending and receiving NDP messages on a
network interface.
This package contains the development files.

Alternatives

Package Version Architecture Repository
libndp-dev_1.4-2ubuntu0.16.04.1_amd64.deb 1.4 amd64 Ubuntu Updates Main
libndp-dev_1.4-2_i386.deb 1.4 i386 Ubuntu Main
libndp-dev_1.4-2_amd64.deb 1.4 amd64 Ubuntu Main
libndp-dev - - -

Requires

Name Value
libndp0 = 1.4-2ubuntu0.16.04.1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libndp-dev_1.4-2ubuntu0.16.04.1_i386.deb
Source Package libndp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libndp-dev deb package:
    # sudo apt-get install libndp-dev

Files

Path
/usr/include/ndp.h
/usr/lib/i386-linux-gnu/libndp.a
/usr/lib/i386-linux-gnu/libndp.so
/usr/lib/i386-linux-gnu/pkgconfig/libndp.pc
/usr/share/doc/libndp-dev/changelog.Debian.gz
/usr/share/doc/libndp-dev/copyright

Changelog

2016-05-16 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
libndp (1.4-2ubuntu0.16.04.1) xenial-security; urgency=medium
* SECURITY UPDATE: denial of service via RA messages from sources outside
the local network
- d/p/0001-libndp-validate-the-IPv6-hop-limit.patch: validate hop limit
in libndp/libndp.c.
- d/p/0002-libndb-reject-redirect-and-router-advertisements-fro.patch:
reject redirect and router advertisements from non-link-local in
libndp/libndp.c.
- d/p/0001-fixup-libndp-validate-the-IPv6-hop-limit.patch: allocate
space for the hop limit in libndp/libndp.c.
- CVE-2016-3698
2014-09-29 - Andrew Ayer <agwa@andrewayer.name>
libndp (1.4-2) unstable; urgency=medium
* Remove single-debian-patch option
* Add kfreebsd support
* Bump Standards-Version to 3.9.6 (no changes needed)
2014-07-29 - Andrew Ayer <agwa@andrewayer.name>
libndp (1.4-1) unstable; urgency=high
* Fix grammatical/syntactic errors in extended description.
Thanks to Filipus Klutiero (Closes: #754917)
* Set single-debian-patch and add a patch header.
* New upstream release.  Fixes CVE-2014-3554. (Closes: #756389)
2014-06-30 - Andrew Ayer <agwa@andrewayer.name>
libndp (1.3-1) unstable; urgency=low
* New upstream release.
* debian/watch: fix rule so that correct URL is downloaded.
2014-06-18 - Andrew Ayer <agwa@andrewayer.name>
libndp (1.2-5) unstable; urgency=low
* Disable silent builds so blhc can check for hardening flags
* Add Vcs-* headers to control file (Closes: #751999)
* Mark binary packages as linux-only (Closes: #752000)
2014-06-15 - Andrew Ayer <agwa@andrewayer.name>
libndp (1.2-4) unstable; urgency=low
* Shorten copyright file by defining license text only once
* Move src package and -tools bin package to section "net"
* Remove unnecessary Build-Depends
2014-04-20 - Andrew Ayer <agwa@andrewayer.name>
libndp (1.2-3) unstable; urgency=low
* Make -dbg package "Multi-Arch: same"
* Make package description more informative
* Switch to Standards-Version 3.9.5
2014-04-20 - Andrew Ayer <agwa@andrewayer.name>
libndp (1.2-2) unstable; urgency=low
* Fix debian/copyright to specify correct license.
2014-03-29 - Andrew Ayer <agwa@andrewayer.name>
libndp (1.2-1) unstable; urgency=low
* Initial release (Closes: #742973)

See Also

Package Description
libndp0_1.4-2ubuntu0.16.04.1_i386.deb Library for Neighbor Discovery Protocol
libnettle6_3.2-1ubuntu0.16.04.1_i386.deb low level cryptographic library (symmetric and one-way cryptos)
libnl-3-200_3.2.27-1ubuntu0.16.04.1_i386.deb library for dealing with netlink sockets
libnl-3-dev_3.2.27-1ubuntu0.16.04.1_i386.deb development library and headers for libnl-3
libnl-cli-3-200_3.2.27-1ubuntu0.16.04.1_i386.deb library for dealing with netlink sockets - cli helpers
libnl-cli-3-dev_3.2.27-1ubuntu0.16.04.1_i386.deb development library and headers for libnl-cli-3
libnl-genl-3-200_3.2.27-1ubuntu0.16.04.1_i386.deb library for dealing with netlink sockets - generic netlink
libnl-genl-3-dev_3.2.27-1ubuntu0.16.04.1_i386.deb development library and headers for libnl-genl-3
libnl-idiag-3-200_3.2.27-1ubuntu0.16.04.1_i386.deb library for dealing with netlink sockets - inetdiag interface
libnl-idiag-3-dev_3.2.27-1ubuntu0.16.04.1_i386.deb development library and headers for libnl-genl-3
libnl-nf-3-200_3.2.27-1ubuntu0.16.04.1_i386.deb library for dealing with netlink sockets - netfilter interface
libnl-nf-3-dev_3.2.27-1ubuntu0.16.04.1_i386.deb development library and headers for libnl-nf-3
libnl-route-3-200_3.2.27-1ubuntu0.16.04.1_i386.deb library for dealing with netlink sockets - route interface
libnl-route-3-dev_3.2.27-1ubuntu0.16.04.1_i386.deb development library and headers for libnl-route-3
libnl-xfrm-3-200_3.2.27-1ubuntu0.16.04.1_i386.deb library for dealing with netlink sockets - package transformations
Advertisement
Advertisement