libfwupd-dev_0.8.3-0ubuntu5_i386.deb


Advertisement

Description

libfwupd-dev - development files for libfwupd

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main i386
Package filename libfwupd-dev_0.8.3-0ubuntu5_i386.deb
Package name libfwupd-dev
Package version 0.8.3
Package release 0ubuntu5
Package architecture i386
Package type deb
Category libdevel
Homepage https://github.com/hughsie/fwupd
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 14.63 KB
Installed size 163.00 KB
fwupd is a daemon to allow session software to update device firmware.
You can either use a GUI software manager like GNOME Software to view and
apply updates, the command-line tool or the system D-Bus interface directly.
Currently, firmware updates using the UEFI capsule format and for the
ColorHug are supported. More formats may be supported in the future.
See <https://github.com/hughsie/fwupd> for details
This package provides the development files for libfwupd

Alternatives

Package Version Architecture Repository
libfwupd-dev_0.8.3-0ubuntu5_amd64.deb 0.8.3 amd64 Ubuntu Updates Main
libfwupd-dev_0.7.0-0ubuntu4_i386.deb 0.7.0 i386 Ubuntu Main
libfwupd-dev_0.7.0-0ubuntu4_amd64.deb 0.7.0 amd64 Ubuntu Main
libfwupd-dev - - -

Requires

Name Value
libfwupd1 = 0.8.3-0ubuntu5

Replaces

Name Value
fwupd-dev << 0.5.4-2~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libfwupd-dev_0.8.3-0ubuntu5_i386.deb
Source Package fwupd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libfwupd-dev deb package:
    # sudo apt-get install libfwupd-dev

Files

Path
/usr/include/fwupd-1/fwupd.h
/usr/include/fwupd-1/libfwupd/fwupd-client.h
/usr/include/fwupd-1/libfwupd/fwupd-enums.h
/usr/include/fwupd-1/libfwupd/fwupd-error.h
/usr/include/fwupd-1/libfwupd/fwupd-result.h
/usr/include/fwupd-1/libfwupd/fwupd-version.h
/usr/lib/i386-linux-gnu/libfwupd.so
/usr/lib/i386-linux-gnu/pkgconfig/fwupd.pc
/usr/share/doc/libfwupd-dev/changelog.Debian.gz
/usr/share/doc/libfwupd-dev/copyright
/usr/share/gir-1.0/Fwupd-1.0.gir

Changelog

2019-05-22 - Jian-Ding Chen <tim.chen119@canonical.com>
fwupd (0.8.3-0ubuntu5) xenial; urgency=medium
* debian/patches 0001-Raise-the-metadata-limit-to-10Mb.patch:
- Raise the metadata limit to 10Mb, fix XML mismatch error while fwupdmgr
refresh (LP: #1829813)
2018-08-16 - Mario Limonciello <mario.limonciello@dell.com>
fwupd (0.8.3-0ubuntu4) xenial; urgency=medium
* debian/patches 0001-Do-not-abort-startup-if-the-XML-metadata-file-is-inv.patch:
- Fix a crash from bad metadata (LP: #1780442)
2018-04-04 - Robert Ancell <robert.ancell@canonical.com>
fwupd (0.8.3-0ubuntu3) xenial; urgency=medium
* debian/patches/0001-Use-a-CNAME-to-redirect-to-the-correct-CDN-for-metad.patch:
- Change metadata server to upstream requested one (LP: #1761006)
2018-02-14 - Mario Limonciello <mario.limonciello@dell.com>
fwupd (0.8.3-0ubuntu2) xenial; urgency=medium
* Fix systemd unit for what is actually supported in
systemd 229 in xenial (LP: #1746114)
* This bug also fixes issues with USB devices being closed (LP: #1642812)
2018-01-29 - Mario Limonciello <mario.limonciello@dell.com>
fwupd (0.8.3-0ubuntu1) xenial; urgency=medium
* Move to upstream 0.8.x release branch. (LP: #1746114)
* Drop all patches integrated into this release.
* Refresh symbols
2016-08-11 - Mario Limonciello <mario_limonciello@dell.com>
fwupd (0.7.0-0ubuntu4.3) xenial-proposed; urgency=medium
* Download metadata from Amazon S3 instead. (LP: #1612365)
2016-06-08 - Mario Limonciello <mario_limonciello@dell.com>
fwupd (0.7.0-0ubuntu4.2) xenial-proposed; urgency=medium
* Fix USB audio devices not working properly (LP: #1574079)
2016-04-28 - Mario Limonciello <mario_limonciello@dell.com>
fwupd (0.7.0-0ubuntu4.1) xenial-proposed; urgency=medium
* Add name and summary to Rival Steelseries device (LP: #1575248)
2016-04-14 - Mario Limonciello <mario_limonciello@dell.com>
fwupd (0.7.0-0ubuntu4) xenial; urgency=medium
* Backport UEFI naming to DMI Product Name from master
2016-04-03 - Mario Limonciello <mario_limonciello@dell.com>
fwupd (0.7.0-0ubuntu3) xenial; urgency=medium
* Backport commits from upstream to fix problems on big endian.
* Drop extra patches that are no longer applied
* Require test suite passing on all architectures (LP: #1565114)

See Also

Package Description
libfwupd1_0.8.3-0ubuntu5_i386.deb Firmware update daemon library
libgail-3-0_3.18.9-1ubuntu3.3_i386.deb GNOME Accessibility Implementation Library -- shared libraries
libgail-3-dev_3.18.9-1ubuntu3.3_i386.deb GNOME Accessibility Implementation Library -- development files
libgail-3-doc_3.18.9-1ubuntu3.3_all.deb documentation files of the Gail library
libgail-common_2.24.30-1ubuntu1.16.04.2_i386.deb GNOME Accessibility Implementation Library -- common modules
libgail-dev_2.24.30-1ubuntu1.16.04.2_i386.deb GNOME Accessibility Implementation Library -- development files
libgail-doc_2.24.30-1ubuntu1.16.04.2_all.deb documentation files of the Gail library
libgail18_2.24.30-1ubuntu1.16.04.2_i386.deb GNOME Accessibility Implementation Library -- shared libraries
libgbm-dev-lts-utopic_13_i386.deb Transitional package for libgbm-dev-lts-utopic
libgbm-dev-lts-vivid_13_i386.deb Transitional package for libgbm-dev-lts-vivid
libgbm-dev-lts-wily_13_i386.deb Transitional package for libgbm-dev-lts-wily
libgbm-dev-lts-xenial_13_i386.deb Transitional package for libgbm-dev-lts-xenial
libgbm-dev_18.0.5-0ubuntu0~16.04.1_i386.deb generic buffer management API -- development files
libgbm1-lts-utopic_13_i386.deb Transitional package for libgbm1-lts-utopic
libgbm1-lts-vivid_13_i386.deb Transitional package for libgbm1-lts-vivid
Advertisement
Advertisement