libevview3-3_3.18.2-1ubuntu4.6_i386.deb


Advertisement

Description

libevview3-3 - Document (PostScript, PDF) rendering library - Gtk+ widgets

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main i386
Package filename libevview3-3_3.18.2-1ubuntu4.6_i386.deb
Package name libevview3-3
Package version 3.18.2
Package release 1ubuntu4.6
Package architecture i386
Package type deb
Category libs
Homepage https://wiki.gnome.org/Apps/Evince
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 128.53 KB
Installed size 1.01 MB
This package contains libevview, which provides GTK+ widgets for displaying
documents.

Alternatives

Package Version Architecture Repository
libevview3-3_3.18.2-1ubuntu4.6_amd64.deb 3.18.2 amd64 Ubuntu Updates Main
libevview3-3_3.18.2-1ubuntu4_i386.deb 3.18.2 i386 Ubuntu Main
libevview3-3_3.18.2-1ubuntu4_amd64.deb 3.18.2 amd64 Ubuntu Main
libevview3-3 - - -

Requires

Name Value
gstreamer1.0-plugins-base -
libatk1.0-0 >= 1.12.4
libc6 >= 2.4
libcairo2 >= 1.14.0
libevdocument3-4 >= 3.18.0
libglib2.0-0 >= 2.37.3
libgstreamer-plugins-base1.0-0 >= 1.0.0
libgstreamer1.0-0 >= 1.0.0
libgtk-3-0 >= 3.16.0
libpango-1.0-0 >= 1.14.0

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libevview3-3_3.18.2-1ubuntu4.6_i386.deb
Source Package evince

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libevview3-3 deb package:
    # sudo apt-get install libevview3-3

Files

Path
/usr/lib/i386-linux-gnu/libevview3.so.3
/usr/lib/i386-linux-gnu/libevview3.so.3.0.0
/usr/share/doc/libevview3-3/AUTHORS
/usr/share/doc/libevview3-3/NEWS.gz
/usr/share/doc/libevview3-3/README
/usr/share/doc/libevview3-3/TODO
/usr/share/doc/libevview3-3/changelog.Debian.gz
/usr/share/doc/libevview3-3/copyright
/usr/share/lintian/overrides/libevview3-3

Changelog

2019-07-17 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
evince (3.18.2-1ubuntu4.6) xenial-security; urgency=medium
* SECURITY UPDATE: Buffer overflow
- debian/patches/CVE-2019-1010006-*.patch: remove unused configure
check for cairo_format_stride_for_width and fix overflow checks
in backend/tiff/tiff-document.c.
- CVE-2019-1010006
2019-06-18 - Jamie Strandboge <jamie@ubuntu.com>
evince (3.18.2-1ubuntu4.5) xenial-security; urgency=medium
* apparmor-profile: apply hardening from Ubuntu 18.10
- add preamble for expectations of the profile
- evince{-previewer}: restrict access to DBus system bus (we allow full
access to session, translation and accessibility buses for compatibility)
+ allow Get* to anything polkit allows
+ allow talking to avahi (for printing)
+ allow talking to colord (for printing)
- make the thumbnailer more restrictive (LP: #1794848) (Closes: #909849)
+ remove evince abstraction and use only what is needed from it
+ limit access to DBus session bus
+ generally disallow writes
+ allow reads for non-hidden files
* debian/apparmor-profile.abstraction: apply hardening from Ubuntu 18.10
- disallow access to the dirs of private files (LP: #1788929)
* debian/apparmor-profile: allow /bin/env ixr
2019-04-25 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
evince (3.18.2-1ubuntu4.4) xenial-security; urgency=medium
* SECURITY UPDATE: Uninitialized memory use
- debian/patches/CVE-2019-11459.patch: handle failure
from TIFFREADGBAImageOriented, returning NULL instead
of displaying uninitialized memory in backend/tiff/tiff-document.c.
- CVE-2019-11459
2017-11-30 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
evince (3.18.2-1ubuntu4.3) xenial-security; urgency=medium
* SECURITY UPDATE: command injection in dvi backend
- debian/patches/CVE-2017-1000159.patch: properly quote filename in
backend/dvi/dvi-document.c.
- CVE-2017-1000159
2017-09-29 - Sebastien Bacher <seb128@ubuntu.com>
evince (3.18.2-1ubuntu4.2) xenial; urgency=medium
* debian/patches/git_mimetype_typo.patch:
- remove trailing ";" which leads to non working mailcap, regression
introduced in the previous upload (lp: #1716357)
2017-07-11 - Steve Beattie <sbeattie@ubuntu.com>
evince (3.18.2-1ubuntu4.1) xenial-security; urgency=medium
* SECURITY UPDATE: command injection via cbt files
- debian/patches/CVE-2017-1000083.patch: disable cbt support
entirely as not widely used.
- CVE-2017-1000083
2016-03-08 - Robert Ancell <robert.ancell@canonical.com>
evince (3.18.2-1ubuntu4) xenial; urgency=medium
* debian/control:
- Set breaks/replaces for .desktop file moves
* debian/evince.install:
* debian/evince-common.install:
- Move .desktop files from -common to the main binary (LP: #1553156)
- Remove reference to obsolete evince-gtk.desktop
2016-02-26 - Sebastien Bacher <seb128@ubuntu.com>
evince (3.18.2-1ubuntu3) xenial; urgency=medium
* Rebuild with the new poppler soname
2016-02-24 - Matthias Klose <doko@ubuntu.com>
evince (3.18.2-1ubuntu2) xenial; urgency=medium
* Multiarchify the library packages. LP: #1508590.
* libevdocument3-4: Breaks: evince-hwp (<< 0.1.1-2ubuntu1).

See Also

Package Description
libexempi-dev_2.2.2-2ubuntu0.1_i386.deb library to parse XMP metadata (Development files)
libexempi3_2.2.2-2ubuntu0.1_i386.deb library to parse XMP metadata (Library)
libexif-dev_0.6.21-2ubuntu0.1_i386.deb library to parse EXIF files (development files)
libexif12_0.6.21-2ubuntu0.1_i386.deb library to parse EXIF files
libexiv2-14_0.25-2.1ubuntu16.04.6_i386.deb EXIF/IPTC/XMP metadata manipulation library
libexiv2-dev_0.25-2.1ubuntu16.04.6_i386.deb EXIF/IPTC/XMP metadata manipulation library - development files
libexiv2-doc_0.25-2.1ubuntu16.04.6_all.deb EXIF/IPTC/XMP metadata manipulation library - HTML documentation
libexpat1-dev_2.1.0-7ubuntu0.16.04.5_i386.deb XML parsing C library - development kit
libexpat1_2.1.0-7ubuntu0.16.04.5_i386.deb XML parsing C library - runtime library
libfcitx-config4_4.2.9.1-1ubuntu1.16.04.2_i386.deb Flexible Input Method Framework - configuration support library
libfcitx-core0_4.2.9.1-1ubuntu1.16.04.2_i386.deb Flexible Input Method Framework - library of core funtions
libfcitx-gclient0_4.2.9.1-1ubuntu1.16.04.2_i386.deb Flexible Input Method Framework - D-Bus client library for Glib
libfcitx-qt0_4.2.9.1-1ubuntu1.16.04.2_i386.deb Flexible Input Method Framework - Meta package for Qt library
libfcitx-utils0_4.2.9.1-1ubuntu1.16.04.2_i386.deb Flexible Input Method Framework - utility support library
libfdisk-dev_2.27.1-6ubuntu3.10_i386.deb fdisk partitioning library - headers and static libraries
Advertisement
Advertisement