gstreamer1.0-plugins-good_1.8.3-1ubuntu0.4_i386.deb


Advertisement

Description

gstreamer1.0-plugins-good - GStreamer plugins from the "good" set

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main i386
Package filename gstreamer1.0-plugins-good_1.8.3-1ubuntu0.4_i386.deb
Package name gstreamer1.0-plugins-good
Package version 1.8.3
Package release 1ubuntu0.4
Package architecture i386
Package type deb
Category libs
Homepage http://gstreamer.freedesktop.org/modules/gst-plugins-good.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 1.50 MB
Installed size 5.75 MB
GStreamer is a streaming media framework, based on graphs of filters
which operate on media data.  Applications using this library can do
anything from real-time sound processing to playing videos, and just
about anything else media-related.  Its plugin-based architecture means
that new data types or processing capabilities can be added simply by
installing new plug-ins.
This package contains the GStreamer plugins from the "good" set, a set
of good-quality plug-ins under the LGPL license.

Alternatives

Package Version Architecture Repository
gstreamer1.0-plugins-good_1.8.3-1ubuntu0.4_amd64.deb 1.8.3 amd64 Ubuntu Updates Main
gstreamer1.0-plugins-good_1.8.0-1ubuntu1_i386.deb 1.8.0 i386 Ubuntu Main
gstreamer1.0-plugins-good_1.8.0-1ubuntu1_amd64.deb 1.8.0 amd64 Ubuntu Main
gstreamer1.0-plugins-good - - -

Requires

Name Value
gstreamer1.0-plugins-base -
libaa1 >= 1.4p5
libavc1394-0 >= 0.5.3
libbz2-1.0 -
libc6 >= 2.17
libcaca0 >= 0.99.beta17-1
libcairo-gobject2 >= 1.10.0
libcairo2 >= 1.10.0
libdv4 -
libflac8 >= 1.3.0
libgcc1 >= 1:3.0
libgdk-pixbuf2.0-0 >= 2.22.0
libglib2.0-0 >= 2.43.2
libgstreamer-plugins-base1.0-0 >= 1.8.1
libgstreamer-plugins-good1.0-0 = 1.8.3-1ubuntu0.4
libgstreamer1.0-0 >= 1.8.0
libgudev-1.0-0 >= 146
libiec61883-0 >= 1.2.0
libjack-0.116 -
libjack-jackd2-0 >= 1.9.5~dfsg-14
libjpeg8 >= 8c
liborc-0.4-0 >= 1:0.4.25
libpng12-0 >= 1.2.13-4
libraw1394-11 -
libshout3 -
libsoup2.4-1 >= 2.48
libspeex1 >= 1.2~beta3-1
libstdc++6 >= 4.1.1
libtag1v5 >= 1.9.1-2.4ubuntu1
libv4l-0 >= 0.5.0
libvpx3 >= 1.5.0
libwavpack1 >= 4.60
libx11-6 -
libxdamage1 >= 1:1.1
libxext6 -
libxfixes3 -
zlib1g >= 1:1.1.4

Provides

Name Value
gstreamer1.0-audiosink -
gstreamer1.0-audiosource -
gstreamer1.0-videosink -
gstreamer1.0-videosource -
gstreamer1.0-visualization -

Replaces

Name Value
gstreamer1.0-plugins-bad << 1.1.2

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gstreamer1.0-plugins-good_1.8.3-1ubuntu0.4_i386.deb
Source Package gst-plugins-good1.0

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gstreamer1.0-plugins-good deb package:
    # sudo apt-get install gstreamer1.0-plugins-good

Files

Path
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgst1394.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstaasink.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstalaw.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstalpha.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstalphacolor.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstapetag.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstaudiofx.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstaudioparsers.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstauparse.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstautodetect.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstavi.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstcacasink.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstcairo.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstcamerabin2.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstcutter.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstdebug.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstdeinterlace.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstdtmf.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstdv.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgsteffectv.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstequalizer.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstflac.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstflv.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstflxdec.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstgdkpixbuf.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstgoom.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstgoom2k1.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgsticydemux.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstid3demux.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstimagefreeze.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstinterleave.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstisomp4.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstjack.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstjpeg.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstjpegformat.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstlevel.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstmatroska.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstmonoscope.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstmulaw.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstmultifile.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstmultipart.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstnavigationtest.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstoss4audio.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstossaudio.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstpng.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstreplaygain.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstrtp.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstrtpmanager.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstrtsp.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstshapewipe.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstshout2.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstsmpte.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstsouphttpsrc.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstspectrum.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstspeex.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgsttaglib.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstudp.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstvideo4linux2.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstvideobox.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstvideocrop.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstvideofilter.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstvideomixer.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstvpx.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstwavenc.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstwavpack.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstwavparse.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstximagesrc.so
/usr/lib/i386-linux-gnu/gstreamer-1.0/libgsty4menc.so
/usr/share/doc/gstreamer1.0-plugins-good/AUTHORS
/usr/share/doc/gstreamer1.0-plugins-good/NEWS.gz
/usr/share/doc/gstreamer1.0-plugins-good/README.Debian
/usr/share/doc/gstreamer1.0-plugins-good/README.gz
/usr/share/doc/gstreamer1.0-plugins-good/changelog.Debian.gz
/usr/share/doc/gstreamer1.0-plugins-good/copyright
/usr/share/gstreamer-1.0/presets/GstIirEqualizer10Bands.prs
/usr/share/gstreamer-1.0/presets/GstIirEqualizer3Bands.prs
/usr/share/gstreamer-1.0/presets/GstVP8Enc.prs

Changelog

2017-03-23 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
gst-plugins-good1.0 (1.8.3-1ubuntu0.4) xenial-security; urgency=medium
* SECURITY UPDATE: DoS in gst_aac_parse_sink_setcaps
- debian/patches/CVE-2016-10198.patch: make sure there's enough data in
gst/audioparsers/gstaacparse.c.
- CVE-2016-10198
* SECURITY UPDATE: DoS in qtdemux_tag_add_str_full
- debian/patches/CVE-2016-10199.patch: fix out of bounds read in
gst/isomp4/qtdemux.c.
- CVE-2016-10199
* SECURITY UPDATE: DoS in qtdemux_parse_samples
- debian/patches/CVE-2017-5840.patch: properly increment stts index in
gst/isomp4/qtdemux.c.
- CVE-2017-5840
* SECURITY UPDATE: DoS in gst_avi_demux_parse_ncdt
- debian/patches/CVE-2017-5841.patch: fix out of bounds reads in
gst/avi/gstavidemux.c.
- CVE-2017-5841
* SECURITY UPDATE: DoS in gst_avi_demux_parse_ncdt
- debian/patches/CVE-2017-5845.patch: check size in
gst/avi/gstavidemux.c.
- CVE-2017-5845
2017-01-13 - Iain Lane <iain.lane@canonical.com>
gst-plugins-good1.0 (1.8.3-1ubuntu0.3) xenial; urgency=medium
* Rebase on top of security update again.
2016-11-24 - Iain Lane <iain.lane@canonical.com>
gst-plugins-good1.0 (1.8.3-1ubuntu0.2) xenial; urgency=medium
* Rebase on top of security update.
2016-09-02 - Iain Lane <iain.lane@canonical.com>
gst-plugins-good1.0 (1.8.3-1ubuntu0.1) xenial; urgency=medium
* No-change backport from yakkety to 16.04 (LP: #1619600)
2016-09-01 - Iain Lane <iain.lane@canonical.com>
gst-plugins-good1.0 (1.8.3-1ubuntu1) yakkety; urgency=medium
* Merge with Debian unstable; remaining changes:
+ Import plugins from -bad that are needed for main applications.
- jpegformat
- camerabin2 (+ basecamerabinsrc + photography)
+ Break and Replace -bad versions which contained these plugins.
+ Add a library package containing the shared library and a -dev package for
compiling against it. Add Breaks and Replaces against the plugins packages
which formerly contained files shipped here.
+ Add 'pluginsdir' variable to our added pcfile for compatibility with
some external software
+ debian/control{,.in}: Update Vcs-* for Ubuntu
2016-08-19 - Sebastian Dröge <slomo@debian.org>
gst-plugins-good1.0 (1.8.3-1) unstable; urgency=medium
* New upstream bugfix release.
2016-11-25 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
gst-plugins-good1.0 (1.8.2-1ubuntu0.3) xenial-security; urgency=medium
* SECURITY UPDATE: incomplete fix for flx decoder
- debian/patches/flxdec-bounds3.patch: don't unref() parent in the
chain function in gst/flx/gstflxdec.c.
- debian/patches/flxdec-bounds4.patch: rewrite logic based on
GstByteReader/Writer in gst/flx/flx_color.c, gst/flx/flx_fmt.h,
gst/flx/gstflxdec.c, gst/flx/gstflxdec.h.
- No CVE number
2016-11-22 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
gst-plugins-good1.0 (1.8.2-1ubuntu0.2) xenial-security; urgency=medium
* SECURITY UPDATE: code execution via out-of-bounds write in flx decoder
- debian/patches/flxdec-bounds1.patch: add bounds checking to
gst/flx/gstflxdec.c.
- debian/patches/flxdec-bounds2.patch: fix compiler warnings in
gst/flx/gstflxdec.c.
- No CVE number
2016-06-20 - Iain Lane <iain.lane@canonical.com>
gst-plugins-good1.0 (1.8.2-1ubuntu0.1) xenial; urgency=medium
* No-change backport to 16.04

See Also

Package Description
gstreamer1.0-pulseaudio_1.8.3-1ubuntu0.4_i386.deb GStreamer plugin for PulseAudio
gstreamer1.0-tools_1.8.3-1~ubuntu0.1_i386.deb Tools for use with GStreamer
gstreamer1.0-x_1.8.3-1ubuntu0.3_i386.deb GStreamer plugins for X11 and Pango
gtk-3-examples_3.18.9-1ubuntu3.3_i386.deb example files for GTK+ 3
gtk2-engines-murrine_0.98.2-0ubuntu2.2_i386.deb cairo-based gtk+-2.0 theme engine
gtk2.0-examples_2.24.30-1ubuntu1.16.04.2_i386.deb example files for GTK+ 2.0
guile-2.0-dev_2.0.11+1-10ubuntu0.1_i386.deb Development files for Guile 2.0
guile-2.0-doc_2.0.11+1-10ubuntu0.1_all.deb Documentation for Guile 2.0
guile-2.0-libs_2.0.11+1-10ubuntu0.1_i386.deb Core Guile libraries
guile-2.0_2.0.11+1-10ubuntu0.1_i386.deb GNU extension language and Scheme interpreter
gvfs-backends_1.28.2-1ubuntu1~16.04.3_i386.deb userspace virtual filesystem - backends
gvfs-bin_1.28.2-1ubuntu1~16.04.3_i386.deb userspace virtual filesystem - binaries
gvfs-common_1.28.2-1ubuntu1~16.04.3_all.deb userspace virtual filesystem - common data files
gvfs-daemons_1.28.2-1ubuntu1~16.04.3_i386.deb userspace virtual filesystem - servers
gvfs-fuse_1.28.2-1ubuntu1~16.04.3_i386.deb userspace virtual filesystem - fuse server
Advertisement
Advertisement