gir1.2-soup-2.4_2.52.2-1ubuntu0.3_i386.deb


Advertisement

Description

gir1.2-soup-2.4 - GObject introspection data for the libsoup HTTP library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main i386
Package filename gir1.2-soup-2.4_2.52.2-1ubuntu0.3_i386.deb
Package name gir1.2-soup-2.4
Package version 2.52.2
Package release 1ubuntu0.3
Package architecture i386
Package type deb
Category libs
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 24.14 KB
Installed size 163.00 KB
This package contains introspection data for the libsoup HTTP library.
libsoup uses the Glib main loop and is designed to work well with GTK+
applications.  This enables GNOME applications to access HTTP servers
on the network in a completely asynchronous fashion, very similar to
the GTK+ programming model (a synchronous operation mode is also
supported for those who want it).
It can be used by packages using the GIRepository format to generate
dynamic bindings.

Alternatives

Package Version Architecture Repository
gir1.2-soup-2.4_2.52.2-1ubuntu0.3_amd64.deb 2.52.2 amd64 Ubuntu Updates Main
gir1.2-soup-2.4_2.52.2-1_i386.deb 2.52.2 i386 Ubuntu Main
gir1.2-soup-2.4_2.52.2-1_amd64.deb 2.52.2 amd64 Ubuntu Main
gir1.2-soup-2.4 - - -

Requires

Name Value
gir1.2-glib-2.0 -
libsoup-gnome2.4-1 >= 2.27.4
libsoup2.4-1 >= 2.52.0

Provides

Name Value
gir1.2-soup-gnome-2.4 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gir1.2-soup-2.4_2.52.2-1ubuntu0.3_i386.deb
Source Package libsoup2.4

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-soup-2.4 deb package:
    # sudo apt-get install gir1.2-soup-2.4

Files

Path
/usr/lib/girepository-1.0/Soup-2.4.typelib
/usr/lib/girepository-1.0/SoupGNOME-2.4.typelib
/usr/share/doc/gir1.2-soup-2.4/AUTHORS
/usr/share/doc/gir1.2-soup-2.4/NEWS.gz
/usr/share/doc/gir1.2-soup-2.4/README
/usr/share/doc/gir1.2-soup-2.4/changelog.Debian.gz
/usr/share/doc/gir1.2-soup-2.4/copyright

Changelog

2018-07-02 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
libsoup2.4 (2.52.2-1ubuntu0.3) xenial-security; urgency=medium
* SECURITY UPDATE: Fail to handle empty hostnames
- debian/patches/CVE-2018-12910.patch: fix in libsoup/soup-cookie-jar.c.
- CVE-2018-12910
2017-08-08 - Steve Beattie <sbeattie@ubuntu.com>
libsoup2.4 (2.52.2-1ubuntu0.2) xenial-security; urgency=medium
* SECURITY UPDATE: chunked encoding stack buffer overflow
- debian/patches/CVE-2017-2885.patch: better boundary checking in
soup-filter-input-stream.c
- CVE-2017-2885
2016-04-22 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
libsoup2.4 (2.52.2-1ubuntu0.1) xenial-security; urgency=medium
* debian/patches/new_samba_compat.patch: fix regression in NTLM
authentication caused by Samba security update (LP: #1573494)
2015-11-10 - Michael Biebl <biebl@debian.org>
libsoup2.4 (2.52.2-1) unstable; urgency=medium
* New upstream release.
* Remove outdated comment from debian/rules.
2015-10-13 - Michael Biebl <biebl@debian.org>
libsoup2.4 (2.52.1-1) unstable; urgency=medium
[ Iain Lane ]
* Run the testsuite verbosely to get info about failures
[ Michael Biebl ]
* New upstream release.
* Drop obsolete Conflicts and Replaces from pre-wheezy.
[ Steven Chamberlain ]
* Re-enable testsuite on non-Linux platforms.
2015-09-27 - Andreas Henriksson <andreas@fatal.se>
libsoup2.4 (2.52.0-1) unstable; urgency=medium
[ Michael Biebl ]
* Track stable releases in debian/watch.
[ Andreas Henriksson ]
* New upstream release.
* Add valac build-dependency for vapigen
- soup now generates its own vapi
* libsoup2.4-dev: ship generated vala api libsoup-2.4.vapi
* Update debian/libsoup2.4-1.symbols with many additions.
2015-05-23 - Emilio Pozuelo Monfort <pochu@debian.org>
libsoup2.4 (2.50.0-2) unstable; urgency=medium
* Upload to unstable.
2015-04-02 - Iain Lane <laney@debian.org>
libsoup2.4 (2.50.0-1) experimental; urgency=medium
* New upstream release 2.50.0
+ Updated translations
2015-03-18 - Iain Lane <laney@debian.org>
libsoup2.4 (2.49.92-1) experimental; urgency=medium
* New upstream release 2.49.92
+ Fixed an NTLM problem that caused spurious "Authentication Failed"
errors in evolution-ews.
2015-03-04 - Iain Lane <laney@debian.org>
libsoup2.4 (2.49.91.1-1) experimental; urgency=medium
* New upstream release 2.49.91.1
* Add new symbols for this release

See Also

Package Description
gir1.2-tracker-1.0_1.6.2-0ubuntu1.1_i386.deb GObject introspection data for Tracker
gir1.2-unity-5.0_7.1.4+16.04.20180209.1-0ubuntu1_i386.deb GObject introspection data for the Unity library
gir1.2-upowerglib-1.0_0.99.4-2ubuntu0.3_i386.deb GObject introspection data for upower
gir1.2-webkit2-4.0_2.20.5-0ubuntu0.16.04.1_i386.deb Web content engine library for GTK+ - GObject introspection data
git-core_2.7.4-0ubuntu1.7_all.deb fast, scalable, distributed revision control system (obsolete)
git-doc_2.7.4-0ubuntu1.7_all.deb fast, scalable, distributed revision control system (documentation)
git-man_2.7.4-0ubuntu1.7_all.deb fast, scalable, distributed revision control system (manual pages)
git_2.7.4-0ubuntu1.7_i386.deb fast, scalable, distributed revision control system
gitk_2.7.4-0ubuntu1.7_all.deb fast, scalable, distributed revision control system (revision tree visualizer)
glance-store-common_0.13.0-3ubuntu0.16.04.1_all.deb OpenStack Image Service store library - common files
glib-networking-common_2.48.2-1~ubuntu16.04.1_all.deb network-related giomodules for GLib - data files
glib-networking-services_2.48.2-1~ubuntu16.04.1_i386.deb network-related giomodules for GLib - D-Bus services
glib-networking_2.48.2-1~ubuntu16.04.1_i386.deb network-related giomodules for GLib
glibc-doc_2.23-0ubuntu11_all.deb GNU C Library: Documentation
gnome-accessibility-themes_3.18.0-2ubuntu2_all.deb Accessibility themes for the GNOME desktop
Advertisement
Advertisement