cups-browsed_1.8.3-2ubuntu3.5_i386.deb


Advertisement

Description

cups-browsed - OpenPrinting CUPS Filters - cups-browsed

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main i386
Package filename cups-browsed_1.8.3-2ubuntu3.5_i386.deb
Package name cups-browsed
Package version 1.8.3
Package release 2ubuntu3.5
Package architecture i386
Package type deb
Category net
Homepage http://www.openprinting.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 93.15 KB
Installed size 296.00 KB
This package provides cups-browsed, a daemon which browses the Bonjour
broadcasts of shared remote CUPS printers and makes the printers
available locally, replacing the CUPS broadcasting/browsing which was
dropped in CUPS 1.6.x. This way the old behavior of having the remote
printers available automatically is now re-implemented with Bonjour.
cups-browsed is also useful with a CUPS >= 1.6 client to allow the
latter to browse the printer list of CUPS < 1.6 servers (by using the
old 'cups' protocol in BrowseRemoteProtocols).
cups-browsed is also useful with a CUPS >= 1.6 server to allow CUPS <
1.6 clients to browse its printer list (by using the old 'cups'
protocol in BrowseLocalProtocols).

Alternatives

Package Version Architecture Repository
cups-browsed_1.8.3-2ubuntu3.5_amd64.deb 1.8.3 amd64 Ubuntu Updates Main
cups-browsed_1.8.3-2ubuntu3_i386.deb 1.8.3 i386 Ubuntu Main
cups-browsed_1.8.3-2ubuntu3_amd64.deb 1.8.3 amd64 Ubuntu Main
cups-browsed - - -

Requires

Name Value
init-system-helpers >= 1.18~
libavahi-client3 >= 0.6.16
libavahi-common3 >= 0.6.16
libavahi-glib1 >= 0.6.16
libc6 >= 2.4
libcups2 >= 1.7.0
libglib2.0-0 >= 2.37.3
libldap-2.4-2 >= 2.4.7
lsb-base >= 4.1+Debian11ubuntu7

Replaces

Name Value
cups-filters << 1.4.0~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package cups-browsed_1.8.3-2ubuntu3.5_i386.deb
Source Package cups-filters

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install cups-browsed deb package:
    # sudo apt-get install cups-browsed

Files

Path
/etc/apparmor.d/usr.sbin.cups-browsed
/etc/cups/cups-browsed.conf
/etc/init/cups-browsed.conf
/etc/init.d/cups-browsed
/lib/systemd/system/cups-browsed.service
/usr/lib/cups/backend/implicitclass
/usr/sbin/cups-browsed
/usr/share/doc/cups-browsed/AUTHORS
/usr/share/doc/cups-browsed/README.gz
/usr/share/doc/cups-browsed/changelog.Debian.gz
/usr/share/doc/cups-browsed/copyright
/usr/share/man/man5/cups-browsed.conf.5.gz
/usr/share/man/man8/cups-browsed.8.gz

Changelog

2019-05-09 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
cups-filters (1.8.3-2ubuntu3.5) xenial-security; urgency=medium
* Fix PDF printing regression caused by latest Ghostscript security
updates (LP: #1828401)
- debian/patches/lp1828401.patch: don't use undocumented Ghostscript
function in filter/foomatic-rip/pdf.c.
2018-05-01 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
cups-filters (1.8.3-2ubuntu3.4) xenial-security; urgency=medium
* Rebuild against new qpdf security update.
- debian/control: Bump libqpdf-dev Build-Depends to 8.0~
2016-08-18 - Till Kamppeter <till.kamppeter@gmail.com>
cups-filters (1.8.3-2ubuntu3.1) xenial-proposed; urgency=medium
* Added "Requires=cups-service" to the cups-browsed.service file to make
cups-browsed always shut down before CUPS to avoid the system hanging
during shutdown (LP: #1579905).
2016-04-20 - Adam Conrad <adconrad@ubuntu.com>
cups-filters (1.8.3-2ubuntu3) xenial; urgency=medium
* Undo cups-filters-lsb and cups-filters-invalid-mta changes, we
will fix this in a more generic way in a post-release update.
2016-03-29 - Till Kamppeter <till.kamppeter@gmail.com>
cups-filters (1.8.3-2ubuntu2) xenial; urgency=medium
* Added Conflicts:/Replaces:/Provides: foomatic-filters-beh to the
cups-filters binary package due to the fact that the beh backend is
now part of cups-filters (LP: #1563686).
2016-03-25 - Till Kamppeter <till.kamppeter@gmail.com>
cups-filters (1.8.3-2ubuntu1) xenial; urgency=medium
* Merge from Debian unstable.  Remaining changes:
- Added the binary packages cups-filters-lsb and cups-filters-invalid-mta
to temporarily replace the dropped LSB support in Debian/Ubuntu which
we need for distribution-independent printer driver packages. This
will be removed as soon as a new concept for distribution-independent
printer driver packages is in place.
- Added build dependency on python3-all-dev for the cups-filters-lsb
binary package.
2016-03-25 - Didier Raboud <odyx@debian.org>
cups-filters (1.8.3-2) unstable; urgency=medium
[ Till Kamppeter ]
* Install the new /usr/share/cups/mime/cupsfilters-ghostscript.convs file
2016-03-24 - Didier Raboud <odyx@debian.org>
cups-filters (1.8.3-1) unstable; urgency=medium
* New upstream release
- cups-browsed: When creating or modifying a local print queue
set the printer-is-shared bit to false in a separate IPP
request as this operation errors on queues directly pointing
to remote CUPS queues with the IPP backend. This way we can
ignore the error and assure that all other settings are
applied (LP: #1560099)
* Refresh debian/copyright to reflect the gstoraster convs file split
2016-02-29 - Didier Raboud <odyx@debian.org>
cups-filters (1.8.2-3) unstable; urgency=medium
* Bump Standards-Version to 3.9.7 without changes needed
* Drop superfluous liblouis-data dependency (Closes: #816304)
2016-02-29 - Sebastien Bacher <seb128@ubuntu.com>
cups-filters (1.8.2-2ubuntu3) xenial; urgency=medium
* No change rebuild with the new poppler soname

See Also

Package Description
cups-bsd_2.1.3-4ubuntu0.10_i386.deb Common UNIX Printing System(tm) - BSD commands
cups-client_2.1.3-4ubuntu0.10_i386.deb Common UNIX Printing System(tm) - client programs (SysV)
cups-common_2.1.3-4ubuntu0.10_all.deb Common UNIX Printing System(tm) - common files
cups-core-drivers_2.1.3-4ubuntu0.10_i386.deb Common UNIX Printing System(tm) - PPD-less printing
cups-daemon_2.1.3-4ubuntu0.10_i386.deb Common UNIX Printing System(tm) - daemon
cups-filters-core-drivers_1.8.3-2ubuntu3.5_i386.deb OpenPrinting CUPS Filters - PPD-less printing
cups-filters_1.8.3-2ubuntu3.5_i386.deb OpenPrinting CUPS Filters - Main Package
cups-ppdc_2.1.3-4ubuntu0.10_i386.deb Common UNIX Printing System(tm) - PPD manipulation utilities
cups-server-common_2.1.3-4ubuntu0.10_all.deb Common UNIX Printing System(tm) - server common files
cups_2.1.3-4ubuntu0.10_i386.deb Common UNIX Printing System(tm) - PPD/driver support, web interface
curl_7.47.0-1ubuntu2.14_i386.deb command line tool for transferring data with URL syntax
curtin-common_19.1-7-g37a7a0f4-0ubuntu1~16.04.1_all.deb Library and tools for curtin installer
cvs_1.12.13+real-15ubuntu0.1_i386.deb Concurrent Versions System
cyrus-sasl2-doc_2.1.26.dfsg1-14ubuntu0.1_all.deb Cyrus SASL - documentation
db5.3-doc_5.3.28-11ubuntu0.2_all.deb Berkeley v5.3 Database Documentation [html]
Advertisement
Advertisement