corosync_2.3.5-3ubuntu2.3_i386.deb


Advertisement

Description

corosync - cluster engine daemon and utilities

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main i386
Package filename corosync_2.3.5-3ubuntu2.3_i386.deb
Package name corosync
Package version 2.3.5
Package release 3ubuntu2.3
Package architecture i386
Package type deb
Category admin
Homepage http://corosync.github.io/corosync/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 170.95 KB
Installed size 707.00 KB
The Corosync Cluster Engine is a Group Communication System with
additional features for implementing high availability within
applications. The project provides four C Application Programming
Interface features:
* A closed process group communication model with virtual synchrony
guarantees for creating replicated state machines.
* A simple availability manager that restarts the application process
when it has failed.
* A configuration and statistics in-memory database that provide the
ability to set, retrieve, and receive change notifications of
information.
* A quorum system that notifies applications when quorum is achieved
or lost.
This package contains the Corosync daemon and some administration tools.

Alternatives

Package Version Architecture Repository
corosync_2.3.5-3ubuntu2.3_amd64.deb 2.3.5 amd64 Ubuntu Updates Main
corosync_2.3.5-3ubuntu1_i386.deb 2.3.5 i386 Ubuntu Main
corosync_2.3.5-3ubuntu1_amd64.deb 2.3.5 amd64 Ubuntu Main
corosync - - -

Requires

Name Value
adduser -
init-system-helpers >= 1.18~
libc6 >= 2.4
libcfg6 >= 2.3.3
libcmap4 >= 1.99.9
libcorosync-common4 >= 1.99.9
libcpg4 >= 1.1.0
libqb0 >= 0.17.1
libquorum5 >= 1.99.9
libstatgrab10 -
libsystemd0 -
libtotem-pg5 >= 2.3.0
libvotequorum7 >= 2.3.4
lsb-base >= 3.0-6
xsltproc -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package corosync_2.3.5-3ubuntu2.3_i386.deb
Source Package corosync

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install corosync deb package:
    # sudo apt-get install corosync

Files

Path
/etc/corosync/corosync.conf
/etc/default/corosync
/etc/init/corosync.conf
/etc/init.d/corosync
/etc/logrotate.d/corosync
/lib/systemd/system/corosync.service
/usr/bin/corosync-blackbox
/usr/bin/corosync-xmlproc
/usr/sbin/corosync
/usr/sbin/corosync-cfgtool
/usr/sbin/corosync-cmapctl
/usr/sbin/corosync-cpgtool
/usr/sbin/corosync-keygen
/usr/sbin/corosync-quorumtool
/usr/share/augeas/lenses/corosync.aug
/usr/share/augeas/lenses/tests/test_corosync.aug
/usr/share/corosync/xml2conf.xsl
/usr/share/doc/corosync/AUTHORS
/usr/share/doc/corosync/INSTALL.gz
/usr/share/doc/corosync/README.recovery.gz
/usr/share/doc/corosync/SECURITY
/usr/share/doc/corosync/changelog.Debian.gz
/usr/share/doc/corosync/copyright
/usr/share/doc/corosync/examples/corosync.conf.example
/usr/share/doc/corosync/examples/corosync.conf.example.udpu
/usr/share/doc/corosync/examples/corosync.xml.example
/usr/share/lintian/overrides/corosync
/usr/share/man/man5/corosync.conf.5.gz
/usr/share/man/man5/corosync.xml.5.gz
/usr/share/man/man5/votequorum.5.gz
/usr/share/man/man8/cmap_keys.8.gz
/usr/share/man/man8/corosync-blackbox.8.gz
/usr/share/man/man8/corosync-cfgtool.8.gz
/usr/share/man/man8/corosync-cmapctl.8.gz
/usr/share/man/man8/corosync-cpgtool.8.gz
/usr/share/man/man8/corosync-keygen.8.gz
/usr/share/man/man8/corosync-quorumtool.8.gz
/usr/share/man/man8/corosync-xmlproc.8.gz
/usr/share/man/man8/corosync.8.gz
/usr/share/man/man8/corosync_overview.8.gz

Changelog

2019-05-30 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
corosync (2.3.5-3ubuntu2.3) xenial-security; urgency=medium
* SECURITY UPDATE: Integer overflow
- debian/patches/CVE-2018-1084-*.patch: check length of the packet
in exec/totemcrypto.c.
- CVE-2018-1084
2018-02-19 - Eric Desrochers <eric.desrochers@canonical.com>
corosync (2.3.5-3ubuntu2.1) xenial; urgency=high
* Properly restart corosync and pacemaker together (LP: #1740892)
- d/rules: pass --restart-after-upgrade to dh_installinit
- d/control: indicate this version breaks all older pacemaker, to
force an upgrade of pacemaker.
- d/corosync.postinst: if flagged to do so by pacemaker, start
pacemaker on upgrade.
2017-12-20 - Victor Tapia <victor.tapia@canonical.com>
corosync (2.3.5-3ubuntu2) xenial; urgency=medium
* d/p/Parser-Make-config-file-parser-more-hierarchy.patch: Fixes how
corosync parses a config file with malformed entries (LP: #1739033).
2016-04-01 - Jorge Niedbalski <jorge.niedbalski@canonical.com>
corosync (2.3.5-3ubuntu1) xenial; urgency=high
* debian/patches/Totempg-Fix-memory-leak.patch: Fixes memory leak on 
Totempg. (LP: #1563089).
2015-10-22 - Ferenc Wágner <wferi@niif.hu>
corosync (2.3.5-3) unstable; urgency=medium
* [e64ff08] Really add arm64 support (Closes: #753289)
* [5e60e11] Enable the monitoring service on Linux architectures
* [9b635d5] Make libtotem-pg-dev usable by shipping corosync/list.h
2015-10-16 - Ferenc Wágner <wferi@niif.hu>
corosync (2.3.5-2) unstable; urgency=medium
* [e66dda1] Make sure environment variables are propagated by the init script
* [638b690] Mention the significance of cluster_name when creating shared LVM
VGs
* [48d88e3] Generalization may be acceptable for upstream, Debianization is
not
* [cd6437f] New patch Send-corosync-startup-notification-to-systemd.patch
* [f4da902] New patch Make-systemd-stop-and-restart-corosync-notifyd-if-
co.patch
* [1504fb9] New patch Send-corosync-notifyd-startup-notification-to-
system.patch
* [837ec3e] New patch Use-debian-changelog-timestamp-for-the-build-time-
of.patch
(Closes: #800662, #800663)
* [c96145c] libcorosync-common-dev takes over files from old corosync-dev
(Closes: #800923)
* [24f4fe9] New patch cmap_track_add.3.in-fix-typo-bellow-below.patch
* [ef858f3] Only Linux supports RDMA, let's omit it on other architectures
* [70989fd] Simplify debian/rules by providing .pc files for rdmacm and
ibverbs

See Also

Package Description
cpp-5-aarch64-linux-gnu_5.4.0-6ubuntu1~16.04.9cross1_i386.deb GNU C preprocessor
cpp-5-arm-linux-gnueabihf_5.4.0-6ubuntu1~16.04.9cross1_i386.deb GNU C preprocessor
cpp-5-doc_5.4.0-6ubuntu1~16.04.11_all.deb Documentation for the GNU C preprocessor (cpp)
cpp-5-powerpc-linux-gnu_5.4.0-6ubuntu1~16.04.9cross1_i386.deb GNU C preprocessor
cpp-5-powerpc64le-linux-gnu_5.4.0-6ubuntu1~16.04.9cross1_i386.deb GNU C preprocessor
cpp-5_5.4.0-6ubuntu1~16.04.11_i386.deb GNU C preprocessor
cracklib-runtime_2.9.2-1ubuntu1_i386.deb runtime support for password checker library cracklib2
crash_7.2.3+real-1~16.04.1_i386.deb kernel debugging utility, allowing gdb like syntax
cryptsetup-bin_1.6.6-5ubuntu2.1_i386.deb disk encryption support - command line tools
cryptsetup_1.6.6-5ubuntu2.1_i386.deb disk encryption support - startup scripts
cups-browsed_1.8.3-2ubuntu3.5_i386.deb OpenPrinting CUPS Filters - cups-browsed
cups-bsd_2.1.3-4ubuntu0.10_i386.deb Common UNIX Printing System(tm) - BSD commands
cups-client_2.1.3-4ubuntu0.10_i386.deb Common UNIX Printing System(tm) - client programs (SysV)
cups-common_2.1.3-4ubuntu0.10_all.deb Common UNIX Printing System(tm) - common files
cups-core-drivers_2.1.3-4ubuntu0.10_i386.deb Common UNIX Printing System(tm) - PPD-less printing
Advertisement
Advertisement