python2.7_2.7.12-1ubuntu0~16.04.4_amd64.deb


Advertisement

Description

python2.7 - Interactive high-level object-oriented language (version 2.7)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main amd64
Package name python2.7
Package version 2.7.12
Package release 1ubuntu0~16.04.4
Package architecture amd64
Package type deb
Installed size 350 B
Download size 219.14 KB
Official Mirror archive.ubuntu.com
Python is a high-level, interactive, object-oriented language. Its 2.7 version
includes an extensive class library with lots of goodies for
network programming, system administration, sounds and graphics.

Alternatives

Package Version Architecture Repository
python2.7_2.7.12-1ubuntu0~16.04.4_i386.deb 2.7.12 i386 Ubuntu Updates Main
python2.7_2.7.11-7ubuntu1_amd64.deb 2.7.11 amd64 Ubuntu Main
python2.7_2.7.11-7ubuntu1_i386.deb 2.7.11 i386 Ubuntu Main
python2.7 - - -

Requires

Name Value
libpython2.7-stdlib = 2.7.12-1ubuntu0~16.04.4
mime support
python2.7-minimal = 2.7.12-1ubuntu0~16.04.4

Conflicts

Name Value
python-profiler <= 2.7.1-2

Replaces

Name Value
python-profiler <= 2.7.1-2
python2.7-minimal << 2.7.3-7~

Download

Type URL
Binary Package python2.7_2.7.12-1ubuntu0~16.04.4_amd64.deb
Source Package python2.7

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python2.7 deb package:
    # sudo apt-get install python2.7

Files

Path
/usr/bin/2to3-2.7
/usr/bin/pdb2.7
/usr/bin/pydoc2.7
/usr/bin/pygettext2.7
/usr/share/applications/python2.7.desktop
/usr/share/doc/python2.7/ACKS.gz
/usr/share/doc/python2.7/NEWS.gz
/usr/share/doc/python2.7/README.Debian
/usr/share/doc/python2.7/README.gz
/usr/share/doc/python2.7/changelog.Debian.gz
/usr/share/doc/python2.7/changelog.gz
/usr/share/doc/python2.7/copyright
/usr/share/lintian/overrides/python2.7
/usr/share/man/man1/2to3-2.7.1.gz
/usr/share/man/man1/pdb2.7.1.gz
/usr/share/man/man1/pydoc2.7.1.gz
/usr/share/man/man1/pygettext2.7.1.gz
/usr/share/pixmaps/python2.7.xpm

Changelog

2018-11-12 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
python2.7 (2.7.12-1ubuntu0~16.04.4) xenial-security; urgency=medium
* SECURITY UPDATE: heap buffer overflow via race condition
- debian/patches/CVE-2018-1000030-1.patch: stop crashes when iterating
over a file on multiple threads in Lib/test/test_file2k.py,
Objects/fileobject.c.
- debian/patches/CVE-2018-1000030-2.patch: fix crash when multiple
threads iterate over a file in Lib/test/test_file2k.py,
Objects/fileobject.c.
- CVE-2018-1000030
* SECURITY UPDATE: command injection in shutil module
- debian/patches/CVE-2018-1000802.patch: use subprocess rather than
distutils.spawn in Lib/shutil.py.
- CVE-2018-1000802
* SECURITY UPDATE: DoS via catastrophic backtracking
- debian/patches/CVE-2018-106x.patch: fix expressions in
Lib/difflib.py, Lib/poplib.py. Added tests to
Lib/test/test_difflib.py, Lib/test/test_poplib.py.
- CVE-2018-1060
- CVE-2018-1061
* SECURITY UPDATE: incorrect Expat hash salt initialization
- debian/patches/CVE-2018-14647.patch: call SetHashSalt in
Include/pyexpat.h, Modules/_elementtree.c, Modules/pyexpat.c.
- CVE-2018-14647
2017-12-04 - Matthias Klose <doko@ubuntu.com>
python2.7 (2.7.12-1ubuntu0~16.04.3) xenial-proposed; urgency=medium
* Some performance improvements: LP: #1638695.
- Build the _math.o object file without -fPIC for static builds.
* Rename md5_* functions to _Py_md5_*. Closes: #868366. LP: #1734109.
* Explicitly use the system python for byte compilation in postinst scripts.
LP: #1682934.
* Fix issue #22636: Avoid shell injection problems with
ctypes.util.find_library(). LP: #1512068.
2017-11-20 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
python2.7 (2.7.12-1ubuntu0~16.04.2) xenial-security; urgency=medium
* SECURITY UPDATE: integer overflow in the PyString_DecodeEscape
function
- debian/patches/CVE-2017-1000158.patch: fix this integer overflow
in Objects/stringobject.c.
- CVE-2017-1000158
2016-11-18 - Steve Beattie <sbeattie@ubuntu.com>
python2.7 (2.7.12-1ubuntu0~16.04.1) xenial-security; urgency=medium
* SECURITY UPDATE: use of HTTP_PROXY flag supplied by attacker in CGI
scripts (aka HTTPOXY attack)
- debian/patches/CVE-2016-1000110.patch: if running as CGI
script, forget HTTP_PROXY in Lib/urllib.py, add test to
Lib/test/test_urllib.py, add documentation.
- CVE-2016-1000110
* NOTE: backport of 2.7.12 to Ubuntu 16.04 LTS also addresses:
- CVE-2016-0772: StartTLS stripping attack
- CVE-2016-5636: Integer overflow when handling zipfiles
2016-07-01 - Matthias Klose <doko@ubuntu.com>
python2.7 (2.7.12-1~16.04) xenial-proposed; urgency=medium
* SRU: LP: #1591895. Backport 2.7.12 to 16.04 LTS.
2016-06-29 - Matthias Klose <doko@debian.org>
python2.7 (2.7.12-1) unstable; urgency=medium
* Python 2.7.12 release.
2016-06-13 - Matthias Klose <doko@debian.org>
python2.7 (2.7.12~rc1-2) unstable; urgency=medium
* Extend debian/copyright to the files shipped in the wheel files.

See Also

Package Description
python3-apparmor-click_0.3.13.1_all.deb Click manifest to AppArmor easyprof conversion tools
python3-apparmor_2.10.95-0ubuntu2.10_amd64.deb AppArmor Python3 utility library
python3-apport_2.20.1-0ubuntu2.18_all.deb Python 3 library for Apport crash report handling
python3-apt_1.1.0~beta1ubuntu0.16.04.2_amd64.deb Python 3 interface to libapt-pkg
python3-brlapi_5.3.1-2ubuntu2.1_amd64.deb Braille display access via BRLTTY - Python3 bindings
python3-click-package_0.4.43+16.04.20170613-0ubuntu1_amd64.deb Click packages (Python 3 interface)
python3-commandnotfound_0.3ubuntu16.04.2_all.deb Python 3 bindings for command-not-found
python3-crypto_2.6.1-6ubuntu0.16.04.3_amd64.deb cryptographic algorithms and protocols for Python 3
python3-cryptography_1.2.3-1ubuntu0.2_amd64.deb Python library exposing cryptographic recipes and primitives (Python 3)
python3-curtin_18.1-17-gae48e86f-0ubuntu1~16.04.1_all.deb Library and tools for curtin installer
python3-distupgrade_16.04.26_all.deb manage release upgrades
python3-django-maas_2.3.5-6511-gf466fdb-0ubuntu1_all.deb MAAS server Django web framework (Python 3)
python3-django_1.8.7-1ubuntu5.6_all.deb High-level Python web development framework (Python 3 version)
python3-jwt_1.3.0-1ubuntu0.1_all.deb Python 3 implementation of JSON Web Token
python3-launchpadlib_1.10.3-3ubuntu0.1_all.deb Launchpad web services client library (Python 3)
Advertisement
Advertisement