libpython2.7_2.7.12-1ubuntu0~16.04.4_amd64.deb


Advertisement

Description

libpython2.7 - Shared Python runtime library (version 2.7)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main amd64
Package name libpython2.7
Package version 2.7.12
Package release 1ubuntu0~16.04.4
Package architecture amd64
Package type deb
Installed size 3.47 KB
Download size 1.02 MB
Official Mirror archive.ubuntu.com
Python is a high-level, interactive, object-oriented language. Its 2.7 version
includes an extensive class library with lots of goodies for
network programming, system administration, sounds and graphics.
This package contains the shared runtime library, normally not needed
for programs using the statically linked interpreter.

Alternatives

Package Version Architecture Repository
libpython2.7_2.7.12-1ubuntu0~16.04.4_i386.deb 2.7.12 i386 Ubuntu Updates Main
libpython2.7_2.7.11-7ubuntu1_amd64.deb 2.7.11 amd64 Ubuntu Main
libpython2.7_2.7.11-7ubuntu1_i386.deb 2.7.11 i386 Ubuntu Main
libpython2.7 - - -

Requires

Name Value
libc6 >= 2.15
libpython2.7-stdlib = 2.7.12-1ubuntu0~16.04.4
zlib1g >= 1:1.2.0

Replaces

Name Value
python2.7 << 2.6

Download

Type URL
Binary Package libpython2.7_2.7.12-1ubuntu0~16.04.4_amd64.deb
Source Package python2.7

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpython2.7 deb package:
    # sudo apt-get install libpython2.7

Files

Path
/usr/lib/python2.7/config-x86_64-linux-gnu/libpython2.7.so
/usr/lib/x86_64-linux-gnu/libpython2.7.so.1
/usr/lib/x86_64-linux-gnu/libpython2.7.so.1.0
/usr/share/doc/libpython2.7
/usr/share/lintian/overrides/libpython2.7

Changelog

See python2.7_2.7.12-1ubuntu0~16.04.4_amd64.deb changelog.

See Also

Package Description
libpython3.5-dev_3.5.2-2ubuntu0~16.04.5_amd64.deb Header files and a static library for Python (v3.5)
libpython3.5-minimal_3.5.2-2ubuntu0~16.04.5_amd64.deb Minimal subset of the Python language (version 3.5)
libpython3.5-stdlib_3.5.2-2ubuntu0~16.04.5_amd64.deb Interactive high-level object-oriented language (standard library, version 3.5)
libpython3.5-testsuite_3.5.2-2ubuntu0~16.04.5_all.deb Testsuite for the Python standard library (v3.5)
libpython3.5_3.5.2-2ubuntu0~16.04.5_amd64.deb Shared Python runtime library (version 3.5)
libqmi-glib-dev_1.16.2-1ubuntu0.16.04.1_amd64.deb Header files for adding QMI support to applications that use glib
libqmi-glib-doc_1.16.2-1ubuntu0.16.04.1_all.deb API documentation for libqmi-glib
libqmi-glib5_1.16.2-1ubuntu0.16.04.1_amd64.deb Support library to use the Qualcomm MSM Interface (QMI) protocol
libqmi-proxy_1.16.2-1ubuntu0.16.04.1_amd64.deb Proxy to communicate with QMI ports
libqpdf-dev_8.0.2-3~16.04.1_amd64.deb development files for PDF transformation/inspection library
libqpdf21_8.0.2-3~16.04.1_amd64.deb runtime library for PDF transformation/inspection software
libqt5concurrent5_5.5.1+dfsg-16ubuntu7.5_amd64.deb Qt 5 concurrent module
libqt5core5a_5.5.1+dfsg-16ubuntu7.5_amd64.deb Qt 5 core module
libqt5dbus5_5.5.1+dfsg-16ubuntu7.5_amd64.deb Qt 5 D-Bus module
libqt5gui5_5.5.1+dfsg-16ubuntu7.5_amd64.deb Qt 5 GUI module
Advertisement
Advertisement