libgif7_5.1.4-0.3~16.04.1_amd64.deb


Advertisement

Description

libgif7 - library for GIF images (library)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main amd64
Package filename libgif7_5.1.4-0.3~16.04.1_amd64.deb
Package name libgif7
Package version 5.1.4
Package release 0.3~16.04.1
Package architecture amd64
Package type deb
Category libs
Homepage http://giflib.sourceforge.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 29.81 KB
Installed size 68.00 KB
GIFLIB is a package of portable tools and library routines for working with GIF
images.
This package contains the library.

Alternatives

Package Version Architecture Repository
libgif7_5.1.4-0.3~16.04.1_i386.deb 5.1.4 i386 Ubuntu Updates Main
libgif7_5.1.2-0.2_i386.deb 5.1.2 i386 Ubuntu Main
libgif7_5.1.2-0.2_amd64.deb 5.1.2 amd64 Ubuntu Main
libgif7 - - -

Requires

Name Value
libc6 >= 2.14

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libgif7_5.1.4-0.3~16.04.1_amd64.deb
Source Package giflib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgif7 deb package:
    # sudo apt-get install libgif7

Files

Path
/usr/lib/x86_64-linux-gnu/libgif.so.7
/usr/lib/x86_64-linux-gnu/libgif.so.7.0.0
/usr/share/doc/libgif7/AUTHORS
/usr/share/doc/libgif7/NEWS.gz
/usr/share/doc/libgif7/TODO
/usr/share/doc/libgif7/changelog.Debian.gz
/usr/share/doc/libgif7/copyright

Changelog

2019-08-19 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
giflib (5.1.4-0.3~16.04.1) xenial-security; urgency=medium
* SECURITY UPDATE: Denial of service
- debian/patches/CVE-2018-11490.patch: adding checks
in DGifDecompressLine in order to avoid a heap buffer overflow and
a denial of service in lib/dgif_lib.c.
- CVE-2018-11490
* SECURITY UPDATE: Divide-by-zero
- debian/patches/CVE-2019-15133.patch: adding checks bounds
in lib/dgif_lib.c.
- CVE-2019-15133
2016-06-14 - Matthias Klose <doko@ubuntu.com>
giflib (5.1.4-0.3~16.04) xenial-proposed; urgency=medium
* SRU: LP: #1580376: Upload bug fix release for 16.04 LTS.
2016-06-10 - Matthias Klose <doko@debian.org>
giflib (5.1.4-0.3) unstable; urgency=medium
* Non-maintainer upload.
* CVE-2016-3977: gif2rgb: heap buffer overflow. Closes: #820526.
2016-05-08 - Matthias Klose <doko@debian.org>
giflib (5.1.4-0.2) unstable; urgency=medium
* Non-maintainer upload.
* Drop the local fix for issue #81, solved differently upstream.
Closes: #823481.
2016-04-25 - Matthias Klose <doko@debian.org>
giflib (5.1.4-0.1) unstable; urgency=medium
* Non-maintainer upload.
* New upstream version.
* Security issues already fixed in 5.1.2: CVE-2016-3977. 
Closes: #820594, #820526.
* Update symbols file.
2016-04-15 - Gianfranco Costamagna <locutusofborg@debian.org>
giflib (5.1.2-0.3) unstable; urgency=medium
* Non-maintainer upload.
[ Tobias Frost ] 
* debian/patches/ef0cb9b4be572262b49fbc26fb2348683f44a517.patch:
try to fix testsuite failures on feh/powerpc.
(Closes: #812657)
2016-01-27 - Matthias Klose <doko@debian.org>
giflib (5.1.2-0.2) unstable; urgency=medium
* Non-maintainer upload.
* Fix DGifOpen(), uninitialized memory. Closes: #812093.
2016-01-16 - Matthias Klose <doko@debian.org>
giflib (5.1.2-0.1) unstable; urgency=high
* Non-maintainer upload.
* New upstream version.
- CVE-2015-7555, Heap-based buffer overflow in giffix utility.
Closes: #808704.
2015-12-12 - Matthias Klose <doko@debian.org>
giflib (5.1.1-0.2) unstable; urgency=medium
* Non-maintainer upload, upload to unstable. Closes: #803158.
2015-10-28 - Matthias Klose <doko@debian.org>
giflib (5.1.1-0.1) experimental; urgency=medium
* Non-maintainer upload.
* New upstream version. See: #803158.
* Enable parallel builds.
* Build-depend on xmlto.
* Don't ship broken libungif symlinks. Closes: #732272. LP: #1337898.

See Also

Package Description
libgl1-mesa-dev-lts-utopic_13_amd64.deb Transitional package for libgl1-mesa-dev-lts-utopic
libgl1-mesa-dev-lts-vivid_13_amd64.deb Transitional package for libgl1-mesa-dev-lts-vivid
libgl1-mesa-dev-lts-wily_13_amd64.deb Transitional package for libgl1-mesa-dev-lts-wily
libgl1-mesa-dev-lts-xenial_13_amd64.deb Transitional package for libgl1-mesa-dev-lts-xenial
libgl1-mesa-dev_18.0.5-0ubuntu0~16.04.1_amd64.deb free implementation of the OpenGL API -- GLX development files
libgl1-mesa-dri-lts-utopic_13_amd64.deb Transitional package for libgl1-mesa-dri-lts-utopic
libgl1-mesa-dri-lts-vivid_13_amd64.deb Transitional package for libgl1-mesa-dri-lts-vivid
libgl1-mesa-dri-lts-wily_13_amd64.deb Transitional package for libgl1-mesa-dri-lts-wily
libgl1-mesa-dri-lts-xenial_13_amd64.deb Transitional package for libgl1-mesa-dri-lts-xenial
libgl1-mesa-dri_18.0.5-0ubuntu0~16.04.1_amd64.deb free implementation of the OpenGL API -- DRI modules
libgl1-mesa-glx-lts-utopic_13_amd64.deb Transitional package for libgl1-mesa-glx-lts-utopic
libgl1-mesa-glx-lts-vivid_13_amd64.deb Transitional package for libgl1-mesa-glx-lts-vivid
libgl1-mesa-glx-lts-wily_13_amd64.deb Transitional package for libgl1-mesa-glx-lts-wily
libgl1-mesa-glx-lts-xenial_13_amd64.deb Transitional package for libgl1-mesa-glx-lts-xenial
libgl1-mesa-glx_18.0.5-0ubuntu0~16.04.1_amd64.deb free implementation of the OpenGL API -- GLX runtime
Advertisement
Advertisement