libcib4_1.1.14-2ubuntu1.6_amd64.deb


Advertisement

Description

libcib4 - cluster resource manager CIB library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main amd64
Package filename libcib4_1.1.14-2ubuntu1.6_amd64.deb
Package name libcib4
Package version 1.1.14
Package release 2ubuntu1.6
Package architecture amd64
Package type deb
Category libs
Homepage http://www.clusterlabs.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 50.58 KB
Installed size 230.00 KB
At its core, Pacemaker is a distributed finite state machine capable of
co-ordinating the startup and recovery of inter-related services across
a set of machines.
Pacemaker understands many different resource types (OCF, SYSV, systemd)
and can accurately model the relationships between them (colocation,
ordering).
It can even use technology such as Docker to automatically isolate the
resources managed by the cluster.
This package contains the Cluster Information Base library.

Alternatives

Package Version Architecture Repository
libcib4_1.1.14-2ubuntu1.6_i386.deb 1.1.14 i386 Ubuntu Updates Main
libcib4_1.1.14-2ubuntu1_i386.deb 1.1.14 i386 Ubuntu Main
libcib4_1.1.14-2ubuntu1_amd64.deb 1.1.14 amd64 Ubuntu Main
libcib4 - - -

Requires

Name Value
libc6 >= 2.14
libcrmcommon3 >= 1.1.14~rc4
libglib2.0-0 >= 2.12.0
libgnutls30 >= 3.4.0
libpe-rules2 >= 1.0.10
libqb0 >= 0.17.1
libxml2 >= 2.7.4

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libcib4_1.1.14-2ubuntu1.6_amd64.deb
Source Package pacemaker

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcib4 deb package:
    # sudo apt-get install libcib4

Files

Path
/usr/lib/x86_64-linux-gnu/libcib.so.4
/usr/lib/x86_64-linux-gnu/libcib.so.4.1.0
/usr/share/doc/libcib4/changelog.Debian.gz
/usr/share/doc/libcib4/copyright

Changelog

2019-04-18 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
pacemaker (1.1.14-2ubuntu1.6) xenial-security; urgency=medium
* SECURITY UPDATE: DoS and local privilege escalation in client-server
authentication
- debian/patches/CVE-2018-1687x-1.patch: make crm_pid_active more
precise as to when detections fail in include/crm_internal.h,
lib/common/utils.c.
- debian/patches/CVE-2018-1687x-2.patch: add new helpers to allow IPC
client side to authenticate the server in configure.ac,
include/crm/common/Makefile.am, include/crm/common/ipc.h,
include/crm/common/ipc_internal.h, lib/common/ipc.c.
- debian/patches/CVE-2018-1687x-3.patch: pacemakerd to trust
pre-existing processes via new checks instead in mcp/pacemaker.c.
- debian/patches/CVE-2018-1687x-4.patch: other daemons to authenticate
IPC servers of fellow processes in lib/cluster/corosync.c,
lib/cluster/cpg.c, lib/common/ipc.c, mcp/corosync.c.
- debian/patches/CVE-2018-1687x-5.patch: CPG users to be careful about
now-more-probable rival processes in attrd/main.c, cib/main.c,
crmd/main.c, fencing/main.c, lib/cluster/cpg.c.
- debian/patches/CVE-2018-1687x-6.patch: fix possible NULL pointer
dereference in crmd/control.c.
- debian/libcrmcommon3.symbols: added new symbols.
- CVE-2018-16877
- CVE-2018-16878
2019-03-07 - Heitor R. Alves de Siqueira <halves@canonical.com>
pacemaker (1.1.14-2ubuntu1.5) xenial; urgency=medium
* Change systemd unit to source /etc/default files by default
(LP: #1819046)
2018-02-19 - Eric Desrochers <eric.desrochers@canonical.com>
pacemaker (1.1.14-2ubuntu1.4) xenial; urgency=high
* Properly restart corosync and pacemaker together (LP: #1740892)
- d/pacemaker.preinst: flag corosync to restart pacemaker on
upgrade.
2017-10-25 - James Page <james.page@ubuntu.com>
pacemaker (1.1.14-2ubuntu1.3) xenial; urgency=medium
* Fix default start/stop levels for init scripts, ensuring that
running pacemaker daemons are restarted after package upgrades
(LP: #1727063):
- d/p/Enable-the-init-scripts-on-multi-user-runlevels.patch: Cherry
picked fix from later package versions.
2017-06-02 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
pacemaker (1.1.14-2ubuntu1.2) xenial-security; urgency=medium
* SECURITY UPDATE: Improper IPC guarding
- debian/patches/CVE-2016-7035.patch: fix logic in lib/common/ipc.c.
- CVE-2016-7035
* SECURITY UPDATE: denial of service in pacemaker remote
- debian/patches/CVE-2016-7797.patch: notify only on completed
handshake in lrmd/tls_backend.c.
- CVE-2016-7797
2016-08-04 - Christian Ehrhardt <christian.ehrhardt@canonical.com>
pacemaker (1.1.14-2ubuntu1.1) xenial; urgency=medium
* add missing dependency to dbus (LP: #1595901)
2016-03-21 - Pierre-André MOREY <pierre-andre.morey@canonical.com>
pacemaker (1.1.14-2ubuntu1) xenial; urgency=medium
* Merge from Debian unstable.  Remaining changes:
- d/control: Drop publican from BD's, skip some doc generation.
- d/control: depend on corosync ( >= 2.3.0 )
- d/control: Demote fence-agents to Suggests, avoiding main inclusion.
- d/control: Promote crmsh | pcs to Recommends for upgraders from 14.04.
- d/pacemaker-doc.*: Drop docs generated using publican from install.

See Also

Package Description
libcilkrts5_5.4.0-6ubuntu1~16.04.11_amd64.deb Intel Cilk Plus language extensions (runtime)
libclamav-dev_0.101.4+dfsg-0ubuntu0.16.04.1_amd64.deb anti-virus utility for Unix - development files
libclamav7_0.100.3+dfsg-0ubuntu0.16.04.1_amd64.deb anti-virus utility for Unix - library
libclamav9_0.101.4+dfsg-0ubuntu0.16.04.1_amd64.deb anti-virus utility for Unix - library
libclang-common-4.0-dev_4.0-1ubuntu1~16.04.2_amd64.deb clang library - Common development package
libclang1-4.0_4.0-1ubuntu1~16.04.2_amd64.deb C interface to the clang library
libclang1-5.0_5.0-3~16.04.1_amd64.deb C interface to the clang library
libclang1-6.0_6.0-1ubuntu2~16.04.1_amd64.deb C interface to the clang library
libclick-0.4-0_0.4.43+16.04.20170613-0ubuntu1_amd64.deb run-time Click package management library
libclick-0.4-dev_0.4.43+16.04.20170613-0ubuntu1_amd64.deb development files for Click package management library
libcmap-dev_2.3.5-3ubuntu2.3_amd64.deb cluster engine CMAP library development
libcmap4_2.3.5-3ubuntu2.3_amd64.deb cluster engine CMAP library
libcomerr2_1.42.13-1ubuntu1.1_amd64.deb common error description library
libcompizconfig0-dev_0.9.12.3+16.04.20180221-0ubuntu1_amd64.deb Development file for plugin settings - OpenCompositing Project
libcompizconfig0_0.9.12.3+16.04.20180221-0ubuntu1_amd64.deb Settings library for plugins - OpenCompositing Project
Advertisement
Advertisement