libapache2-mod-php7.0_7.0.33-0ubuntu0.16.04.6_amd64.deb


Advertisement

Description

libapache2-mod-php7.0 - server-side, HTML-embedded scripting language (Apache 2 module)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main amd64
Package filename libapache2-mod-php7.0_7.0.33-0ubuntu0.16.04.6_amd64.deb
Package name libapache2-mod-php7.0
Package version 7.0.33
Package release 0ubuntu0.16.04.6
Package architecture amd64
Package type deb
Category httpd
Homepage http://www.php.net/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 1.17 MB
Installed size 4.08 MB
This package provides the PHP module for the Apache 2 webserver (as
found in the apache2-mpm-prefork package).  Please note that this package
ONLY works with Apache's prefork MPM, as it is not compiled thread-safe.
The following extensions are built in: Core date filter hash libxml openssl
pcre Reflection session SPL standard zlib.
PHP (recursive acronym for PHP: Hypertext Preprocessor) is a widely-used
open source general-purpose scripting language that is especially suited
for web development and can be embedded into HTML.

Alternatives

Package Version Architecture Repository
libapache2-mod-php7.0_7.0.33-0ubuntu0.16.04.6_i386.deb 7.0.33 i386 Ubuntu Updates Main
libapache2-mod-php7.0_7.0.4-7ubuntu2_i386.deb 7.0.4 i386 Ubuntu Main
libapache2-mod-php7.0_7.0.4-7ubuntu2_amd64.deb 7.0.4 amd64 Ubuntu Main
libapache2-mod-php7.0 - - -

Requires

Name Value
apache2-api-20120211 -
apache2-bin >= 2.4.16
libc6 >= 2.15
libmagic1 -
libpcre3 -
libssl1.0.0 >= 1.0.2~beta3
libxml2 >= 2.8.0
mime-support -
php7.0-cli -
php7.0-common = 7.0.33-0ubuntu0.16.04.6
php7.0-json -
php7.0-opcache -
tzdata -
ucf -
zlib1g >= 1:1.1.4

Provides

Name Value
libapache2-mod-php -
phpapi-20151012 -

Conflicts

Name Value
libapache2-mod-php5 << 5.6.16+dfsg-4~
libapache2-mod-php5filter << 5.6.16+dfsg-4~

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libapache2-mod-php7.0_7.0.33-0ubuntu0.16.04.6_amd64.deb
Source Package php7.0

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libapache2-mod-php7.0 deb package:
    # sudo apt-get install libapache2-mod-php7.0

Files

Path
/etc/apache2/mods-available/php7.0.conf
/etc/apache2/mods-available/php7.0.load
/usr/lib/apache2/modules/libphp7.0.so
/usr/lib/php/7.0/sapi/apache2
/usr/share/bug/libapache2-mod-php7.0/control
/usr/share/bug/libapache2-mod-php7.0/script
/usr/share/doc/libapache2-mod-php7.0
/usr/share/lintian/overrides/libapache2-mod-php7.0

Changelog

2019-08-12 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
php7.0 (7.0.33-0ubuntu0.16.04.6) xenial-security; urgency=medium
* SECURITY UPDATE: Heap-buffer-overflow
- debian/patches/CVE-2019-11041.patch: check Thumbnail.size in order
to avoid an overflow in ext/exif.exif.c and adding test to
ext/exif/tests/bug78222.phpt.
- CVE-2019-11041
* SECURITY UPDATE: Heap-buffer-overflow
- debian/patches/CVE-2019-11042.patch: check ByteCount in order to
avoid an overflow in ext/exif/exif.c and adding tests to
ext/exif/tests/bug78256.phpt.
- CVE-2019-11042
2019-06-04 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
php7.0 (7.0.33-0ubuntu0.16.04.5) xenial-security; urgency=medium
* SECURITY UPDATE: overflow in exif_process_IFD_TAG
- debian/patches/CVE-2019-11036.patch: check dir_entry in
ext/exif/exif.c.
- CVE-2019-11036
* SECURITY UPDATE: out-of-bounds read in _php_iconv_mime_decode()
- debian/patches/CVE-2019-11039.patch: add an extra check in
ext/iconv/iconv.c.
- CVE-2019-11039
* SECURITY UPDATE: heap-buffer-overflow on php_jpg_get16
- debian/patches/CVE-2019-11040.patch: add an extra check in
ext/exif/exif.c.
- CVE-2019-11040
2019-04-18 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
php7.0 (7.0.33-0ubuntu0.16.04.4) xenial-security; urgency=medium
* SECURITY UPDATE: Heap-buffer-overflow in php_ifd_get32s
- debian/patches/CVE-2019-11034.patch: check size in ext/exif/exif.c.
- CVE-2019-11034
* SECURITY UPDATE: Heap-buffer-overflow in exif_iif_add_value in EXIF
- debian/patches/CVE-2019-11035-1.patch: add checks to ext/exif/exif.c.
- debian/patches/CVE-2019-11035-2.patch: add casts to ext/exif/exif.c.
- debian/patches/CVE-2019-11035-3.patch: fix typo in ext/exif/exif.c.
- CVE-2019-11035
2019-03-21 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
php7.0 (7.0.33-0ubuntu0.16.04.3) xenial-security; urgency=medium
* SECURITY UPDATE: Unauthorized users access
- debian/patches/CVE-2019-9637.patch: fix in
main/streams/plain_wrapper.c.
- CVE-2019-9637
* SECURITY UPDATE: Invalid read in exif_process_IFD_MAKERNOTE
- debian/patches/CVE-2019-9638-and-CVE-2019-9639-*.patch: fix in
ext/exif/exif.c, added tests in ext/exif/tests/bug77563.jpg,
ext/exif/tests/bug77563.phpt.
- CVE-2019-9638
- CVE-2019-9639
* SECURITY UPDATE: Invalid read
- debian/patches/CVE-2019-9640.patch: fix in
ext/exif/exif.c, added tests in ext/exif/tests/bug77540.jpg,
ext/exif/tests/bug77540.phpt.
- CVE-2019-9640
* SECURITY UPDATE: Unitialized read
- debian/patches/CVE-2019-9641.patch: fix in ext/exif/exif.c.
- CVE-2019-9641
* SECURITY UPDATE: Buffer overflow
- debian/patches/CVE-2019-9675.patch: fix in
ext/phar/tar.c, added tests in ext/phar/tests/bug71488.phpt,
ext/phar/tests/bug77586,phpt, ext/phar/tests/bug77586/files/*.

See Also

Package Description
libapache2-mod-php_7.0+35ubuntu6.1_all.deb server-side, HTML-embedded scripting language (Apache 2 module) (default)
libapparmor-dev_2.10.95-0ubuntu2.11_amd64.deb AppArmor development libraries and header files
libapparmor-perl_2.10.95-0ubuntu2.11_amd64.deb AppArmor library Perl bindings
libapparmor1_2.10.95-0ubuntu2.11_amd64.deb changehat AppArmor library
libappindicator-dev_12.10.1+16.04.20170215-0ubuntu1_amd64.deb Application Indicators
libappindicator-doc_12.10.1+16.04.20170215-0ubuntu1_all.deb Application Indicators
libappindicator0.1-cil-dev_12.10.1+16.04.20170215-0ubuntu1_all.deb Application Indicators
libappindicator0.1-cil_12.10.1+16.04.20170215-0ubuntu1_all.deb CLI bindings for libappindicator
libappindicator1_12.10.1+16.04.20170215-0ubuntu1_amd64.deb Application Indicators
libappindicator3-1_12.10.1+16.04.20170215-0ubuntu1_amd64.deb Application Indicators
libappindicator3-dev_12.10.1+16.04.20170215-0ubuntu1_amd64.deb Application Indicators
libappstream-dev_0.9.4-1ubuntu4_amd64.deb Library to access AppStream services (development files)
libappstream-glib-dev_0.5.13-1ubuntu6_amd64.deb GNOME library to access AppStream services (development files)
libappstream-glib8_0.5.13-1ubuntu6_amd64.deb GNOME library to access AppStream services
libappstream3_0.9.4-1ubuntu4_amd64.deb Library to access AppStream services
Advertisement
Advertisement