gstreamer1.0-pulseaudio_1.8.3-1ubuntu0.4_amd64.deb


Advertisement

Description

gstreamer1.0-pulseaudio - GStreamer plugin for PulseAudio

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main amd64
Package filename gstreamer1.0-pulseaudio_1.8.3-1ubuntu0.4_amd64.deb
Package name gstreamer1.0-pulseaudio
Package version 1.8.3
Package release 1ubuntu0.4
Package architecture amd64
Package type deb
Category sound
Homepage http://gstreamer.freedesktop.org/modules/gst-plugins-good.html
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 54.84 KB
Installed size 216.00 KB
GStreamer is a streaming media framework, based on graphs of filters
which operate on media data.  Applications using this library can do
anything from real-time sound processing to playing videos, and just
about anything else media-related.  Its plugin-based architecture means
that new data types or processing capabilities can be added simply by
installing new plug-ins.
This package contains the GStreamer plugin for PulseAudio, a sound server
for POSIX and WIN32 systems.

Alternatives

Package Version Architecture Repository
gstreamer1.0-pulseaudio_1.8.3-1ubuntu0.4_i386.deb 1.8.3 i386 Ubuntu Updates Main
gstreamer1.0-pulseaudio_1.8.0-1ubuntu1_i386.deb 1.8.0 i386 Ubuntu Main
gstreamer1.0-pulseaudio_1.8.0-1ubuntu1_amd64.deb 1.8.0 amd64 Ubuntu Main
gstreamer1.0-pulseaudio - - -

Requires

Name Value
libc6 >= 2.14
libglib2.0-0 >= 2.40
libgstreamer-plugins-base1.0-0 >= 1.0.0
libgstreamer1.0-0 >= 1.4.0
libpulse0 >= 2.0

Provides

Name Value
gstreamer1.0-audiosink -
gstreamer1.0-audiosource -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gstreamer1.0-pulseaudio_1.8.3-1ubuntu0.4_amd64.deb
Source Package gst-plugins-good1.0

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gstreamer1.0-pulseaudio deb package:
    # sudo apt-get install gstreamer1.0-pulseaudio

Files

Path
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstpulse.so
/usr/share/doc/gstreamer1.0-pulseaudio/AUTHORS
/usr/share/doc/gstreamer1.0-pulseaudio/NEWS.gz
/usr/share/doc/gstreamer1.0-pulseaudio/README.Debian
/usr/share/doc/gstreamer1.0-pulseaudio/README.gz
/usr/share/doc/gstreamer1.0-pulseaudio/changelog.Debian.gz
/usr/share/doc/gstreamer1.0-pulseaudio/copyright

Changelog

2017-03-23 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
gst-plugins-good1.0 (1.8.3-1ubuntu0.4) xenial-security; urgency=medium
* SECURITY UPDATE: DoS in gst_aac_parse_sink_setcaps
- debian/patches/CVE-2016-10198.patch: make sure there's enough data in
gst/audioparsers/gstaacparse.c.
- CVE-2016-10198
* SECURITY UPDATE: DoS in qtdemux_tag_add_str_full
- debian/patches/CVE-2016-10199.patch: fix out of bounds read in
gst/isomp4/qtdemux.c.
- CVE-2016-10199
* SECURITY UPDATE: DoS in qtdemux_parse_samples
- debian/patches/CVE-2017-5840.patch: properly increment stts index in
gst/isomp4/qtdemux.c.
- CVE-2017-5840
* SECURITY UPDATE: DoS in gst_avi_demux_parse_ncdt
- debian/patches/CVE-2017-5841.patch: fix out of bounds reads in
gst/avi/gstavidemux.c.
- CVE-2017-5841
* SECURITY UPDATE: DoS in gst_avi_demux_parse_ncdt
- debian/patches/CVE-2017-5845.patch: check size in
gst/avi/gstavidemux.c.
- CVE-2017-5845
2017-01-13 - Iain Lane <iain.lane@canonical.com>
gst-plugins-good1.0 (1.8.3-1ubuntu0.3) xenial; urgency=medium
* Rebase on top of security update again.
2016-11-24 - Iain Lane <iain.lane@canonical.com>
gst-plugins-good1.0 (1.8.3-1ubuntu0.2) xenial; urgency=medium
* Rebase on top of security update.
2016-09-02 - Iain Lane <iain.lane@canonical.com>
gst-plugins-good1.0 (1.8.3-1ubuntu0.1) xenial; urgency=medium
* No-change backport from yakkety to 16.04 (LP: #1619600)
2016-09-01 - Iain Lane <iain.lane@canonical.com>
gst-plugins-good1.0 (1.8.3-1ubuntu1) yakkety; urgency=medium
* Merge with Debian unstable; remaining changes:
+ Import plugins from -bad that are needed for main applications.
- jpegformat
- camerabin2 (+ basecamerabinsrc + photography)
+ Break and Replace -bad versions which contained these plugins.
+ Add a library package containing the shared library and a -dev package for
compiling against it. Add Breaks and Replaces against the plugins packages
which formerly contained files shipped here.
+ Add 'pluginsdir' variable to our added pcfile for compatibility with
some external software
+ debian/control{,.in}: Update Vcs-* for Ubuntu
2016-08-19 - Sebastian Dröge <slomo@debian.org>
gst-plugins-good1.0 (1.8.3-1) unstable; urgency=medium
* New upstream bugfix release.
2016-11-25 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
gst-plugins-good1.0 (1.8.2-1ubuntu0.3) xenial-security; urgency=medium
* SECURITY UPDATE: incomplete fix for flx decoder
- debian/patches/flxdec-bounds3.patch: don't unref() parent in the
chain function in gst/flx/gstflxdec.c.
- debian/patches/flxdec-bounds4.patch: rewrite logic based on
GstByteReader/Writer in gst/flx/flx_color.c, gst/flx/flx_fmt.h,
gst/flx/gstflxdec.c, gst/flx/gstflxdec.h.
- No CVE number
2016-11-22 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
gst-plugins-good1.0 (1.8.2-1ubuntu0.2) xenial-security; urgency=medium
* SECURITY UPDATE: code execution via out-of-bounds write in flx decoder
- debian/patches/flxdec-bounds1.patch: add bounds checking to
gst/flx/gstflxdec.c.
- debian/patches/flxdec-bounds2.patch: fix compiler warnings in
gst/flx/gstflxdec.c.
- No CVE number
2016-06-20 - Iain Lane <iain.lane@canonical.com>
gst-plugins-good1.0 (1.8.2-1ubuntu0.1) xenial; urgency=medium
* No-change backport to 16.04

See Also

Package Description
gstreamer1.0-tools_1.8.3-1~ubuntu0.1_amd64.deb Tools for use with GStreamer
gstreamer1.0-x_1.8.3-1ubuntu0.3_amd64.deb GStreamer plugins for X11 and Pango
gtk-3-examples_3.18.9-1ubuntu3.3_amd64.deb example files for GTK+ 3
gtk2-engines-murrine_0.98.2-0ubuntu2.2_amd64.deb cairo-based gtk+-2.0 theme engine
gtk2.0-examples_2.24.30-1ubuntu1.16.04.2_amd64.deb example files for GTK+ 2.0
guile-2.0-dev_2.0.11+1-10ubuntu0.1_amd64.deb Development files for Guile 2.0
guile-2.0-doc_2.0.11+1-10ubuntu0.1_all.deb Documentation for Guile 2.0
guile-2.0-libs_2.0.11+1-10ubuntu0.1_amd64.deb Core Guile libraries
guile-2.0_2.0.11+1-10ubuntu0.1_amd64.deb GNU extension language and Scheme interpreter
gvfs-backends_1.28.2-1ubuntu1~16.04.3_amd64.deb userspace virtual filesystem - backends
gvfs-bin_1.28.2-1ubuntu1~16.04.3_amd64.deb userspace virtual filesystem - binaries
gvfs-common_1.28.2-1ubuntu1~16.04.3_all.deb userspace virtual filesystem - common data files
gvfs-daemons_1.28.2-1ubuntu1~16.04.3_amd64.deb userspace virtual filesystem - servers
gvfs-fuse_1.28.2-1ubuntu1~16.04.3_amd64.deb userspace virtual filesystem - fuse server
gvfs-libs_1.28.2-1ubuntu1~16.04.3_amd64.deb userspace virtual filesystem - private libraries
Advertisement
Advertisement