grub-ipxe_1.0.0+git-20150424.a25a16d-1ubuntu1.2_all.deb


Advertisement

Description

grub-ipxe - Network booting from GRUB using iPXE

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main amd64
Package filename grub-ipxe_1.0.0+git-20150424.a25a16d-1ubuntu1.2_all.deb
Package name grub-ipxe
Package version 1.0.0+git
Package release 20150424.a25a16d-1ubuntu1.2
Package architecture all
Package type deb
Category admin
Homepage http://ipxe.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 600.41 KB
Installed size 1.04 MB
iPXE is network boot firmware.  It supports a variety of network cards,
including some wireless cards, and variety of network protocols (traditional
DHCP, BOOTP and TFTP and also HTTP, iSCSI, SAN via FCoE and Infiniband). It
supports scripting.
This package adds a menu entry to grub2 for network booting using iPXE.

Alternatives

Package Version Architecture Repository
grub-ipxe_1.0.0+git-20150424.a25a16d-1ubuntu1.2_all.deb 1.0.0+git all Ubuntu Updates Main
grub-ipxe_1.0.0+git-20150424.a25a16d-1ubuntu1_all.deb 1.0.0+git all Ubuntu Main
grub-ipxe_1.0.0+git-20150424.a25a16d-1ubuntu1_all.deb 1.0.0+git all Ubuntu Main
grub-ipxe - - -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package grub-ipxe_1.0.0+git-20150424.a25a16d-1ubuntu1.2_all.deb
Source Package ipxe

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install grub-ipxe deb package:
    # sudo apt-get install grub-ipxe

Files

Path
/boot/ipxe.efi
/boot/ipxe.lkrn
/etc/grub.d/20_ipxe
/usr/share/doc/grub-ipxe/changelog.Debian.gz
/usr/share/doc/grub-ipxe/copyright

Changelog

2017-11-20 - Andres Rodriguez <andreserl@ubuntu.com>
ipxe (1.0.0+git-20150424.a25a16d-1ubuntu1.2) xenial-proposed; urgency=medium
* debian/patches/handle-dhcp-nack.patch: Handle DHCP NAK and send a
re-discover. (LP: #1707999)
2016-02-08 - Serge Hallyn <serge.hallyn@ubuntu.com>
ipxe (1.0.0+git-20150424.a25a16d-1ubuntu1) xenial; urgency=medium
* Merge from Debian unstable. Remaining changes:
- d/p/enable-https.patch: Enable HTTPS support.
- d/control,grub-ipxe*: Split grub integration from ipxe->grub-ipxe.
- d/ipxe-qemu.links: Add compat links from /usr/share/qemu to
/usr/lib/ipxe/qemu.
- d/ipxe-qemu.install: Install ne.rom as pxe-ne2k_isa.rom.
2015-04-29 - Bastian Blank <waldi@debian.org>
ipxe (1.0.0+git-20150424.a25a16d-1) unstable; urgency=medium
* New snapshot.
* Build-depend on liblzma-dev.
* Update Standards-Version, no changes.
* Redo ISO generation:
- Fix isolinux location and build-deps. (closes: #783051)
- Include EFI image, build-depend on dosfstools and mtools.
- Use xorriso instead of genisoimage.
- Use isohybrid.
* Enable support for IPv6 and NFS. (closes: #746500)
2015-02-09 - Serge Hallyn <serge.hallyn@ubuntu.com>
ipxe (1.0.0+git-20141004.86285d1-1ubuntu3) vivid; urgency=medium
* ipxe.install: remove one more line which was supposed to be split out
into grub-ipxe.install.
2015-02-09 - Serge Hallyn <serge.hallyn@ubuntu.com>
ipxe (1.0.0+git-20141004.86285d1-1ubuntu2) vivid; urgency=medium
* ipxe.install: remove /boot/ipxe.efi and ipxe.lkrn which are split out
into grub-ipxe.install.  (LP: #1418751)
2015-01-12 - Serge Hallyn <serge.hallyn@ubuntu.com>
ipxe (1.0.0+git-20141004.86285d1-1ubuntu1) vivid; urgency=medium
* Merge from Debian unstable. (LP: #1409057)  Remaining changes:
- d/p/enable-https.patch: Enable HTTPS support.
- d/control,grub-ipxe*: Split grub integration from ipxe->grub-ipxe.
- d/ipxe-qemu.links: Add compat links from /usr/share/qemu to
/usr/lib/ipxe/qemu.
- d/ipxe-qemu.install: Install ne.rom as pxe-ne2k_isa.rom.
* Dropped changes, alternative fix in Debian:
- d/control: Add libiberty-dev to BD's to fix FTBFS.
- drop isolinux from build-deps and patch to augment ISOLINUX_BIN
- Drop transitional kvm-ipxe package since we are past 14.04
2014-10-19 - Bastian Blank <waldi@debian.org>
ipxe (1.0.0+git-20141004.86285d1-1) unstable; urgency=medium
* New snapshot.
2014-09-10 - Juli?n Moreno Pati?o <julian@debian.org>
ipxe (1.0.0+git-20131111.c3d1e78-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Add missing export in d/rules.
* Change syslinux to syslinux-common in B-D. (Closes: #750349)
2014-08-12 - Serge Hallyn <serge.hallyn@ubuntu.com>
ipxe (1.0.0+git-20131111.c3d1e78-2ubuntu2) utopic; urgency=medium
* Fix FTBFS in utopic due to movement of isolinux.bin:
- add isolinux to build-deps
- add /usr/lib/ISOLINUX/isolinux.bin to ISOLINUX_BIN in
src/arch/i386/Makefile
2014-01-06 - James Page <james.page@ubuntu.com>
ipxe (1.0.0+git-20131111.c3d1e78-2ubuntu1) trusty; urgency=low
* Merge from Debian unstable.  Remaining changes:
- d/p/enable-https.patch: Enable HTTPS support.
- d/control,grub-ipxe*: Split grub integration from ipxe->grub-ipxe.
- d/control: Transition kvm-ipxe->ipxe-qemu for LTS->LTS upgrade.
- d/ipxe-qemu.links: Add compat links from /usr/share/qemu to
/usr/lib/ipxe/qemu.
- d/ipxe-qemu.install: Install ne.rom as pxe-ne2k_isa.rom.
* Dropped changes, alternative fix in Debian:
- d/control: Add libiberty-dev to BD's to fix FTBFS.

See Also

Package Description
grub-legacy-ec2_19.2-36-g059d049c-0ubuntu2~16.04.1_all.deb Handles update-grub for ec2 instances
grub-pc-bin_2.02~beta2-36ubuntu3.23_amd64.deb GRand Unified Bootloader, version 2 (PC/BIOS binaries)
grub-pc_2.02~beta2-36ubuntu3.23_amd64.deb GRand Unified Bootloader, version 2 (PC/BIOS version)
grub-xen-bin_2.02~beta2-36ubuntu3.23_amd64.deb GRand Unified Bootloader, version 2 (Xen binaries)
grub-xen_2.02~beta2-36ubuntu3.23_amd64.deb GRand Unified Bootloader, version 2 (Xen version)
grub2-common_2.02~beta2-36ubuntu3.23_amd64.deb GRand Unified Bootloader (common files for version 2)
gstreamer1.0-alsa_1.8.3-1ubuntu0.3_amd64.deb GStreamer plugin for ALSA
gstreamer1.0-doc_1.8.3-1~ubuntu0.1_all.deb GStreamer core documentation and manuals
gstreamer1.0-plugins-base-apps_1.8.3-1ubuntu0.3_amd64.deb GStreamer helper programs from the "base" set
gstreamer1.0-plugins-base-doc_1.8.3-1ubuntu0.3_all.deb GStreamer documentation for plugins from the "base" set
gstreamer1.0-plugins-base_1.8.3-1ubuntu0.3_amd64.deb GStreamer plugins from the "base" set
gstreamer1.0-plugins-good-doc_1.8.3-1ubuntu0.4_all.deb GStreamer documentation for plugins from the "good" set
gstreamer1.0-plugins-good_1.8.3-1ubuntu0.4_amd64.deb GStreamer plugins from the "good" set
gstreamer1.0-pulseaudio_1.8.3-1ubuntu0.4_amd64.deb GStreamer plugin for PulseAudio
gstreamer1.0-tools_1.8.3-1~ubuntu0.1_amd64.deb Tools for use with GStreamer
Advertisement
Advertisement