gir1.2-lokdocview-0.1_5.1.6~rc2-0ubuntu1~xenial10_amd64.deb


Advertisement

Description

gir1.2-lokdocview-0.1 - GTK3 widget wrapping LibreOffice functionality - introspection

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main amd64
Package filename gir1.2-lokdocview-0.1_5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
Package name gir1.2-lokdocview-0.1
Package version 5.1.6~rc2
Package release 0ubuntu1~xenial10
Package architecture amd64
Package type deb
Category introspection
Homepage http://www.libreoffice.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 7.85 KB
Installed size 56.00 KB
LOKDocView is the GTK3 widget that wraps the libreoffice functionality and
exposes a simple API for applications to use this widget.
This package contains the Introspection data.

Alternatives

Package Version Architecture Repository
gir1.2-lokdocview-0.1_5.1.6~rc2-0ubuntu1~xenial10_i386.deb 5.1.6~rc2 i386 Ubuntu Updates Main
gir1.2-lokdocview-0.1_5.1.2-0ubuntu1_i386.deb 5.1.2 i386 Ubuntu Main
gir1.2-lokdocview-0.1_5.1.2-0ubuntu1_amd64.deb 5.1.2 amd64 Ubuntu Main
gir1.2-lokdocview-0.1 - - -

Requires

Name Value
gir1.2-gdkpixbuf-2.0 -
gir1.2-glib-2.0 -
gir1.2-gtk-3.0 -
libreoffice-core = 1:5.1.6~rc2-0ubuntu1~xenial10
libreoffice-gtk3 = 1:5.1.6~rc2-0ubuntu1~xenial10

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gir1.2-lokdocview-0.1_5.1.6~rc2-0ubuntu1~xenial10_amd64.deb
Source Package libreoffice

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-lokdocview-0.1 deb package:
    # sudo apt-get install gir1.2-lokdocview-0.1

Files

Path
/usr/lib/girepository-1.0/LOKDocView-0.1.typelib
/usr/share/bug/gir1.2-lokdocview-0.1/presubj
/usr/share/doc/gir1.2-lokdocview-0.1
/usr/share/gir-1.0/LOKDocView-0.1.gir

Changelog

2019-09-21 - Marcus Tomlinson <marcus.tomlinson@canonical.com>
libreoffice (1:5.1.6~rc2-0ubuntu1~xenial10) xenial-security; urgency=medium
* SECURITY UPDATE: Unsafe URL assembly flaw in allowed script location check
- debian/patches/CVE-2019-9854.diff: assemble the parsed url describing a
script's location from the output of the preceding verification step.
- CVE-2019-9854
2019-08-14 - Marcus Tomlinson <marcus.tomlinson@canonical.com>
libreoffice (1:5.1.6~rc2-0ubuntu1~xenial9) xenial-security; urgency=medium
* SECURITY UPDATE: Insufficient URL validation allowing LibreLogo script execution
- debian/patches/CVE-2019-9850_1_2.diff: decode escape codes and ban scripts
with "LibreLogo" anywhere in its path.
- CVE-2019-9850
* SECURITY UPDATE: LibreLogo global-event script execution
- debian/patches/CVE-2019-9850_1_2.diff: catch more LibreLogo script executions
by expanding check to global events.
- CVE-2019-9851
* SECURITY UPDATE: Insufficient URL encoding flaw in allowed script location check
- debian/patches/CVE-2019-9850_1_2.diff: ensure that all URLs leaving
scriptURI2StorageUri() are percent-encoded.
- CVE-2019-9852
2019-07-16 - Marcus Tomlinson <marcus.tomlinson@canonical.com>
libreoffice (1:5.1.6~rc2-0ubuntu1~xenial8) xenial-security; urgency=medium
* SECURITY UPDATE: LibreLogo arbitrary script execution
- debian/patches/CVE-2019-9848.diff: don't allow LibreLogo to be used with
mouseover/etc dom-alike events.
- CVE-2019-9848
* SECURITY UPDATE: Remote bullet graphics retrieved in 'stealth mode'
- debian/patches/CVE-2019-9849.diff: include bullet graphics in 'stealth
mode' protection.
- CVE-2019-9849
2019-05-03 - Marcus Tomlinson <marcus.tomlinson@canonical.com>
libreoffice (1:5.1.6~rc2-0ubuntu1~xenial7) xenial; urgency=medium
[ Ikuya Awashiro ]
* debian/patches/new-japanese-era-name.patch (LP: #1827451):
Add new Japanse era name "Reiwa" support which taken from upstream:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=cacbb0faef77ae8462de9ff5c7307a6a2e28b2bb
https://cgit.freedesktop.org/libreoffice/core/commit/?id=597c5d75b8e72d429e096535334eaac7973455ef
[ Olivier Tilloy ]
* debian/patches/java.vendor-Ubuntu.patch: update to also recognize
"Private Build" as java.vendor (for custom PPA builds) (LP: #1822839)
* debian/patches/java.vendor-Ubuntu.patch: also make jvmfwk recognize
"Ubuntu" as java.vendor (LP: #1822839)
[ Rene Engelhard ]
* debian/patches/java.vendor-Debian.diff: make jvmfwk recognize "Debian"
as java.vendor as that's what is set in openjdk 11 >= 11.0.3+4-2
- see #926009 (closes: #926318) (LP: #1822839)
2019-01-28 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
libreoffice (1:5.1.6~rc2-0ubuntu1~xenial6) xenial-security; urgency=medium
* SECURITY UPDATE: incorrect integer data type in StgSmallStrm class
- debian/patches/CVE-2018-10119.patch: use short->sal_Int32 like in
StgDataStrm in sot/source/sdstor/stgstrms.cxx.
- CVE-2018-10119
* SECURITY UPDATE: heap-based buffer overflow in SwCTBWrapper::Read
- debian/patches/CVE-2018-10120.patch: check index before use in
sw/source/filter/ww8/ww8toolbar.cxx.
- CVE-2018-10120
* SECURITY UPDATE: information disclosure vulnerability via SMB link
- debian/patches/CVE-2018-10583.patch: set Referer on link
mediadescriptor in sw/source/filter/xml/xmltexti.cxx.
- CVE-2018-10583
* SECURITY UPDATE: Directory traversal flaw in script execution
- debian/patches/CVE-2018-16858.patch: keep pyuno script processing
below base uri in scripting/source/pyprov/pythonscript.py.
- CVE-2018-16858

See Also

Package Description
gir1.2-modemmanager-1.0_1.6.4-1ubuntu0.16.04.1_amd64.deb GObject introspection data for modemmanager
gir1.2-nautilus-3.0_3.18.4.is.3.14.3-0ubuntu6_amd64.deb libraries for nautilus components - gir bindings
gir1.2-networkmanager-1.0_1.2.6-0ubuntu0.16.04.3_amd64.deb GObject introspection data for NetworkManager
gir1.2-nma-1.0_1.2.6-0ubuntu0.16.04.4_amd64.deb GObject introspection data for libnma
gir1.2-nmgtk-1.0_1.2.6-0ubuntu0.16.04.4_amd64.deb GObject introspection data for libnm-gtk
gir1.2-packagekitglib-1.0_0.8.17-4ubuntu6~gcc5.4ubuntu1.4_amd64.deb GObject introspection data for the PackageKit GLib library
gir1.2-polkit-1.0_0.105-14.1ubuntu0.5_amd64.deb GObject introspection data for PolicyKit
gir1.2-poppler-0.18_0.41.0-0ubuntu1.14_amd64.deb GObject introspection data for poppler-glib
gir1.2-snapd-1_1.49-0ubuntu0.16.04.0_amd64.deb Typelib file for libsnapd-glib1
gir1.2-soup-2.4_2.52.2-1ubuntu0.3_amd64.deb GObject introspection data for the libsoup HTTP library
gir1.2-tracker-1.0_1.6.2-0ubuntu1.1_amd64.deb GObject introspection data for Tracker
gir1.2-unity-5.0_7.1.4+16.04.20180209.1-0ubuntu1_amd64.deb GObject introspection data for the Unity library
gir1.2-upowerglib-1.0_0.99.4-2ubuntu0.3_amd64.deb GObject introspection data for upower
gir1.2-webkit2-4.0_2.20.5-0ubuntu0.16.04.1_amd64.deb Web content engine library for GTK+ - GObject introspection data
git-core_2.7.4-0ubuntu1.7_all.deb fast, scalable, distributed revision control system (obsolete)
Advertisement
Advertisement