gdbserver_7.11.1-0ubuntu1~16.5_amd64.deb


Advertisement

Description

gdbserver - GNU Debugger (remote server)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main amd64
Package filename gdbserver_7.11.1-0ubuntu1~16.5_amd64.deb
Package name gdbserver
Package version 7.11.1
Package release 0ubuntu1~16.5
Package architecture amd64
Package type deb
Category devel
Homepage http://www.gnu.org/s/gdb/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 167.75 KB
Installed size 633.00 KB
GDB is a source-level debugger, capable of breaking programs at
any specific line, displaying variable values, and determining
where errors occurred. Currently, gdb supports C, C++, D,
Objective-C, Fortran, Java, OpenCL C, Pascal, assembly, Modula-2,
Go, and Ada. A must-have for any serious programmer.
This package contains gdbserver.  Install this to debug remotely
from another system where GDB is installed.

Alternatives

Package Version Architecture Repository
gdbserver_7.11.1-0ubuntu1~16.5_i386.deb 7.11.1 i386 Ubuntu Updates Main
gdbserver_7.11-0ubuntu1_i386.deb 7.11 i386 Ubuntu Main
gdbserver_7.11-0ubuntu1_amd64.deb 7.11 amd64 Ubuntu Main
gdbserver - - -

Requires

Name Value
libc6 >= 2.15

Replaces

Name Value
gdb << 7.0.1-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package gdbserver_7.11.1-0ubuntu1~16.5_amd64.deb
Source Package gdb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gdbserver deb package:
    # sudo apt-get install gdbserver

Files

Path
/usr/bin/gdbserver
/usr/lib/x86_64-linux-gnu/libinproctrace.so
/usr/share/doc/gdbserver/NEWS.Debian.gz
/usr/share/doc/gdbserver/README.gz
/usr/share/doc/gdbserver/changelog.Debian.gz
/usr/share/doc/gdbserver/copyright
/usr/share/man/man1/gdbserver.1.gz

Changelog

2017-06-09 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
gdb (7.11.1-0ubuntu1~16.5) xenial-security; urgency=medium
* SECURITY UPDATE: integer overflow in string_appends
- debian/patches/CVE-2016-2226.patch: check for overflow in
libiberty/cplus-dem.c, added xmalloc_failed to
gdb/common/common-utils.c.
- CVE-2016-2226
* SECURITY UPDATE: use-after-free vulberabilities
- debian/patches/CVE-2016-4487_4488.patch: set bsize and ksize in
libiberty/cplus-dem.c, added test to
libiberty/testsuite/demangle-expected.
- CVE-2016-4487
- CVE-2016-4488
* SECURITY UPDATE: integer overflow in gnu_special
- debian/patches/CVE-2016-4489.patch: handle case where consume_count
returns -1 in libiberty/cplus-dem.c.
- CVE-2016-4489
* SECURITY UPDATE: integer overflow after sanity checks
- debian/patches/CVE-2016-4490.patch: parse numbers as integer instead
of long in libiberty/cp-demangle.c, added test to
libiberty/testsuite/demangle-expected.
- CVE-2016-4490
* SECURITY UPDATE: denial of service via infinite recursion
- debian/patches/CVE-2016-4491-1.patch: limit recursion in
include/demangle.h, libiberty/cp-demangle.c, libiberty/cp-demint.c,
added test to libiberty/testsuite/demangle-expected. 
- debian/patches/CVE-2016-4491-2.patch: limit more recursion in
libiberty/cp-demangle.c.
- debian/patches/CVE-2016-4491-3.patch: initialize d_printing in
gdb/cp-name-parser.y, libiberty/cp-demangle.c.
- CVE-2016-4491
* SECURITY UPDATE: buffer overflow in do_type
- debian/patches/CVE-2016-4492_4493.patch: properly handle large values
and overflow in libiberty/cplus-dem.c, added test to
libiberty/testsuite/demangle-expected.
- CVE-2016-4492
- CVE-2016-4493
* SECURITY UPDATE: denial of service via infinite recursion
- debian/patches/CVE-2016-6131.patch: prevent infinite recursion in
libiberty/cplus-dem.c, added test to
libiberty/testsuite/demangle-expected.
- CVE-2016-6131
2016-06-02 - Matthias Klose <doko@ubuntu.com>
gdb (7.11.1-0ubuntu1~16.04) xenial-updates; urgency=medium
* SRU: LP: #1588066, backport 7.11.1 to 16.04 LTS.
2016-06-01 - Matthias Klose <doko@ubuntu.com>
gdb (7.11.1-0ubuntu1) yakkety; urgency=medium
* New upstream bug fix release.
- Fix PR gdb/19828, PR gdb/20045, PR gdb/18077, PR gdb/20039,
PR python/20037, PR remote/19840, PR gdb/19858, PR gdb/19829,
PR gdb/19676.
2016-02-24 - Matthias Klose <doko@ubuntu.com>
gdb (7.11-0ubuntu1) xenial; urgency=medium
* New upstream release.
2016-02-20 - Matthias Klose <doko@ubuntu.com>
gdb (7.10.90.20160220-0ubuntu1) xenial; urgency=medium
* Snapshot, taken from the gdb-7.11 branch.
* Build again the pdf docs with fixed texinfo.
* Fix OverflowError in backtrace command on 32bit kernels. LP: #1513922.
2016-02-15 - Matthias Klose <doko@ubuntu.com>
gdb (7.10.90.20160215-0ubuntu2) xenial; urgency=medium
* Don't build the pdf docs, broken with recent texinfo.
2016-02-15 - Matthias Klose <doko@ubuntu.com>
gdb (7.10.90.20160215-0ubuntu1) xenial; urgency=medium
* Snapshot, taken from the gdb-7.11 branch.
2016-01-16 - Matthias Klose <doko@ubuntu.com>
gdb (7.10.1-0ubuntu1) xenial; urgency=medium
* New upstream release.
2015-09-13 - Matthias Klose <doko@ubuntu.com>
gdb (7.10-1ubuntu2) wily; urgency=medium
* Fix build dependencies on i386 and powerpc for gdb64.

See Also

Package Description
geoclue-ubuntu-geoip_1.0.2+14.04.20131125-0ubuntu2.16.04.1_amd64.deb Provide positioning for GeoClue via Ubuntu GeoIP services
gettext-base_0.19.7-2ubuntu3.1_amd64.deb GNU Internationalization utilities for the base system
gettext-doc_0.19.7-2ubuntu3.1_all.deb Documentation for GNU gettext
gettext-el_0.19.7-2ubuntu3.1_all.deb Emacs po-mode for editing gettext .po files
gettext_0.19.7-2ubuntu3.1_amd64.deb GNU Internationalization utilities
gfortran-5-doc_5.4.0-6ubuntu1~16.04.12_all.deb Documentation for the GNU Fortran compiler (gfortran)
gfortran-5-multilib_5.4.0-6ubuntu1~16.04.12_amd64.deb GNU Fortran compiler (multilib support)
gfortran-5_5.4.0-6ubuntu1~16.04.12_amd64.deb GNU Fortran compiler
ghostscript-doc_9.26~dfsg+0-0ubuntu0.16.04.12_all.deb interpreter for the PostScript language and for PDF - Documentation
ghostscript-x_9.26~dfsg+0-0ubuntu0.16.04.12_amd64.deb interpreter for the PostScript language and for PDF - X11 support
ghostscript_9.26~dfsg+0-0ubuntu0.16.04.12_amd64.deb interpreter for the PostScript language and for PDF
giflib-tools_5.1.4-0.3~16.04.1_amd64.deb library for GIF images (utilities)
gir1.2-accountsservice-1.0_0.6.40-2ubuntu11.3_amd64.deb GObject introspection data for AccountService
gir1.2-appindicator-0.1_12.10.1+16.04.20170215-0ubuntu1_amd64.deb Typelib files for libappindicator1
gir1.2-appindicator3-0.1_12.10.1+16.04.20170215-0ubuntu1_amd64.deb Typelib files for libappindicator3-1
Advertisement
Advertisement