fwupd_0.8.3-0ubuntu5_amd64.deb


Advertisement

Description

fwupd - Firmware update daemon

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main amd64
Package filename fwupd_0.8.3-0ubuntu5_amd64.deb
Package name fwupd
Package version 0.8.3
Package release 0ubuntu5
Package architecture amd64
Package type deb
Category admin
Homepage https://github.com/hughsie/fwupd
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 117.09 KB
Installed size 728.00 KB
fwupd is a daemon to allow session software to update device firmware.
You can either use a GUI software manager like GNOME Software to view and
apply updates, the command-line tool or the system D-Bus interface directly.
Currently, firmware updates using the UEFI capsule format and for the
ColorHug are supported. More formats may be supported in the future.
See <https://github.com/hughsie/fwupd> for details

Alternatives

Package Version Architecture Repository
fwupd_0.8.3-0ubuntu5_i386.deb 0.8.3 i386 Ubuntu Updates Main
fwupd_0.7.0-0ubuntu4_i386.deb 0.7.0 i386 Ubuntu Main
fwupd_0.7.0-0ubuntu4_amd64.deb 0.7.0 amd64 Ubuntu Main
fwupd - - -

Requires

Name Value
libappstream-glib8 >= 0.5.13
libc6 >= 2.14
libcolorhug2 >= 1.2.12
libdfu1 >= 0.8.3
libefivar0 >= 0.23
libfwup0 -
libfwupd1 >= 0.8.3
libglib2.0-0 >= 2.45.8
libgpg-error0 >= 1.14
libgpgme11 >= 1.2.0
libgudev-1.0-0 >= 146
libgusb2 >= 0.2.9
libpolkit-gobject-1-0 >= 0.99
libsoup2.4-1 >= 2.41.90
libsqlite3-0 >= 3.5.9

Download

Type URL
Mirror archive.ubuntu.com
Binary Package fwupd_0.8.3-0ubuntu5_amd64.deb
Source Package fwupd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install fwupd deb package:
    # sudo apt-get install fwupd

Files

Path
/etc/fwupd.conf
/etc/dbus-1/system.d/org.freedesktop.fwupd.conf
/etc/pki/fwupd/GPG-KEY-Hughski-Limited
/etc/pki/fwupd/GPG-KEY-Linux-Vendor-Firmware-Service
/etc/pki/fwupd-metadata/GPG-KEY-Linux-Vendor-Firmware-Service
/lib/systemd/system/fwupd-offline-update.service
/lib/systemd/system/fwupd.service
/lib/systemd/system/system-update.target.wants/fwupd-offline-update.service
/lib/udev/rules.d/90-fwupd-devices.rules
/usr/bin/dfu-tool
/usr/bin/fwupdmgr
/usr/lib/x86_64-linux-gnu/fwupd/fwupd
/usr/lib/x86_64-linux-gnu/fwupd-plugins-2/libfu_plugin_altos.so
/usr/lib/x86_64-linux-gnu/fwupd-plugins-2/libfu_plugin_colorhug.so
/usr/lib/x86_64-linux-gnu/fwupd-plugins-2/libfu_plugin_dfu.so
/usr/lib/x86_64-linux-gnu/fwupd-plugins-2/libfu_plugin_ebitdo.so
/usr/lib/x86_64-linux-gnu/fwupd-plugins-2/libfu_plugin_raspberrypi.so
/usr/lib/x86_64-linux-gnu/fwupd-plugins-2/libfu_plugin_steelseries.so
/usr/lib/x86_64-linux-gnu/fwupd-plugins-2/libfu_plugin_test.so
/usr/lib/x86_64-linux-gnu/fwupd-plugins-2/libfu_plugin_udev.so
/usr/lib/x86_64-linux-gnu/fwupd-plugins-2/libfu_plugin_uefi.so
/usr/lib/x86_64-linux-gnu/fwupd-plugins-2/libfu_plugin_unifying.so
/usr/lib/x86_64-linux-gnu/fwupd-plugins-2/libfu_plugin_upower.so
/usr/lib/x86_64-linux-gnu/fwupd-plugins-2/libfu_plugin_usb.so
/usr/share/app-info/xmls/org.freedesktop.fwupd.xml
/usr/share/dbus-1/interfaces/org.freedesktop.fwupd.xml
/usr/share/dbus-1/system-services/org.freedesktop.fwupd.service
/usr/share/doc/fwupd/changelog.Debian.gz
/usr/share/doc/fwupd/copyright
/usr/share/man/man1/dfu-tool.1.gz
/usr/share/man/man1/fwupdmgr.1.gz
/usr/share/polkit-1/actions/org.freedesktop.fwupd.policy
/usr/share/polkit-1/rules.d/org.freedesktop.fwupd.rules
/var/lib/polkit-1/localauthority/10-vendor.d/fwupd.pkla

Changelog

2019-05-22 - Jian-Ding Chen <tim.chen119@canonical.com>
fwupd (0.8.3-0ubuntu5) xenial; urgency=medium
* debian/patches 0001-Raise-the-metadata-limit-to-10Mb.patch:
- Raise the metadata limit to 10Mb, fix XML mismatch error while fwupdmgr
refresh (LP: #1829813)
2018-08-16 - Mario Limonciello <mario.limonciello@dell.com>
fwupd (0.8.3-0ubuntu4) xenial; urgency=medium
* debian/patches 0001-Do-not-abort-startup-if-the-XML-metadata-file-is-inv.patch:
- Fix a crash from bad metadata (LP: #1780442)
2018-04-04 - Robert Ancell <robert.ancell@canonical.com>
fwupd (0.8.3-0ubuntu3) xenial; urgency=medium
* debian/patches/0001-Use-a-CNAME-to-redirect-to-the-correct-CDN-for-metad.patch:
- Change metadata server to upstream requested one (LP: #1761006)
2018-02-14 - Mario Limonciello <mario.limonciello@dell.com>
fwupd (0.8.3-0ubuntu2) xenial; urgency=medium
* Fix systemd unit for what is actually supported in
systemd 229 in xenial (LP: #1746114)
* This bug also fixes issues with USB devices being closed (LP: #1642812)
2018-01-29 - Mario Limonciello <mario.limonciello@dell.com>
fwupd (0.8.3-0ubuntu1) xenial; urgency=medium
* Move to upstream 0.8.x release branch. (LP: #1746114)
* Drop all patches integrated into this release.
* Refresh symbols
2016-08-11 - Mario Limonciello <mario_limonciello@dell.com>
fwupd (0.7.0-0ubuntu4.3) xenial-proposed; urgency=medium
* Download metadata from Amazon S3 instead. (LP: #1612365)
2016-06-08 - Mario Limonciello <mario_limonciello@dell.com>
fwupd (0.7.0-0ubuntu4.2) xenial-proposed; urgency=medium
* Fix USB audio devices not working properly (LP: #1574079)
2016-04-28 - Mario Limonciello <mario_limonciello@dell.com>
fwupd (0.7.0-0ubuntu4.1) xenial-proposed; urgency=medium
* Add name and summary to Rival Steelseries device (LP: #1575248)
2016-04-14 - Mario Limonciello <mario_limonciello@dell.com>
fwupd (0.7.0-0ubuntu4) xenial; urgency=medium
* Backport UEFI naming to DMI Product Name from master
2016-04-03 - Mario Limonciello <mario_limonciello@dell.com>
fwupd (0.7.0-0ubuntu3) xenial; urgency=medium
* Backport commits from upstream to fix problems on big endian.
* Drop extra patches that are no longer applied
* Require test suite passing on all architectures (LP: #1565114)

See Also

Package Description
fwupdate-signed_1.11.3+0.5-2ubuntu7_amd64.deb Linux Firmware Updater EFI signed binary
fwupdate_0.5-2ubuntu7_amd64.deb Tools to manage UEFI firmware updates
g++-5-aarch64-linux-gnu_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GNU C++ compiler
g++-5-arm-linux-gnueabihf_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GNU C++ compiler
g++-5-multilib_5.4.0-6ubuntu1~16.04.12_amd64.deb GNU C++ compiler (multilib support)
g++-5-powerpc-linux-gnu_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GNU C++ compiler
g++-5-powerpc64le-linux-gnu_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GNU C++ compiler
g++-5_5.4.0-6ubuntu1~16.04.12_amd64.deb GNU C++ compiler
gcc-5-aarch64-linux-gnu-base_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GCC, the GNU Compiler Collection (base package)
gcc-5-aarch64-linux-gnu_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GNU C compiler
gcc-5-arm-linux-gnueabihf-base_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GCC, the GNU Compiler Collection (base package)
gcc-5-arm-linux-gnueabihf_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GNU C compiler
gcc-5-base_5.4.0-6ubuntu1~16.04.12_amd64.deb GCC, the GNU Compiler Collection (base package)
gcc-5-cross-base_5.4.0-6ubuntu1~16.04.9cross1_all.deb GCC, the GNU Compiler Collection (library base package)
gcc-5-doc_5.4.0-6ubuntu1~16.04.12_all.deb Documentation for the GNU compilers (gcc, gobjc, g++)
Advertisement
Advertisement