freerdp-x11_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.3_amd64.deb


Advertisement

Description

freerdp-x11 - RDP client for Windows Terminal Services (X11 client)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main amd64
Package filename freerdp-x11_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.3_amd64.deb
Package name freerdp-x11
Package version 1.1.0~git20140921.1.440916e+dfsg1
Package release 5ubuntu1.3
Package architecture amd64
Package type deb
Category x11
Homepage http://www.freerdp.com/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 16.16 KB
Installed size 222.00 KB
FreeRDP is a libre client/server implementation of the Remote
Desktop Protocol (RDP).
Currently, the FreeRDP client supports the following Windows Versions:
* Windows NT Server
* Windows 2000 Terminal Server
* Windows XP
* Windows 2003 Server
* Windows Vista
* Windows 2008/2008r2/2011SBS Server
* Windows 7
* Windows 2012 Server
* Windows 8
This package contains the X11 based client.

Alternatives

Package Version Architecture Repository
freerdp-x11_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.3_i386.deb 1.1.0~git20140921.1.440916e+dfsg1 i386 Ubuntu Updates Main
freerdp-x11_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_i386.deb 1.1.0~git20140921.1.440916e+dfsg1 i386 Ubuntu Main
freerdp-x11_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1_amd64.deb 1.1.0~git20140921.1.440916e+dfsg1 amd64 Ubuntu Main
freerdp-x11 - - -

Requires

Name Value
libc6 >= 2.4
libfreerdp-client1.1 >= 1.1.0~beta1+git20130629
libwinpr-synch0.1 >= 1.1.0~beta1+git20130629
libwinpr-thread0.1 >= 1.1.0~beta1+git20130629
libxfreerdp-client1.1 >= 1.1.0~beta1+git20130629

Provides

Name Value
freerdp -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package freerdp-x11_1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.3_amd64.deb
Source Package freerdp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install freerdp-x11 deb package:
    # sudo apt-get install freerdp-x11

Files

Path
/usr/bin/xfreerdp
/usr/share/doc/freerdp-x11/README
/usr/share/doc/freerdp-x11/changelog.Debian.gz
/usr/share/doc/freerdp-x11/copyright
/usr/share/man/man1/xfreerdp.1.gz

Changelog

2018-12-11 - Alex Murray <alex.murray@canonical.com>
freerdp (1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.3) xenial-security; urgency=medium
* SECURITY UPDATE: Integer truncation in update_read_bitmap_update
- debian/patches/CVE-2018-8786.patch: Promote count to 32-bit integer
type to avoid integer truncation in libfreerdp/core/update.c. Based on
upstream patch.
- CVE-2018-8786
* SECURITY UPDATE: Integer overflow in gdi_Bitmap_Decompress
- debian/patches/CVE-2018-8787.patch: Check for and avoid possible
integer overflow in libfreerdp/gdi/graphics.c. Based on upstream
patch.
- CVE-2018-8787
* SECURITY UPDATE: Buffer overflow in nsc_rle_decode
- debian/patches/CVE-2018-8788.patch: Check for lengths and avoid
possible buffer overflow in libfreerdp/codec/nsc.c and
libfreerdp/codec/nsc_encode.c. Based on upstream patch.
- CVE-2018-8788
* SECURITY UPDATE: Out-of-bounds read in ntlm_read_message_fields_buffer
- debian/patches/CVE-2018-8789.patch: Ensure to use 64-bit integer
type when checking offset against stream length in
winpr/libwinpr/sspi/NTLM/ntlm_message.c. Based on upstream patch.
- CVE-2018-8789
2017-08-03 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
freerdp (1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.2) xenial-security; urgency=medium
* SECURITY UPDATE: integer overflow in license_read_scope_list
- debian/patches/CVE-2014-0791.patch: check length in
libfreerdp/core/license.c.
- CVE-2014-0791
* SECURITY UPDATE: multiple code execution and DoS issues
- debian/patches/CVE-2017-283x.patch: fix issues in
libfreerdp/core/capabilities.c, libfreerdp/core/certificate.*,
libfreerdp/core/connection.c, libfreerdp/core/gcc.c,
libfreerdp/core/info.c, libfreerdp/core/license.c,
libfreerdp/core/mcs.c, libfreerdp/core/nego.c,
libfreerdp/core/peer.c, libfreerdp/core/rdp.*,
libfreerdp/core/security.*, libfreerdp/core/surface.c,
libfreerdp/core/tpkt.*, libfreerdp/core/transport.c.
- CVE-2017-2834, CVE-2017-2835, CVE-2017-2836, CVE-2017-2837,
CVE-2017-2838, CVE-2017-2839
* debian/patches/alignment_test_failure.patch: fix FTBFS on armhf because
of failing alignment test.
2015-10-05 - Robert Ancell <robert.ancell@canonical.com>
freerdp (1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1) wily; urgency=medium
* Merge with Debian unstable, remaining changes
- Disable ffmpeg support
- Disable gstreamer support, this relies on gstreamer 0.10 and we don't
want to add any more deps on that.
2015-08-19 - Mike Gabriel <sunweaver@debian.org>
freerdp (1.1.0~git20140921.1.440916e+dfsg1-5) unstable; urgency=medium
* debian/patches:
+ Improve 1003_multi-arch-include-path.patch. Also make include dir in
freerdp.pc (pkgconfig) multi-arch compliant. (Closes: #790636).
+ Add 0004_build-cmake-3.1-compatibility.patch. Fix FTBFS with cmake 3.1.
(Closes: #788557). Thanks to Andreas Cadhalpun for helping out on this.
* debian/control:
+ Bump Standards: to 3.9.6. No changes needed.
2015-05-15 - Iain Lane <iain@orangesquash.org.uk>
freerdp (1.1.0~git20140921.1.440916e+dfsg1-4ubuntu1) wily; urgency=low
* Merge with Debian unstable, remaining changes
- Disable ffmpeg support
- Disable gstreamer support, this relies on gstreamer 0.10 and we don't
want to add any more deps on that.
2015-03-10 - Mike Gabriel <sunweaver@debian.org>
freerdp (1.1.0~git20140921.1.440916e+dfsg1-4) unstable; urgency=medium
* debian/patches:
+ Add 0002_handle-old-style-cmdline-options.patch. Command line detection
is run with dummy settings where not everything is allocated. Collections
(device, dynamic channel and static channel) didn't handle this case
properly. (Closes: #779312).
+ Add 0003_copy-data-when-adding-glyph-to-cache.patch. Copy data when adding
glyph to cache. Fix double free or corruption inupdate_gdi_fast_glyph ->
glyph_cache_put -> _int_free (Closes: #740637).

See Also

Package Description
friendly-recovery_0.2.31ubuntu2.1_all.deb Make recovery more user-friendly
fuse_2.9.4-1ubuntu3.1_amd64.deb Filesystem in Userspace
fwupd_0.8.3-0ubuntu5_amd64.deb Firmware update daemon
fwupdate-signed_1.11.3+0.5-2ubuntu7_amd64.deb Linux Firmware Updater EFI signed binary
fwupdate_0.5-2ubuntu7_amd64.deb Tools to manage UEFI firmware updates
g++-5-aarch64-linux-gnu_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GNU C++ compiler
g++-5-arm-linux-gnueabihf_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GNU C++ compiler
g++-5-multilib_5.4.0-6ubuntu1~16.04.12_amd64.deb GNU C++ compiler (multilib support)
g++-5-powerpc-linux-gnu_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GNU C++ compiler
g++-5-powerpc64le-linux-gnu_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GNU C++ compiler
g++-5_5.4.0-6ubuntu1~16.04.12_amd64.deb GNU C++ compiler
gcc-5-aarch64-linux-gnu-base_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GCC, the GNU Compiler Collection (base package)
gcc-5-aarch64-linux-gnu_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GNU C compiler
gcc-5-arm-linux-gnueabihf-base_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GCC, the GNU Compiler Collection (base package)
gcc-5-arm-linux-gnueabihf_5.4.0-6ubuntu1~16.04.9cross1_amd64.deb GNU C compiler
Advertisement
Advertisement