crash_7.2.3+real-1~16.04.1_amd64.deb


Advertisement

Description

crash - kernel debugging utility, allowing gdb like syntax

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Updates Main amd64
Package filename crash_7.2.3+real-1~16.04.1_amd64.deb
Package name crash
Package version 7.2.3+real
Package release 1~16.04.1
Package architecture amd64
Package type deb
Category utils
Homepage -
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 2.56 MB
Installed size 7.78 MB
The core analysis suite is a self-contained tool that can be used to
investigate either live systems, or multiple different core dump formats
including kdump, LKCD, netdump and diskdump.
o  The tool is loosely based on the SVR4 crash command, but has been
completely integrated with gdb in order to be able to display
formatted kernel data structures, disassemble source code, etc.
o  The current set of available commands consist of common kernel core
analysis tools such as a context-specific stack traces, source code
disassembly, kernel variable displays, memory display, dumps of
linked-lists, etc.  In addition, any gdb command may be entered,
which in turn will be passed onto the gdb module for execution.
o  There are several commands that delve deeper into specific kernel
subsystems, which also serve as templates for kernel developers
to create new commands for analysis of a specific area of interest.
Adding a new command is a simple affair, and a quick recompile
adds it to the command menu.
o  The intent is to make the tool independent of Linux version dependencies,
building in recognition of major kernel code changes so as to adapt to
new kernel versions, while maintaining backwards compatibility.

Alternatives

Package Version Architecture Repository
crash_7.2.3+real-1~16.04.1_i386.deb 7.2.3+real i386 Ubuntu Updates Main
crash_7.1.4-1ubuntu4_i386.deb 7.1.4 i386 Ubuntu Main
crash_7.1.4-1ubuntu4_amd64.deb 7.1.4 amd64 Ubuntu Main
crash - - -

Requires

Name Value
binutils -
libc6 >= 2.17
liblzo2-2 -
libncurses5 >= 6
libsnappy1v5 -
libtinfo5 >= 6
zlib1g >= 1:1.2.0

Download

Type URL
Mirror archive.ubuntu.com
Binary Package crash_7.2.3+real-1~16.04.1_amd64.deb
Source Package crash

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install crash deb package:
    # sudo apt-get install crash

Files

Path
/usr/bin/crash
/usr/include/crash/defs.h
/usr/lib/crash/extensions/dminfo.so
/usr/lib/crash/extensions/echo.so
/usr/lib/crash/extensions/snap.so
/usr/lib/crash/extensions/trace.so
/usr/share/doc/crash/README.gz
/usr/share/doc/crash/changelog.Debian.gz
/usr/share/doc/crash/copyright
/usr/share/man/man8/crash.8.gz

Changelog

2018-06-26 - Thadeu Lima de Souza Cascardo <cascardo@canonical.com>
crash (7.2.3+real-1~16.04.1) xenial; urgency=medium
* Backport to xenial. LP: #1746088
- Build-Depends on debhelper 9.
2018-06-22 - Troy Heber <troyh@debian.org>
crash (7.2.3+real-1) unstable; urgency=medium
* Revert wget addition and re-include embedded gdb (Closes: #901863)
2018-05-22 - Troy Heber <troyh@debian.org>
crash (7.2.3-2) unstable; urgency=medium
* Add wget as a builddep
2018-05-21 - Troy Heber <troyh@debian.org>
crash (7.2.3-1) unstable; urgency=medium
* Fix for a crash-7.2.2 regression that may cause the "mount" command to
generate a segmentation violation.  The bug is dependent upon the compiler
version used to build the crash utility, where a buffer overrun is not
seen with more recent versions of gcc, which hide the bug due to a
different stack layout of a function's local variables.
* Fix for a second crash-7.2.2 buffer overrun regression that may cause the
"rd -S" option to generate a segmentation violation if a displayed memory
location contains a slab object address.
* Fix for a third, highly unlikely, crash-7.2.2 buffer overrun regression,
that could potentially occur during session initialization.

See Also

Package Description
cryptsetup-bin_1.6.6-5ubuntu2.1_amd64.deb disk encryption support - command line tools
cryptsetup_1.6.6-5ubuntu2.1_amd64.deb disk encryption support - startup scripts
cups-browsed_1.8.3-2ubuntu3.5_amd64.deb OpenPrinting CUPS Filters - cups-browsed
cups-bsd_2.1.3-4ubuntu0.10_amd64.deb Common UNIX Printing System(tm) - BSD commands
cups-client_2.1.3-4ubuntu0.10_amd64.deb Common UNIX Printing System(tm) - client programs (SysV)
cups-common_2.1.3-4ubuntu0.10_all.deb Common UNIX Printing System(tm) - common files
cups-core-drivers_2.1.3-4ubuntu0.10_amd64.deb Common UNIX Printing System(tm) - PPD-less printing
cups-daemon_2.1.3-4ubuntu0.10_amd64.deb Common UNIX Printing System(tm) - daemon
cups-filters-core-drivers_1.8.3-2ubuntu3.5_amd64.deb OpenPrinting CUPS Filters - PPD-less printing
cups-filters_1.8.3-2ubuntu3.5_amd64.deb OpenPrinting CUPS Filters - Main Package
cups-ppdc_2.1.3-4ubuntu0.10_amd64.deb Common UNIX Printing System(tm) - PPD manipulation utilities
cups-server-common_2.1.3-4ubuntu0.10_all.deb Common UNIX Printing System(tm) - server common files
cups_2.1.3-4ubuntu0.10_amd64.deb Common UNIX Printing System(tm) - PPD/driver support, web interface
curl_7.47.0-1ubuntu2.14_amd64.deb command line tool for transferring data with URL syntax
curtin-common_19.1-7-g37a7a0f4-0ubuntu1~16.04.1_all.deb Library and tools for curtin installer
Advertisement
Advertisement