tweeper_0.4-1ubuntu1_all.deb


Advertisement

Description

tweeper - web scraper to convert supported websites (e.g. Twitter.com) to RSS

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name tweeper
Package version 0.4
Package release 1ubuntu1
Package architecture all
Package type deb
Installed size 66 B
Download size 12.26 KB
Official Mirror archive.ubuntu.com
tweeper is a web scraper which can be used to conveniently follow the
public activity of social network users without the need to log in or even be
subscribed to the social network; tweeper converts the public information to
RSS so that it can be accessed and collected by a feed reader.
tweeper started as the TWitter fEEd scraPER but support for other web sites
has been added.
The sites that tweeper is able to scrape and convert to RSS are:
* Twitter.com
* Pump.io based websites, like Identi.ca
* Dilbert.com
* Howtoons.com
* Instagram.com
* Facebook.com (public pages)
tweeper can be used as:
1. a command line tool;
2. a filter for feed readers;
3. a web based tool when used with a PHP-enabled web server.

Alternatives

Package Version Architecture Repository
tweeper_0.4-1ubuntu1_all.deb 0.4 all Ubuntu Universe
tweeper - - -

Requires

Name Value
php-cli -
php-curl -
php-xml-serializer -
php-xsl -

Download

Type URL
Binary Package tweeper_0.4-1ubuntu1_all.deb
Source Package tweeper

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install tweeper deb package:
    # sudo apt-get install tweeper

Files

Path
/usr/bin/tweeper
/usr/share/doc/tweeper/README
/usr/share/doc/tweeper/TODO
/usr/share/doc/tweeper/changelog.Debian.gz
/usr/share/doc/tweeper/copyright
/usr/share/man/man1/tweeper.1.gz
/usr/share/php/tweeper/rss_converter_dilbert.com.xsl
/usr/share/php/tweeper/rss_converter_facebook.com.xsl
/usr/share/php/tweeper/rss_converter_howtoons.com.xsl
/usr/share/php/tweeper/rss_converter_identi.ca.xsl
/usr/share/php/tweeper/rss_converter_instagram.com.xsl
/usr/share/php/tweeper/rss_converter_pump.io.xsl
/usr/share/php/tweeper/rss_converter_twitter.com.xsl
/usr/share/php/tweeper/tweeper
/usr/share/php/tweeper/tweeper.php

Changelog

2016-04-04 - Nishanth Aravamudan <nish.aravamudan@canonical.com>
tweeper (0.4-1ubuntu1) xenial; urgency=medium
* Update to PHP7.0 dependencies (LP: #1565894).
2015-09-13 - Antonio Ospite <ao2@ao2.it>
tweeper (0.4-1) unstable; urgency=medium
* New upstream release
* debian/control: update the package description
* debian/control: depend on php-xml-serializer
* debian/copyright: update copyright years
* debian/control: bump Standards-Version to 3.9.6
2014-04-24 - Antonio Ospite <ao2@ao2.it>
tweeper (0.3-1) unstable; urgency=medium
* New upstream release
* debian/copyright: update contact info and copyright years
* debian/patches: remove all patches, all have been applied upstream
* debian/control: mention that Howtoons.com is now supported
2014-02-12 - Antonio Ospite <ao2@ao2.it>
tweeper (0.2-3) unstable; urgency=medium
* debian/control: update Maintainer email address
* debian/patches: add a patch to support "audio/ogg" enclosures
* debian/control: add missing run-time dependencies.
Thanks to Anton Nesterov (Closes: #738201)
* debian/control: cosmetics remove trailing spaces
2013-11-20 - Antonio Ospite <ospite@studenti.unina.it>
tweeper (0.2-2) unstable; urgency=low
* debian/gbp.conf: explicitly disable pristine-tar.
Thanks to gregor herrmann <gregoa@debian.org>
* debian/control: bump Standards-Version to 3.9.5
* debian/rules: use $(CURDIR) instead of $$(pwd)
* debian/control: specify the debian package branch in Vcs-Git
* debian/patches: add a fix to the man page from upstream
* debian/rules: install the NEWS file as the upstream changelog
* debian/docs: package also the README and TODO files
* debian/control: suggest libapache2-mod-php5 or php5-cgi
* debian/control: reword some list items in the long description
* debian/patches: add a patch to fix the list items in the man page
2013-11-18 - Antonio Ospite <ospite@studenti.unina.it>
tweeper (0.2-1) unstable; urgency=low
* Initial release (Closes: #729858)

See Also

Package Description
twidge_1.1.2_i386.deb Unix Command-Line Twitter and Identica Client
twiggy_0.1025+dfsg-1_all.deb AnyEvent HTTP server for PSGI (like Thin)
twine_1.5.0-1_all.deb utility for interacting with PyPI
twinkle_1.9.0+dfsg-3_i386.deb Voice over Internet Protocol (VoIP) SIP Phone
twitter-recess_1.1.9-1_all.deb code quality tool for CSS built on top of LESS
twittering-mode_3.0.0-1_all.deb Twitter client for Emacs
twm_1.0.9-1ubuntu1_i386.deb Tab window manager
twms_0.05t-2_all.deb tiny web map service
twoftpd-run_1.42-1_all.deb a simple secure efficient FTP server
twoftpd_1.42-1_i386.deb a simple secure efficient FTP server (programs)
twolame_0.3.13-1.2_i386.deb MPEG Audio Layer 2 encoder (command line frontend)
tworld-data_1.3.2-2_all.deb Chip's Challenge Game Engine Emulation - level data files
tworld_1.3.2-2_i386.deb Chip's Challenge Game Engine Emulation
twpsk_4.1-1_i386.deb Soundcard-based X program for operating PSK31
txt2html_2.51-1_all.deb Text to HTML converter
Advertisement
Advertisement