timblserver_1.8-1.1_i386.deb


Advertisement

Description

timblserver - Server extensions for Timbl

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: timblserver
Package version: 1.8
Package release: 1.1
Package architecture: i386
Package type: deb
Installed size: 142 B
Download size: 40.83 KB
Official Mirror: archive.ubuntu.com
timblserver is a TiMBL wrapper; it adds server functionality to TiMBL. It allows TiMBL to run multiple experiments as a TCP server, optionally via HTTP. The Tilburg Memory Based Learner, TiMBL, is a tool for Natural Language Processing research, and for many other domains where classification tasks are learned from examples. TimblServer is a product of the ILK Research Group (Tilburg University, The Netherlands) and the CLiPS Research Centre (University of Antwerp, Belgium). If you do scientific research in NLP, TimblServer will likely be of use to you.

Alternatives

    Download

    Source package: timblserver

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install timblserver deb package:
      # sudo apt-get install timblserver

    Files

    • /usr/bin/timblclient
    • /usr/bin/timblserver
    • /usr/share/doc/timblserver/AUTHORS
    • /usr/share/doc/timblserver/NEWS.gz
    • /usr/share/doc/timblserver/README
    • /usr/share/doc/timblserver/TODO
    • /usr/share/doc/timblserver/changelog.Debian.gz
    • /usr/share/doc/timblserver/copyright
    • /usr/share/man/man1/timblclient.1.gz
    • /usr/share/man/man1/timblserver.1.gz

    Changelog

    2016-01-30 - Andreas Beckmann <anbe@debian.org> timblserver (1.8-1.1) unstable; urgency=medium * Non-maintainer upload. * Use dh_autoreconf. (Closes: #752795) * libtimblserver4-dev: Add Provides: libtimblserver-dev to ease future transitions. * Upload to unstable.

    2015-06-15 - Joost van Baal-Ilić <joostvb@debian.org> timblserver (1.8-1) experimental; urgency=low * New upstream release. - Fixes "timblserver: FTBFS in unstable: error: 'class Timbl::GetOptClass' has no member named 'getLogFile'. Thanks James Cowgill for reporting. (Closes: #775850) - debian/control: change Build-Depends libticcutils2-dev from >= 0.3 to >= 0.7. * debian/control: migrated version control from Subversion to git (still on Debian's Alioth). Thanks Jeremy T. Bouse. - change obsolete SVN Id and URL tags in files to git information. * debian/control: explicitly list automake as Build-Depends. * .gitignore: added: do not track generated files. * We ship libtimblserver4, not libtimblserver3: - debian/{libtimblserver2-dev,libtimblserver2}.install: removed, we ship libtimblserver4. - debian/libtimblserver*.install: renamed {libtimblserver3-dev,libtimblserver3}.install to {libtimblserver4-dev,libtimblserver4}.install. - debian/libtimblserver4.install: do not install /usr/lib/libtimblserver.so.3*, do install /usr/lib/libtimblserver.so.4* - debian/control: binary package timblserver no longer depends upon libtimblserver3 but upon libtimblserver4. * debian/control: Standards-Version upgraded from policy 3.9.4 to 3.9.6 (no other changes needed). * debian/NEWS: removed since did not contain any news worthy items.

    2013-09-08 - Joost van Baal-Ilić <joostvb@debian.org> timblserver (1.7-4) unstable; urgency=low * debian/control: change Build-Depends "libtimbl4-dev | libtimbl-dev" in "libtimbl4-dev": on second thought, we decided not to go for unversioned libtimbl-dev. See also Bug#718503: "release.debian.org: transition: timbl". * debian/control: change Build-Depends "libticcutils2-dev | libticcutils-dev" in "libticcutils2-dev (>=0.3)": on second thought, we decided not to go for unversioned libticcutils-dev. See also Bug#718501: "release.debian.org: transition: ticcutils". * debian/libtimblserver3-dev.install, debian/libtimblserver-dev.install, debian/control: rename libtimblserver-dev to libtimblserver3-dev. Upstream cannot guarantee strong compatibility yet. This fixes (part of) "mbtserver: FTBFS: unsatisfiable build-dependencies: libtimblserver3-dev, libmbt1-dev". Thanks Lucas Nussbaum (Closes: #713119). It fixes "Bug#721495: mbtserver: Wrong order of build-depends". Thanks Kurt Roeckx (Closes: #721495). * debian/control: Standards-Version upgraded from policy 3.9.3 to 3.9.4 (no other changes needed: section 8.6 is mostly not applicable to us: we keep using shlibs files, not symbols, since we build from C++ sources). * debian/watch: make sure no longer matches "*-latest.tar.gz", thanks Bart Martens.

    2013-06-15 - Joost van Baal-Ilić <joostvb@debian.org> timblserver (1.7-3) unstable; urgency=low * debian/libtimblserver-dev.install, debian/libtimblserver3-dev.install, debian/control: rename libtimblserver3-dev to unversioned libtimblserver-dev. * debian/control: change Build-Depends "libtimbl4-dev, libticcutils2-dev" to "libtimbl4-dev | libtimbl-dev, libticcutils2-dev | libticcutils-dev": prepare for upcoming unversioned -dev packages.

    2013-04-18 - Ko van der Sloot <ko.vandersloot@uvt.nl> timblserver (1.7-2) unstable; urgency=low * debian/control: added Conflicts: libtimblserver2-dev and Replaces: libtimblserver2-dev.

    2013-04-04 - Ko van der Sloot <ko.vandersloot@uvt.nl> timblserver (1.7-1) unstable; urgency=low * New Upstream Release. * debian/control: now we depend on libtimbl4{-dev} and libticcutils2-dev. * debian/libtimblserver3{-dev}.install: new files.

    Advertisement
    Advertisement