syslog-ng_3.5.6-2.1_all.deb


Advertisement

Description

syslog-ng - Enhanced system logging daemon (metapackage)

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: syslog-ng
Package version: 3.5.6
Package release: 2.1
Package architecture: all
Package type: deb
Installed size: 41 B
Download size: 4.35 KB
Official Mirror: archive.ubuntu.com
syslog-ng is an enhanced log daemon, supporting a wide range of input and output methods: syslog, unstructured text, message queues, databases (SQL and NoSQL alike) and more. Key features: * receive and send RFC3164 and RFC5424 style syslog messages * work with any kind of unstructured data * receive and send JSON formatted messages * classify and structure logs with builtin parsers (csv-parser(), db-parser(), etc.) * normalize, crunch and process logs as they flow through the system * hand on messages for further processing using message queues (like AMQP), files or databases (like PostgreSQL or MongoDB). This package is a metapackage, depending on the rest of syslog-ng, including all available plugins. It can be safely removed, if only parts of syslog-ng need to be installed.

Alternatives

    Download

    Source package: syslog-ng

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install syslog-ng deb package:
      # sudo apt-get install syslog-ng

    Files

    • /usr/share/doc/syslog-ng/changelog.Debian.gz
    • /usr/share/doc/syslog-ng/copyright

    Changelog

    2015-09-08 - Michael Biebl <biebl@debian.org> syslog-ng (3.5.6-2.1) unstable; urgency=medium * Non-maintainer upload. * Build against libsystemd-dev. (Closes: #779765)

    2014-08-13 - Gergely Nagy <algernon@madhouse-project.org> syslog-ng (3.5.6-2) unstable; urgency=high [ Gergely Nagy <algernon@madhouse-project.org> ] * Use dh_installinit --restart-after-upgrade instead of hand-coding essentially the same thing, badly. * Urgency high, as this moderates the effect of #757903.

    2014-08-11 - Gergely Nagy <algernon@madhouse-project.org> syslog-ng (3.5.6-1) unstable; urgency=high [ Gergely Nagy <algernon@madhouse-project.org> ] * New upstream release, fixing a major memory leak (thus the urgency) * Loosen the shlibs dependency on syslog-ng-core, so that syslog-ng-incubator need not be rebuilt for every single syslog-ng upload. * Fixed a typo in debian/rules.

    2014-07-26 - Gergely Nagy <algernon@madhouse-project.org> syslog-ng (3.5.5-2) unstable; urgency=high [ Gergely Nagy <algernon@madhouse-project.org> ] * Explicitly disable linux capability support on non-linux platforms, instead of relying on auto-detection (which doesn't always work).

    2014-07-23 - Gergely Nagy <algernon@madhouse-project.org> syslog-ng (3.5.5-1) unstable; urgency=high [ Gergely Nagy <algernon@madhouse-project.org> ] * New upstream release, fixing major leaks (hence the urgency) * Build-Depend on libjson-c-dev | libjson0-dev. (Closes: #745014) * Add /var/log/error to the logrotate file. (Closes: #747020) * Include libsyslog-ng-test.a and the related pkg-config file in the syslog-ng-dev package. * Added an upstart init script (mostly for the benefit of older Ubuntu releases and backports). * syslog-ng-mod-redis no longer (mistakenly) recommends geoip-database.

    2014-03-19 - Gergely Nagy <algernon@madhouse-project.org> syslog-ng (3.5.4.1-1) unstable; urgency=medium [ Gergely Nagy <algernon@madhouse-project.org> ] * New upstream release. * Handle the shlibs file correctly, and install it to the syslog-ng-core package.

    2013-12-25 - Gergely Nagy <algernon@madhouse-project.org> syslog-ng (3.5.3-1) unstable; urgency=medium [ Gergely Nagy <algernon@madhouse-project.org> ] * New upstream release. + Based on 3.5/master, which includes a couple of bison3 fixes.

    2013-12-02 - Gergely Nagy <algernon@madhouse-project.org> syslog-ng (3.5.2-1) unstable; urgency=high [ Gergely Nagy <algernon@madhouse-project.org> ] * New upstream release. + Fix the system() source on older Linux kernels (Closes: #729991) + Fix kernel timestamp computation on 32-bit systems (Closes: #729575) * Added a missing GPL-2+ license block to debian/copyright. * Correctly install the pkg-config file to /usr/lib/pkgconfig. * Updated the Vcs-* fields to point to debian.org resources. * Updated the package descriptions to be more similar to the upstream one. * Urgency set to high, due to the RC bugfix on 32-bit architectures.

    Advertisement
    Advertisement