swath_0.5.3-1_i386.deb


Advertisement

Description

swath - Thai word segmentation program

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: swath
Package version: 0.5.3
Package release: 1
Package architecture: i386
Package type: deb
Installed size: 637 B
Download size: 145.92 KB
Official Mirror: archive.ubuntu.com
Swath is a general-purpose utility for analyzing word boundaries in Thai text and inserting predefined word delimiter codes. It can be used as a filter for Thai LaTeX files so the lines are wrapped properly when processed with babel-thai macros. Other formats that swath can also handle include HTML, RTF and plain text.

Alternatives

    Download

    Binary package: swath_0.5.3-1_i386.deb
    Source package: swath

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install swath deb package:
      # sudo apt-get install swath

    Files

    • /usr/bin/swath
    • /usr/share/doc/swath/NEWS.gz
    • /usr/share/doc/swath/README
    • /usr/share/doc/swath/changelog.Debian.gz
    • /usr/share/doc/swath/copyright
    • /usr/share/man/man1/swath.1.gz
    • /usr/share/swath/swathdic.tri

    Changelog

    2014-09-01 - Theppitak Karoonboonyanan <thep@debian.org> swath (0.5.3-1) unstable; urgency=medium * Imported Upstream version 0.5.3 * debian/copyright: Update years & upstream contact * Replace thailatex with babel-thai in package description

    2013-12-23 - Theppitak Karoonboonyanan <thep@debian.org> swath (0.5.2-1) unstable; urgency=medium * Imported Upstream version 0.5.2 * Drop explicit rules for xz compression dpkg-dev (>= 1.17.0) does this by default. * Drop versioned B-Dep on libdatrie-dev. Even squeeze version already satisfies it.

    2013-10-30 - Theppitak Karoonboonyanan <thep@debian.org> swath (0.5.1-1) unstable; urgency=low * Use canonical anonscm URIs in Vcs-* fields. * Imported Upstream version 0.5.1 * Bump Standards-Version to 3.9.5 (no changes needed)

    2013-05-10 - Theppitak Karoonboonyanan <thep@debian.org> swath (0.5.0-2) unstable; urgency=low * Upload to unstable.

    2013-02-11 - Theppitak Karoonboonyanan <thep@debian.org> swath (0.5.0-1) experimental; urgency=low * Imported Upstream version 0.5.0 * Drop patches taken from upstream * debian/copyright: Update years. * Watch upstream *.tar.xz instead of *.tar.gz. * Bump Standards-Version to 3.9.4 (no changes needed)

    2013-01-16 - Theppitak Karoonboonyanan <thep@debian.org> swath (0.4.3-3) unstable; urgency=medium * Urgency medium for security fix. * debian/patches/01_buffer-overflow.patch: backport patch from upstream to fix potential buffer overflow in Mule mode. Thanks Dominik Maier for the report. (Closes: #698189)

    2012-08-10 - Theppitak Karoonboonyanan <thep@debian.org> swath (0.4.3-2) unstable; urgency=low * Build with xz compression.

    2012-06-13 - Theppitak Karoonboonyanan <thep@debian.org> swath (0.4.3-1) unstable; urgency=low * Bump Standards-Version to 3.9.3 with changes - Update debian/copyright Format: URL to 'packaging-manuals' one. * Imported Upstream version 0.4.3 * debian/copyright: Fix duplicate Copyright fields [lintian]

    2012-02-08 - Theppitak Karoonboonyanan <thep@debian.org> swath (0.4.2-1) unstable; urgency=low * B-Dep on dpkg-dev 1.16.1, not 0.16.1. * Imported Upstream version 0.4.2 * Build-dep on debhelper >= 9 and drop the lintian override * Update copyright years

    2011-12-23 - Theppitak Karoonboonyanan <thep@debian.org> swath (0.4.1-3) unstable; urgency=low * Packaging moved to alioth, update Vcs-* accordingly * debian/control: Apply wrap-and-sort * Point Homepage to the dedicated page for SWATH * Suggest libthai-data, which can provide alternative dictionary

    Advertisement
    Advertisement