stompserver_0.9.9gem-3build1_all.deb


Advertisement

Description

stompserver - stomp messaging server implemented in Ruby

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: stompserver
Package version: 0.9.9gem
Package release: 3build1
Package architecture: all
Package type: deb
Installed size: 168 B
Download size: 22.61 KB
Official Mirror: archive.ubuntu.com
Stompserver is a stomp messaging server with support for multiple FIFO based queue backends including file, dbm, memory and activerecord. It supports basic authentication and queue monitoring.

Alternatives

    Download

    Source package: stompserver

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install stompserver deb package:
      # sudo apt-get install stompserver

    Files

    • /etc/init.d/stompserver
    • /etc/logrotate.d/stompserver
    • /etc/stompserver/stompserver.conf
    • /usr/bin/stompserver
    • /usr/lib/ruby/vendor_ruby/stomp_server.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/queue.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/queue_manager.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/stomp_auth.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/stomp_frame.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/stomp_id.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/stomp_user.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/test_server.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/topic_manager.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/protocols/http.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/protocols/stomp.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/queue/activerecord_queue.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/queue/ar_message.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/queue/dbm_queue.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/queue/file_queue.rb
    • /usr/lib/ruby/vendor_ruby/stomp_server/queue/memory_queue.rb
    • /usr/share/doc/stompserver/README.txt.gz
    • /usr/share/doc/stompserver/changelog.Debian.gz
    • /usr/share/doc/stompserver/copyright
    • /usr/share/doc/stompserver/examples/passwd.example
    • /usr/share/doc/stompserver/examples/stompserver.conf
    • /usr/share/man/man1/stompserver.1.gz
    • /usr/share/rubygems-integration/all/specifications/stompserver-0.9.9.gemspec

    Changelog

    2014-04-30 - Matthias Klose <doko@ubuntu.com> stompserver (0.9.9gem-3build1) utopic; urgency=medium * No-change rebuild to update the Ruby-Version attribute.

    2013-11-30 - Jonas Genannt <jonas.genannt@capi2name.de> stompserver (0.9.9gem-3) unstable; urgency=low * Team upload. [ Cédric Boutillier ] * debian/control: remove obsolete DM-Upload-Allowed flag * use canonical URI in Vcs-* fields [ Jonas Genannt ] * d/control: - bumped standards version to 3.9.5 - README.source no longer needed - changed ruby1.8 dependency to ruby | ruby-interpreter - changed Ruby-Versions to all * ruby_hashbang.patch: refreshed from upstream, added DEP-3 header (changed ruby1.8 into env ruby) * added patch for Ruby 1.9/2.0 support from Upstream (Closes: #730880) * d/stompserver.init updated init script - added DIETIME/STARTTIME (Closes: #576452) - updated status to lsb init function - added source of default/stompserver (LP: #704687)

    2012-06-26 - Paul van Tilburg <paulvt@debian.org> stompserver (0.9.9gem-2) unstable; urgency=low * Bumped build-dependency on gem2deb to >= 0.3.0~.

    2012-05-26 - Paul van Tilburg <paulvt@debian.org> stompserver (0.9.9gem-1) unstable; urgency=low * Use upstream source from the gem rather than RubyForge.

    2012-05-25 - Paul van Tilburg <paulvt@debian.org> stompserver (0.9.9-2) unstable; urgency=low * Source packages adapted according to the new Ruby policy: - Build for Ruby 1.8 only; there is no support for Ruby 1.9.1. - Migrated to pkg-ruby-extras git repos. Changed the Vcs-* fields in debian/control accordingly. - Changed the depends to follow the new Ruby library naming scheme. * debian/control: - Added a default DM-Upload-Allowed field set to yes. - Standards-Version bumped to 3.9.3; no changes required. - Set XS-Ruby-Versions to ruby1.8. - Changed the build-depends for using gem2deb instead of ruby-pkg-tools. - Switched the maintainer with the uploaders field as per new convention the team is the default maintainer. * debian/copyright: reworked to fit the Debian copyright format version 1.0. * debian/patches: refreshed patches to removed fuzz. * debian/watch: updated to use gemwatch instead Rubyforge. * debian/stompserver.init - Depend on $remote_fs instead of $local_fs. - Added a description.

    2009-08-13 - Joshua Timberman <joshua@opscode.com> stompserver (0.9.9-1) unstable; urgency=low * Initial release (Closes: #537410)

    Advertisement
    Advertisement