sqlformat_0.1.18-1_all.deb


Advertisement

Description

sqlformat - SQL formatting utility

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: sqlformat
Package version: 0.1.18
Package release: 1
Package architecture: all
Package type: deb
Installed size: 21 B
Download size: 4.97 KB
Official Mirror: archive.ubuntu.com
The sqlformat command-line tool can be used to reformat SQL file according to specified options or prepare a snippet in some programming language (only Python and PHP currently supported).

Alternatives

    Download

    Source package: sqlparse

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install sqlformat deb package:
      # sudo apt-get install sqlformat

    Files

    • /usr/bin/sqlformat
    • /usr/share/doc/sqlformat/changelog.Debian.gz
    • /usr/share/doc/sqlformat/copyright
    • /usr/share/man/man1/sqlformat.1.gz

    Changelog

    2015-11-04 - Andriy Senkovych <jolly_roger@itblog.org.ua> sqlparse (0.1.18-1) unstable; urgency=low * New upstream release. * Source tarballs are now signed correctly again.

    2015-09-20 - Andriy Senkovych <jolly_roger@itblog.org.ua> sqlparse (0.1.16-1) unstable; urgency=medium * New upstream release (Closes: #794452) * Update project homepage and copyright source URLs. * Use pypi.debian.net for debian/watch. * Raise dh compat level to 9 * Remove unnecessary dependencies on self * Update short license names

    2014-10-24 - Andriy Senkovych <jolly_roger@itblog.org.ua> sqlparse (0.1.13-2) unstable; urgency=medium * Update debian/watch. * Add autopkgtest support.

    2014-10-09 - Andriy Senkovych <jolly_roger@itblog.org.ua> sqlparse (0.1.13-1) unstable; urgency=medium * New upstream release. * Bump Standards-Version to 3.9.6. No changes required. * Correctly remove alternatives for old package versions.

    2014-08-06 - Andriy Senkovych <jolly_roger@itblog.org.ua> sqlparse (0.1.11-1) unstable; urgency=medium * New upstream release * Add pypy support by creating pypy-sqlparse binary package * Add separate sqlformat package which depends on python3-sqlparse * Do not use alternatives mechanism any more since sqlformat scripts provide the same functionality. * Bump Standards-Version to 3.9.5.0. No changes required.

    2013-10-23 - Andriy Senkovych <jolly_roger@itblog.org.ua> sqlparse (0.1.10-1) unstable; urgency=low * New upstream release(Closes: #722198) * Switch to pybuild * debian/control: - Build-Depend on dh-python - Fix package descriptions

    2013-08-07 - Andriy Senkovych <jolly_roger@itblog.org.ua> sqlparse (0.1.8-1) unstable; urgency=low [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. [ Andriy Senkovych ] * New upstream release * Upload to unstable * Add replaces/breaks relation to make separate sqlparse upgrade smoothly (Closes: #717972) * Bump Standards-Version to 3.9.4. Create empty build-arch target.

    2013-03-08 - Andriy Senkovych <jolly_roger@itblog.org.ua> sqlparse (0.1.6-1) experimental; urgency=low * New upstream version. (Closes: #702197, #677982) * Bump Standards-Version to 3.9.4. No changes required. * debian/copyright: new contributor added. * Add python3 support using automatic 2to3 conversion. * Move documentation to its own package python-sqlparse-doc. * Add dependency on python-setuptools, python-pytest. * Use alternatives mechanism to provide /usr/bin/sqlformat. * Update project homepage and debian/watch.

    2012-04-21 - Andriy Senkovych <jolly_roger@itblog.org.ua> sqlparse (0.1.4-1) unstable; urgency=low * New upstream version.

    2012-02-27 - Andriy Senkovych <jolly_roger@itblog.org.ua> sqlparse (0.1.3-2) unstable; urgency=low [ Jakub Wilk ] * Bump minimum required python-sphinx version to 1.0.7+dfsg. [ Andriy Senkovych ] * Bump Standards-Version to 3.9.3. * Add doc-base documentation reference.

    Advertisement
    Advertisement