split-select_6.0.1+r16-1_i386.deb


Advertisement

Description

split-select - APK split and selection tool

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: split-select
Package version: 6.0.1+r16
Package release: 1
Package architecture: i386
Package type: deb
Installed size: 99 B
Download size: 28.70 KB
Official Mirror: archive.ubuntu.com
Generates the logic for selecting a Split APK given some target Android device configuration. Using the flag --generate will emit a JSON encoded tree of rules that must be satisfied in order to install the given Split APK. Using the flag --target along with the device configuration will emit the set of Split APKs to install, following the same logic that would have been emitted

Alternatives

    Download

    Source package: android-platform-frameworks-base

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install split-select deb package:
      # sudo apt-get install split-select

    Files

    • /usr/bin/split-select
    • /usr/lib/android-sdk/build-tools/23.0.2/split-select
    • /usr/share/doc/split-select/changelog.Debian.gz
    • /usr/share/doc/split-select/copyright
    • /usr/share/lintian/overrides/split-select
    • /usr/share/man/man1/split-select.1.gz

    Changelog

    2016-02-17 - Kai-Chung Yan <seamlikok@gmail.com> android-platform-frameworks-base (1:6.0.1+r16-1) unstable; urgency=medium * New upstream release - d/rules: Update BUILD_TOOLS_VERSION to 23.0.2 * d/copyright: Exclude more useless files to reduce tarball size * Use aapt.bash-completion for installing bash-completion

    2016-02-09 - Kai-Chung Yan <seamlikok@gmail.com> android-platform-frameworks-base (1:6.0.0+r26-3) unstable; urgency=medium * d/control: - Do not use ${binary:Version} on external packages - Remove libunwind from B-D as unnecessary

    2016-02-07 - Kai-Chung Yan <seamlikok@gmail.com> android-platform-frameworks-base (1:6.0.0+r26-2) unstable; urgency=medium * d/split-select.1.md: Fix syntax error * d/libandroidfw.mk: Add "-Wl,-rpath=/usr/lib/android" to LDFLAGS * d/copyright: Include more upstream files for building the Android Frameworks * d/control: Add android-libunwind (>= 6) to B-D for solving the build failure

    2016-02-05 - Kai-Chung Yan <seamlikok@gmail.com> android-platform-frameworks-base (1:6.0.0+r26-1) experimental; urgency=medium * New upstream release * Change version scheme to follow Android release tags * get-orig-source rule in d/rules for generating upstream tarballs * Install executables to faked SDK home * Makefiles independent from Quilt * New package: aidl, split-select, android-libaapt * Use makefiles for generating library symlinks * Add lintian-overrides for binary-or-shlib-defines-rpath * New manpages for aidl, split-select * Update d/copyright * d/control: - Add myself to Uploaders - Change architecture to amd64 & i386 - Change priority to optional - Change Build-Depends: - libpng12-dev => libpng-dev - libexpat1-dev => libexpat-dev - Add android-platform-build-headers - All Build-Depends on AOSP packages >= 1:6.0.0 - Fix Vcs-Git - Use HTTPS for Vcs URLs - Standards-Version => 3.9.7 (No change) * New patches: - aapt_Images_cpp_Res_png_9patch.diff: Fix API usage mistake - fix_aidl_typo.diff - aapt_typo.diff

    2014-12-02 - Hans-Christoph Steiner <hans@eds.org> android-platform-frameworks-base (21-2) unstable; urgency=low * add versions to shlibs so dh can do dep detection (Closes: #768821) (Closes: #769236) * set Android Tools team as Maintainer * fix installation of aapt bash completion rules

    2014-09-30 - Hans-Christoph Steiner <hans@eds.org> android-platform-frameworks-base (21-1) unstable; urgency=low * Initial release (Closes: #763571)

    Advertisement
    Advertisement